A valid PostgreSQL CMS connection could not be established

When I am starting Daz3d, I am getting a message that "A valid PostgreSQL CMS connection could not be established......."

When I try to log in inside of Daz, I get a similar message. I don't know what may have happened, I don't think I changed anything in my system, I turned off Firewall on my Mac. A weel ago everything worked just fine.

NOne of my content is showing up anymore.

Thanks for any help!



Screen Shot 2019-08-02 at 8.51.28 AM.png
412 x 183 - 21K
Screen Shot 2019-08-02 at 8.49.51 AM.png
409 x 239 - 30K


  • ElliandraElliandra Posts: 217

    You may just need to uninstall and reinstall it. I have that happen as well and that's what I usually do. If you do a search for CMS in DIM you can do it rather quickly wink

  • That did it! Thank you!


  • SuSoleilSuSoleil Posts: 85
    edited August 2019

    Well, it didn't do it for me. I had the same thing happen. It's been working fine for years. I changed nothing. From one day to the next, it went from no problems to the same error message  Anne shows above. I uninstalled PostgreSQL and reinstalled it. Didn't help. I changed the port, as suggested. It didn't help. I uninstalled Daz Studio and reinstalled it -- nothing worked. I did all this using DIM. Then, following Serene Night's suggestion on another thread, I tried reinstalling PostgreSQL manually. That didn't work either. It kept presenting a message, asking me to "Please exit all applications using PostgreSQL CMS to continue." Problem was, I had no programs open that used that software. Very frustrating. The only good thing about this is that it might finally force me to stop spending so much time and money on DAZ. And yes, I've opened a ticket and no, so far, no help there, either.

    Post edited by SuSoleil on
  • SuSoleilSuSoleil Posts: 85
    edited August 2019

    I can't believe it. I got it to work. For now. I went back into Daz for the umpteenth time and changed the port configuration AGAIN. This time, back to the original port number, which was 1024. One of the old BitRock installers immediately popped up, offering to "reinstall" the PortgreSQL CMS files (which I had just reinstalled, using DIM). I thought, "Why not?" It then went to work, unpacking and reinstalling with the blue progress bar as in the "olden" days. Daz then showed my products, but did not log me in, and would not let me log in. I had to again close out of Daz and restart the program. When it restarted, the program logged me in, and the Available Products tab had updated. Whew! I'm still aggravated, but relieved. Sorry to sound so grumpy, but instances like this was a wake-up call to how some idiosyncratic software can bar access to thousands of dollars in digital content.

    Post edited by SuSoleil on
Sign In or Register to comment.