Camera framerate [4.11.0.366]

saphirxsaphirx Posts: 6

Having an issue where parenting an object onto a camera, and then trying to look around with said camera in Iray (viewport), lowers the framerate massively.

A similar thing happens when I enable headlight on the camera.

Happens in freshly made scenes (say, a basic G8 model + camera + the primitive parented to the camera)

Here's what I do:

1. create a camera (Camera 1)

2. create a primitive object (doesn't matter which type)

3. parent primitive object to camera

4. switch from Perspective view to Camera 1

5. enable Iray in the viewport

Had this problem for years at this point. Recently formatted to Windows 10 and reinstalled DAZ multiple times. The issue is still around. Recall using the headlight frequently in past projects just fine (with Iray), but nowadays its quite the hurdle to work with.

Using GPU only for rendering. Enabling CPU/tinkering with devices in general doesn't fix it

Tried changing up OpenGL/viewport settings at Edit>Preferences>Interface, no results

Adjusted my NVIDIA settings so that DAZ will use my 1080 (it already did but worth a shot)... did not fix it.

Unparenting the primitive immediately resolves the issue. Not preferable solution. I would like to use headlights and primitives with my camera (lets me do neat coloring/lighting stuff one may do post-render.)

Disabling Iray in the viewport and using for example texture shaded does not have this issue. But preferably I want to avoid jumping in and out of Iray, everytime I want to adjust my camera.

Been googling around for a similar problem, but I've found nothing similar. There was one thread about a laggy viewport, but I had already applied the 'fix' mentioned there. Did not fix my camera issue.

GTX 1080 (419.67 -- issue persists in older drivers)

Windows 10

Having the same issue? Tell me about it, what have you tried to fix it? If I'm alone with this then I may actually be cursed :/

Post edited by saphirx on

Comments

  • Richard HaseltineRichard Haseltine Posts: 52,413

    I would think that was because when you move the camera alone only the point of view is chnaging, but when there is an item parented to the camera the 3D data itself is also changing so there is more work to be done.

  • saphirxsaphirx Posts: 6

    I would think that was because when you move the camera alone only the point of view is chnaging, but when there is an item parented to the camera the 3D data itself is also changing so there is more work to be done.

    Fair enough. That does not explain the camera headlight though... unless that too spawns a temporary point light behind the scenes (that's parented to the camera). But then, how come that didn't cause framedrops in the past? I can't say exactly when I started having camera related framedrops (Headlight was fine, at least), but they were not present in past versions of DAZ (after Iray was implemented), for sure.

    Can't say if parenting primitives to the camera in past versions was any different. Headlight worked much smoother/faster though. I'm sure of it. Though I have not gone back to older versions of DAZ to test it. This has gotten me curious... I'll check out older DAZ releases and report back.

  • saphirxsaphirx Posts: 6

    Right. So I went back to 4.10.0.123. And parenting anything to the camera doesn't cause these framerate dips that I described. Activating the headlight and moving the camera around doesn't make everything choppy (still a framerate drop, but the renderer feels way more responsive and smooth compared to 4.11.0.366). Parented a primitive to the camera (plane in-front of the camera 'lens') and tried navigating around the viewport, same result, no massive framedrop, very much useable for working with the Iray viewport enabled.

    Don't really want to revert to 4.10 since I very much like some changes made since then. But now I'm sure that cameras didn't have these issues in the past. Is this a known issue? Is it even considered an issue? I'm personally limited by these framedrops in the latest versions, since working at slideshow FPS is unbearable.

  • Richard HaseltineRichard Haseltine Posts: 52,413

    You could report it to Daz - it may simply be that soemthing in the newer builds is making a formerly hard to spot issue more visible, but ti could also be a bug. Do this by opening a Technical Support ticket https://www.daz3d.com/help/help-contact-us

  • saphirxsaphirx Posts: 6

    You could report it to Daz - it may simply be that soemthing in the newer builds is making a formerly hard to spot issue more visible, but ti could also be a bug. Do this by opening a Technical Support ticket https://www.daz3d.com/help/help-contact-us

    Thank you for redirecting me to the support page! Made a ticket explaining the issue. Hopefully its recognized as an issue, and addressed in future beta releases! :)

Sign In or Register to comment.