daz using wrong gpu for sure

andy vronandy vron Posts: 33

i have a five card system ...4x1080ti on a 1 lane expansion port and an internal 1070 for what should be viewport tasks.

but with daz beta it is using one of the 4 external 1080 cards which because of the 1 lane limit is real slow..even wireframe is slow...daz is really using the wrong card for everything!!!!!!

so if i turn off the external cards my viewport is real fast using the x16 1070 and when i want to do a render i have to reboot with the 1080 cards switched on.

i have tested extensively and you can visually see windows rescource monitor confirming what is happening.

is there any way to force daz to use the correct internal card attached to the x16 pci slot for viewport tasks ...this is a bit crazy right?

 

Post edited by andy vron on

Comments

  • Richard HaseltineRichard Haseltine Posts: 52,423

    I don't know - people with laptops offering an Intel on-chip GPU and a dedicated nVidia GPU select which to use in the Control Panel, but I would think with multi-GPUs from the same vendor the one with the monitor cable would be used for the display.

  • andy vronandy vron Posts: 33
    edited May 18

    well im sure windows is using the 1070 for desktop tasks... its just daz that seems to be confused ...this idea of letting daz choose seems pretty loose...another renderer that i use allows you to choose the viewport and the renderer gpus so that software works well with my system.

    i also assumed the card with the monitor would be by default doing the viewport work but this seems to not to be the case with daz.

    maybe there is a setting in the registry that could choose??

    Post edited by andy vron on
  • fastbike1fastbike1 Posts: 2,966
    edited May 18

    If only one card is plugged into a monitor, I don't see how Studio can use any other card for Viewport duties (on a desktop).

    Post edited by fastbike1 on
  • sylvie1998sylvie1998 Posts: 126

    In NVIDIA control panel go to Manage 3D Settings and select your 1070 as the only card for OpenGL (1), then deselect it under CUDA GPUs (2).

    cpl.PNG
    666 x 437 - 38K
  • andy vronandy vron Posts: 33
    edited May 18

     

    In NVIDIA control panel go to Manage 3D Settings and select your 1070 as the only card for OpenGL (1), then deselect it under CUDA GPUs (2).

    this looks interesting ...i will try tommorow..thankyou.

     

    Post edited by andy vron on
  • johngjohng Posts: 25

    I have an Intel card and an Nvidia 1050 card. If I run Daz on the Nvidia card there is strange lag when using the controls and the framerate is pretty low. The Intel card runs smoother when using it but in theory Daz ought to run much faster when using the Nvidia card. It's not a terrible problem but I am wondering if there is any solution to it?

  • sylvie1998sylvie1998 Posts: 126

    @johng Laptop or desktop?

    If laptop, you actually have to specify that a program should be run with a specific graphics adapter (with laptops which have Optimus you get a right-click menu option for .exe files which says "Run with graphics processor" and you can chose to always run a program on either built-in or dedicated GPU.

    If desktop, no idea why would you even have Intel graphics enabled, just turn it off in the BIOS and plug the monitor into 1050.

  • kenshaw011267kenshaw011267 Posts: 1,033
    johng said:

    I have an Intel card and an Nvidia 1050 card. If I run Daz on the Nvidia card there is strange lag when using the controls and the framerate is pretty low. The Intel card runs smoother when using it but in theory Daz ought to run much faster when using the Nvidia card. It's not a terrible problem but I am wondering if there is any solution to it?

    The 1050 is a very slow GPU and an intel IGP is not going to be far off that in performance. For viewport stuff you should check your driver versions. If your Nvidia driver is very out of date your openGL could be badly out of date which could be the cause.

    You should also check GPU-Z on what is going on with the 1050 when you're using it. Pascal cards are very heat sensitive and if your rig has bad ventilation that could also be the issue.

  • johngjohng Posts: 25
    edited May 18

    The 1050 is a very slow GPU and an intel IGP is not going to be far off that in performance. For viewport stuff you should check your driver versions. If your Nvidia driver is very out of date your openGL could be badly out of date which could be the cause.

    You should also check GPU-Z on what is going on with the 1050 when you're using it. Pascal cards are very heat sensitive and if your rig has bad ventilation that could also be the issue.

     

    I know both cards are rubbish but there's quite a difference between them in performance:- https://www.game-debate.com/gpu/index.php?gid=3821&gid2=3813&compare=Nvidia GeForce GTX 1050M-vs-Intel HD Graphics 620 Mobile

    It's a pretty new machine and the Geforce is running correctly when I've tried it with other programs. But I've actually had this same problem in the past, maybe Daz gets confused with multi-card setups. Perhaps I will report this as a bug.

     

    Post edited by johng on
  • johngjohng Posts: 25
    edited May 18

    Sorry, multi-post.

    Post edited by johng on
  • kenshaw011267kenshaw011267 Posts: 1,033
    johng said:

    The 1050 is a very slow GPU and an intel IGP is not going to be far off that in performance. For viewport stuff you should check your driver versions. If your Nvidia driver is very out of date your openGL could be badly out of date which could be the cause.

    You should also check GPU-Z on what is going on with the 1050 when you're using it. Pascal cards are very heat sensitive and if your rig has bad ventilation that could also be the issue.

     

    I know both cards are rubbish but there's quite a difference between them in performance:- https://www.game-debate.com/gpu/index.php?gid=3821&gid2=3813&compare=Nvidia GeForce GTX 1050M-vs-Intel HD Graphics 620 Mobile

    It's a pretty new machine and the Geforce is running correctly when I've tried it with other programs. But I've actually had this same problem in the past, maybe Daz gets confused with multi-card setups. Perhaps I will report this as a bug.

     

    It's a laptop? The 1050 is almost certainly thermal throttling. Get GPU-Z and check what happens when you go from idle to Daz. I'm betting the 1050 runs just fine for a few seconds, 30 or so, and then the frequency drops significantly.

  • andy vronandy vron Posts: 33
    edited May 19

    In NVIDIA control panel go to Manage 3D Settings and select your 1070 as the only card for OpenGL (1), then deselect it under CUDA GPUs (2).

    ok sylvie1998....that was the problem...now solved!!!!

    thankyou x1000   ....very very much appreciated!!!!!

    my system is now oficially daz awesome..!

     

    ps ...i couldnt let the control panel deselect the internal card for cuda ...however selecting the internal only for open_Gl solved it.

     

    Post edited by andy vron on
  • sylvie1998sylvie1998 Posts: 126

    No problem, happy rendering.

  • fastbike1fastbike1 Posts: 2,966
    edited May 19

    @andy vron :ps ...i couldnt let the control panel deselect the internal card for cuda ...however selecting the internal only for open_Gl solved it."

    You should be able to select which card(s) you want for rendering from within Studio.

    Capture.PNG
    693 x 835 - 70K
    Post edited by fastbike1 on
  • sylvie1998sylvie1998 Posts: 126

    @fastbike1 That is for rendering, he asked about viewport and I already helped him.

  • johngjohng Posts: 25
    edited May 20
    johng said:

    You should also check GPU-Z on what is going on with the 1050 when you're using it. Pascal cards are very heat sensitive and if your rig has bad ventilation that could also be the issue.

     

    I know both cards are rubbish but there's quite a difference between them in performance:- https://www.game-debate.com/gpu/index.php?gid=3821&gid2=3813&compare=Nvidia GeForce GTX 1050M-vs-Intel HD Graphics 620 Mobile

    It's a pretty new machine and the Geforce is running correctly when I've tried it with other programs. But I've actually had this same problem in the past, maybe Daz gets confused with multi-card setups. Perhaps I will report this as a bug.

     

    It's a laptop? The 1050 is almost certainly thermal throttling. Get GPU-Z and check what happens when you go from idle to Daz. I'm betting the 1050 runs just fine for a few seconds, 30 or so, and then the frequency drops significantly.

    It doesn't seem to be, it seems slow straight away. The fan never even needs to come on like in other programs. Like I said the Intel card runs ok, about 30fps (maybe a locked fps limit?) when animating one G8 figure. On the Nvidia it's about 15-20fps, when it should be much faster than the Intel. It seems kind of strange.

    Post edited by johng on
  • kenshaw011267kenshaw011267 Posts: 1,033

    Get GPU-Z and find out. BTW there is no "Intel card" the Intel IGP, integrated graphics processor, is built into the Intel CPU.

Sign In or Register to comment.