A Dynamic Conundrum

edited December 1969 in Daz Studio Discussion

I'm really hoping someone has a simple explanation/fix for my issue.

Dynamic Cloth

I've been using dynamic cloth with Daz for quite some time .... love the results. Used it just the other day, in fact ... but as of yesterday, I'm experiencing a rather odd, and very frustrating problem. The scene is simple .... one V4 character on a couch with a dynamic sheet draped over her. Seems pretty straight forward ... in fact, the scene I completed two days ago was the exact same scenario. The only thing that's changed is her pose.

Now ... the issue arises when I attempt to drape the sheet. It simply will not collide with everything. The scene is literally V4, a couch and a ground plane. The weirdness of the situation is that I can get the sheet to collide with V4 OR the couch, but not both. No matter what I try, it simply won't do it. I've gone as far as adding primitive planes (of sufficient poly count) to mimic the shape of the couch and removed the couch altogether. No luck. I've even tried exporting the scene as a single .obj and importing into a fresh scene. Nada.

Now, the REALLY weird thing is that it almost seems that the cloth will ONLY collide with whatever is listed at the top of the "Collide With ..." options box. If I rename objects in the scene as A, B, C in varying arrangements, whatever object (V4, couch or ground) is labeled as "A" will get dynamic love ... and the others get ignored. But, as I stated, the day before this started happening, everything worked fine.

Incidentally, I'm using Daz 4.5 with just the basic Dynamic Cloth control ... no fancy plugin.

If anyone has any insight, it would be greatly appreciated!

Cheers!

Comments

  • Richard HaseltineRichard Haseltine Posts: 57,700
    edited December 1969

    Have you tried it in a new scene, in case it's an oddity in the scene?

  • edited December 1969

    Hmm .... that's an excellent question. The one thing I haven't tried yet is rebuilding the scene. As it stands now, all I did after rendering the scene in which the cloth worked, was to save it, repose V4 and save that as another scene. I'll have to hurry home and give that a shot.

    Cheers!

  • SylvanSylvan Posts: 2,482
    edited December 1969

    I can concur that sometimes, somehow a scene is bugged for whatever reason.
    Once, one of my figure was unable to use some the parameters and on another occasion I was unable to add colors to the hair, so frustrating!
    Had to rebuilt the scene and the problem was solved.

  • Cayman StudiosCayman Studios Posts: 1,008
    edited December 1969

    Is the Dynamic Sheet the one sold here at DAZ?

    I have just tried to use it on V4 on a sofa, and the whole thing seemed too much for it - DAZ just crashed. I then tried it with V4 alone in the T-pose and it threw up an error message:

    Cloth Simulation Error

    There was an error during simulation. This could be caused by setting cloth parameters to values that are too extreme. Try adjusting settings and draping again.

    I tried it again, but this time with Genesis. At least it did not crash, but the sheet did not bother to collide with itself even though it was instructed to do so (see attached).

    I'm using DAZ 4.6 on a 64-bit Windows PC and have the Dynamic Clothing Control, but with default settings.

    Sheet.jpg
    500 x 500 - 115K
  • SpottedKittySpottedKitty Posts: 6,608
    edited December 1969

    Is it an old scene, originally saved in .daz format? I've noticed a weird problem where the Collide With settings must be completely reset and clicked through again from the very beginning. Sometimes it just works, sometimes it's as if Collide With works completely differently between D|S3 and D|S4.

  • edited December 1969

    Thanks for the replies, guys. It IS the dynamic sheet sold here at Daz, yes ... but I don't get any error messages at all when I run the simulation. Even combing through the event log, there is no indication that anything at all went wrong. Everything, at least according to Daz, went just fine.

    The self collision thing .... that's, honestly, nothing new for me, at least. With hundreds of renders that use dynamic cloth, I've can honestly say I've never seen a piece of dynamic cloth that actually DID collide with itself.

    It is not an old scene. It was created in Daz 4.5 originally ... and recreated the same way several times thereafter. I even went back to Daz 3 Advanced .. recreated the scene there and received the same results.

    I spent nearly six hours last night running through different scenarios and set ups ... using different sofa models, different V4 models, etc. and all of them gave the same results. There were a few things that I started to notice resembled somewhat of a pattern, though:

    In each case, if geometry was brought into a scene after the dynamic cloth was loaded (different sofa model, etc) ... it would not collide with it, even if selected in the "Collide with ... " settings.

    If the cloth was not colliding with either the sofa or the V4 (but still colliding with the other) ... removing the geometry that it was colliding with made it collide with the other. For example, if it collided with V4, but not the sofa and I remove V4, it will then collide with the sofa and vice versa.

    In the same scenario, if the cloth would not collide with V4 ... renaming V4 in the scene window would cause the collision to happen, but would stop it from happening with anything else in the scene.

    If the cloth was initially colliding with V4 as normal ... opening the "Collide With .. " options and deselecting any part of V4 (i.e. her head, or neck or even her left eye) would cause the cloth to ignore her completely. Selecting those options again would not correct this ... the cloth would have to be removed from the scene and reloaded.

    Each of these scenarios happened consistently in both Daz 4.5 and Daz 3 Advanced. Incidentally, my Daz 3 Advanced install does have the Dynamic Cloth Control plugin. I also tested this after completely uninstalling the dynamic sheets and reinstalling them. Later today, I will be testing with other dynamic clothing. I'm beginning to suspect this is a bit more than just a random glitch. Until then, my only option has been to consider blowing the dust off Poser 9 and haplessly flinging myself against the wall that is the Cloth Room.

    Cheers!

Sign In or Register to comment.