Inverted Faces (Surfaces)

handyman4545handyman4545 Posts: 381
edited April 2019 in Hexagon Discussion

Quite by accident while playing with Marmoset, I discovered I have a real mess on my hands.

Seems that somhow, many of the faces of one of my drawings got "inverted" in the process of design and not only have I no idea how that occured (in order to prevent it from happening again), I have no idea how to economically revert the faces for proper display.

Properly displayed and aligned faces show mats on the outside of the model.
Inverted faces on the other hand, show mats on the inside of the model and are invisable on the outside.

I actually discovered this when I opened the model in Marmoset and verified it by turning off the "Back Face" control in Hexagon.

Anybody run into this issue and how did you fix it?

Inverted Faces.png
1226 x 640 - 472K
Post edited by handyman4545 on


  • Are your meshes using quads or n-gons? Do you have vertexes from the same object touching each other (Hexagon really hates that, and so flips things to no end)?

  • JonnyRayJonnyRay Posts: 1,744

    Shawn (as usual) has some good ideas. :)

    Also try using the Selection option for Non-Planar Surfaces which can help highlight where your problems are.

    Once you get the geometry worked you, you should be able to use the Orient Normals tool to get them flipped around. If they don't stay that way, then you missed something else.

Sign In or Register to comment.