Replicate and instance misfortunes

akmerlowakmerlow Posts: 526
edited January 19 in Bryce Discussion

Hi, i can't understand if i do something wrong or my Bryce is broken.

1) If i multireplicate, or randomreplicate anything and enable "instance", that leads to... literally nothing happens. I got zero results. I tried both objects (i even looked up David Brinnen's advice that you need to be sure object is not grouped) and primitives. When i replicate stuff "as it is", it works. But when i check "instance", nothing happens.

I also see that Edit - Instance command in menu is grayed out. So, is it somehow disabled? These gives me some very serious concerns. I check Bryce 7 Artist Guide, but it doesnt seem to have article on that. And Horo's site has tutorials on further complicated stuff which suggest that instancing already works.

After doing some more tests and re-reading more, i finally understood that "instance" thing works with meshes. That means if, for some reason, i need to instance object made with bryce shapes, i have to export it and re-import again. Is that right? I felt confusion because one of models from old object library refused to be instanced and i didnt know that it wasnt actually a mesh.

2) When object linked to path (like in this tutorial https://horo.ch/raytracing/tuts/pdf/minitut10_en.pdf )

It's possible to use multireplicate if you don't feel like manually doing things, but no matter what i do i can't enable changing of size with each replication step. It works fine with free replicating, but not with objects on path (when you constrain to path). Perhaps path somehow restricts it by its nature? I hope there could be workarounds.

Post edited by akmerlow on

Comments

  • S RayS Ray Posts: 202


    On the edit pull down menu Instance is always grayed out for me no matter what type object I have selected. . In the Instance lab anything can be an instance of any Bryce primitive. Say you have a Bryce terrain and some mesh grass, with the terrain selected you can go into the Instance Lab and instance the grass on the terrain then all the grass will only show on the surface of the terrain by using the drop to surface collision detection Bryce has.  You can use the Instance Lab to instance to a path but you will get random results. There is no matrix control like the multi replicate tool has.

     

  • akmerlowakmerlow Posts: 526

    After doing some more tests and re-reading more, i finally understood that "instance" thing works with meshes.

    Also it can't instance group. Even if it's imported OBJ - it refuses to instance it unless it's merged/combined mesh (which means trouble with texturing without uv mapping i guess).

    S Ray, i haven't tried Lab yet, but thank you for sharing advice.

  • HoroHoro Posts: 6,693

    akmerlow - grouped objects cannot be instanced. You can ungroup them and keep all parts selected. These you can instance and the instanced objects can be grouped again. Truly instanced objects have dashed lines in the wire frame.

  • akmerlowakmerlow Posts: 526

    Thanks for tip, Horo! With random replicate parts behave independantly, but with MR they act together as needed.

Sign In or Register to comment.