Creating props in Blender

Hi everyone,

I recently started experimenting with importing some of my models into DS and creating props from them, but I'm running into a problem with UVs and normals. I do most of my modeling and initial UVs in Rhino 5, then export to obj, import into Blender 2.79b, finish the UVs and apply textures/materials. When I later export to obj from Blender, I set -Y Forward, Z Up, and I have the following boxes checked: Apply Modifiers, Include Edges, Write Normals, Include UVs, Write Materials and Objects as OBJ Groups.

If I import that model into Daz 4.10 Pro, the normals are inside out. The entire model appears black in the viewport, I can correct this by flipping the normals in blender before I export the model, but I feel like I shouldn't have to do that at all (I don't have to do it in any other 3D package) so there must be something I am doing wrong (Also, there doesn't appear to actually BE a way to flip the normals inside DS at all, and I'm curious why that is). That's problem #1. Problem #2 is that the UVs are completely reversed, as if they were applied from the other side of the model, and the only way I can correct this is to actually mirror my textures left to right to get them to show up properly in DS, regardless of whether or not I flipped the normals.

As of right now, I cannot bring anything into Daz from Blender that does not have flipped normals and UVs, and seeing as others people's props don't seem to have their maps flipped, I can only ask: What the hell am I doing wrong?!?

I can post a model if needed.

Comments

  • When I export as OBJ from Blender I use -Z forward and Y up and I don't seem to have the issues you are having.  Perhaps try that - my Daz export Blender preset in the image attached.  I'm also using 'OBJ as objects' but only because it's the default; I'm not sure what the difference is between that and 'OBJ as Groups'.

    Just to be clear, I take the shading looks OK in Blender?  And the normals are pointing the 'right' way when you look at them in Edit mode?  Have you checked the geometry e.g. for doubles, faces exactly or very, very nearly on top of other faces etc.?  Blender may be more forgiving of imperfect geometry than Daz is.  I haven't seen a model look completely inside out, but I have seen shading artifacts in Daz that I eventually traced to poor or incorrect geometry that I hadn't noticed in Blender.

    daz-obj-preset.JPG
    255 x 598 - 29K
  • When I export as OBJ from Blender I use -Z forward and Y up and I don't seem to have the issues you are having.  Perhaps try that - my Daz export Blender preset in the image attached.  I'm also using 'OBJ as objects' but only because it's the default; I'm not sure what the difference is between that and 'OBJ as Groups'.

    Just to be clear, I take the shading looks OK in Blender?  And the normals are pointing the 'right' way when you look at them in Edit mode?  Have you checked the geometry e.g. for doubles, faces exactly or very, very nearly on top of other faces etc.?  Blender may be more forgiving of imperfect geometry than Daz is.  I haven't seen a model look completely inside out, but I have seen shading artifacts in Daz that I eventually traced to poor or incorrect geometry that I hadn't noticed in Blender.

    I use the -Y Forward, Z Up because the objects always come into daz laying on the side if I don't. I hadn't considered that might be messing with the way Blender exports the UVs and normals (like, maybe it's accidentally turning them inside out), and I will give your method a shot, however, I have been playing around with it since I posted this, and I figured out that I can export in fbx format and I don't have to worry about any of that stuff. Everything comes into DS perfectly without any fuss whatsoever and I can go straight to creating the materials. Thanks for the help!

  • EsemwyEsemwy Posts: 522

    Last I heard, the preset to import from Blender was still incorrect. You need a custom preset for it to do the right thing. Off the top of my head, the only other setting I use when exporting from Blender is maintain vertex order. Otherwise, @andya_b341b7c5f5 is correct about the orientation. It’s +Y up and -Z forward.

  • 3WC3WC Posts: 675

    In DS you can use the geometry editor to pick polygons, right click and there is an option to flip normals.

     

    Untitled-1.jpg
    1246 x 862 - 537K
  • 3WC said:

    In DS you can use the geometry editor to pick polygons, right click and there is an option to flip normals.

     

    Thanks forr the tip! I had a bugger of a time finding it, hiding under the tools menu. How did you get it to show up in your toolbar? It's not in mine and I didn't even know this tool existed.

  • 3WC3WC Posts: 675
    3WC said:

    In DS you can use the geometry editor to pick polygons, right click and there is an option to flip normals.

     

    Thanks forr the tip! I had a bugger of a time finding it, hiding under the tools menu. How did you get it to show up in your toolbar? It's not in mine and I didn't even know this tool existed.

    Probably depends on your layout. You can change it by going to Window/Workspace/Select Layout. Or you can customize under Edit, I think, and add whatever tools you want.

Sign In or Register to comment.