Odd seams on planes. Edited and Updated with new Scene File [Work around found]

AbnerKAbnerK Posts: 618

Hi,

I've noticed this a few times now but it's usually been the least of my problems so ignored it. I get odd seams on planes. I've attached a screenshot. This may look like shadow but I've had this exactly same 'salvage edge' patten in parts of a scene which should have had even light. This one uses a bump map but the same things has happened many times when I've used nothing but diffuse colour. What's going on and how can I stop it happening?  On the right is the torso of a figure and there is a shadow running parallel to the chest/back however the vertical lines are what I"m talking about. 

Thanks. 

 

 

Screen Shot 2018-11-21 at 01.14.33.png
1618 x 1448 - 2M
Post edited by AbnerK on

Comments

  • AbnerKAbnerK Posts: 618

    Here's another example. There's three lights in this scene and nothing to cast ahdows. The only shadows you should see are from the 1 body in the scene, the legs. All the straight lines are odd seams. 

    Same in the next one. 

    Thanks

    Screen Shot 2018-11-21 at 11.31.50.jpg
    1804 x 1097 - 1M
  • Is that a plane prinmitive? How many divisions does it have? Is there tiling applied to the textures? Is the figure at the origin, or offset?

  • AbnerKAbnerK Posts: 618
    edited November 2018

    Yes, it's a plane pimirtive, I use the default setting with 10 meters selected usually. There is just a colour applied to the green ones and a seameless texture applied using the same settings a the default G8 base in the 'marble' one above. They are all at 0.0.0

    Now that this image has finished rendering the seam only appears in the shadow. 

    Thanks

    Screen Shot 2018-11-21 at 14.25.51.png
    942 x 1540 - 2M
    Post edited by AbnerK on
  • Sven DullahSven Dullah Posts: 6,085

    Is that with Iray? Do you have depth of field enabled on the camera?

  • 10 m or 10 divisions?

  • AbnerKAbnerK Posts: 618
    edited November 2018

    It's 10 meters, my default setting is 1 division there is a seamless bump map applied, the green ones are the same settings with only green colour applied. 

    Post edited by AbnerK on
  • AbnerKAbnerK Posts: 618
    edited November 2018

    Is that with Iray? Do you have depth of field enabled on the camera?

    Yeah, Iray, no DOF

    I removed the bump map and created a primitive sphere you can still see the seam. I've included the file. 

    duf
    duf
    egg test.duf
    136K
    Egg test.jpg
    500 x 809 - 162K
    Post edited by AbnerK on
  • AbnerKAbnerK Posts: 618

    I can't beleive I'm the only person who has the problem of odd seams I've never solved it, I have to Photoshop them out or just live with them. 

  • Eagle99Eagle99 Posts: 159

    If you use and HDRI and have "Draw Ground" "on" in the render settings the ground of the HDRI might intersect with the plane as soon as the plane have a bump or normal map applied. Even if "Draw Dome" is off.  Either set "Draw Ground" to "off" or set the "position mode" to "manual" and lower the Y-value a bit.

    That's the only thing I can think of at the moment, that can cause this effect.

    Kind regards, Eagle99

  • FishtalesFishtales Posts: 5,397
    edited April 2019

    I just fired up your attached scene and your camera is below the floor. Moving it up above the floor removes the shading.

    Scrub that. I did a few more experiments and the shading keeps showing up in some but not always :)

    Post edited by Fishtales on
  • AbnerKAbnerK Posts: 618
    edited May 2019
    Fishtales said:

    I just fired up your attached scene and your camera is below the floor. Moving it up above the floor removes the shading.

    Scrub that. I did a few more experiments and the shading keeps showing up in some but not always :)

    I almost forgot about this problem until now. I've created another scene from scratch and I've found two areas, two 'Axes of Evil'. where the problem is worse, at 0, on Y axis and 0 on the X axis. Forgive me if that is not strictly accurate my brains is a bit fried after 3 hours of test after test. I've put 5 cubes in the scene, they're there just so you can orient yourself. I've tied a camera to the vertical Test Plane(s). If you orient the Test Plane (along with with, so, viewing through the active 'Test Camera')  you'll see the weird abberation move. 

    The only sollution I can find is to avoid the Axis of Evil. :)

    duf
    duf
    Odd Seam Test.duf
    77K
    Seam Test.png
    618 x 1000 - 616K
    Post edited by AbnerK on
  • lukon100lukon100 Posts: 434

    I've noticed this problem with larger plane primitives.

    I once saw a Youtube tutorial where someone had the same problem in Blender. He got rid of the "seam" lines there by subdividing the plane a few times.

    So I tried the same thing in Daz Studio and it worked there too. Well, I didin't subdivide any existing planes, but I loaded larger planes into my scene with more divisions. That got rid of the seam lines that would have otherwise appeared after texturing them.

  • AbnerKAbnerK Posts: 618
    edited May 2019
    lukon100 said:

    I've noticed this problem with larger plane primitives.

    I once saw a Youtube tutorial where someone had the same problem in Blender. He got rid of the "seam" lines there by subdividing the plane a few times.

    So I tried the same thing in Daz Studio and it worked there too. Well, I didin't subdivide any existing planes, but I loaded larger planes into my scene with more divisions. That got rid of the seam lines that would have otherwise appeared after texturing them.

    Thanks, I don't think you can add divission to an existing plane  in Daz can you? Adding subd doesn't work, I tried that today myself forgetting it's not quite the same as Blender, well, not the same as adding it from the 'Add' menue, more like adding Subdivision Surface from the 'Modify' menu.   I used that solution of adding more verteces in the past. I've learned that Richard's help can be cryptic. :)  To be really honest I'd forgotten about that sollution since I've used Blender too much lately and forgotten you can set up a plane in Daz with subdivissions but not subdivide it later. When I saw the problem earlier I added SubD, that didn't work of course because it just rounds the sides same as from the Modify menu in Blender. I'm on meds that affect my focus sometimes. Other times I've fine but I think I was having a bad day. :D Actually I've had a pretty bad day but because I've been like a dog with a bone. :D 

    Thanks for reminding me. I've never had the problem in Blender though. I did try to recreate the problem in Blender today, but, I hadn't worked out it was nothing to do with the plane, per se, then but, the space the plane was in at that point. Having found that out I'm surprised you're the first person to let me know I'm not going crazy. :D

     

    Thanks. :)

    Post edited by AbnerK on
  • AbnerKAbnerK Posts: 618
    Eagle99 said:

    If you use and HDRI and have "Draw Ground" "on" in the render settings the ground of the HDRI might intersect with the plane as soon as the plane have a bump or normal map applied. Even if "Draw Dome" is off.  Either set "Draw Ground" to "off" or set the "position mode" to "manual" and lower the Y-value a bit.

    That's the only thing I can think of at the moment, that can cause this effect.

    Kind regards, Eagle99

    Thanks Eagle, i think that's good advice anyway. The amont of times I've wondered why I've got holes in the flooring because the displacement map is forcing the surface below the 'ground' I ended up fixing the problem in postwork previously until i discovered raising the floor a few points or turning the ground off fixed it. :)

  • AbnerKAbnerK Posts: 618
    edited June 8

    well, it's been a long time since I had this problem, I thought I'd fixed the issue but long story short, loaded on old scene and there was the oddity. I added a plane with subdivisions, moved the plane above the ground, turned up the light and exposure and the problem went. So, I came back here to load this old test seam and some some more tests.

    Draw Ground off on all.

     Odd seam test 1 - is the scene above, attached, default lighting HDRI no spots no subdivisions in planes.

     Odd seam test 1b - I replaced the planes with my my default 5 divisions and the seams went in the vertical plane but not the slightly-off-horizontal plane. I changed the colour of the distorted sphere so you can see it. 

      Odd seam test 2 -  Scene only lights, both planes with 5 subdivisions, two default spots and Exposure at 5.

     Odd seam test 3 - Scene only, lights at 9000000.0 lumens and render settings default only the cubes on the x axis left. The odd seam here is on the intersection with the ground plane which is still switched off.  I get there's some clipping of the white here too.

     Odd seam test 4 - So, subdivide the plane, don't intersect the ground and keep the lighting good with exposure at 13 or so.

    Incidentally, on the back side of the vertical plane, in the shadows, you can still see an odd seam as in the first test image. It's hard to make out but, it's still there on the dark side. 

    odd seam test 1.png
    433 x 700 - 366K
    odd seam test 1b.png
    433 x 700 - 365K
    odd seam test 2.png
    433 x 700 - 290K
    odd seam test 3.png
    433 x 700 - 72K
    odd seam test 4.png
    433 x 700 - 160K
    Post edited by AbnerK on
  • AbnerKAbnerK Posts: 618

    updated scene attached if you want to compare

    test scen updated.duf.png
    91 x 91 - 3K
Sign In or Register to comment.