UberEnvironment2 Sample rating

Wallace3DWallace3D Posts: 161
edited December 1969 in Daz Studio Discussion

is there a way to set the occlusion sample rating higher than 128? Even when I unlock the parameter and set it to say 256 it still renders at the lower rate.


  • wowiewowie Posts: 2,029
    edited December 1969

    May I ask why do you want to use more samples?
    If you're getting blocky/splotchy occlusion shadows, you should change the shading rate and not the samples.

  • ReDaveReDave Posts: 815
    edited December 1969

    Click on the cog wheel in the top right corner of the Samples channel and select Parameter Settings then turn limits off. However as wowie said it is more efficient to reduce the UE2 specific shading rate (found under "Advanced"), which for some reason is never low enough, one or two is a good value. You don't need remotely close to 128 samples in these cases.

  • Wallace3DWallace3D Posts: 161
    edited December 1969

    When I create a Shader with occlusion setting the samples to 256 makes a huge difference than 128 (less blotchy) and I have my shading rate set to 1

    UE2 at 128 samples is still very blotchy

  • SzarkSzark Posts: 10,634
    edited June 2012

    Uber 128 should be good for any scene.

    In the Advanced render settings the Shading rate should be set to 0.20 or lower when using Uber Enviroment. The two work hand in hand. And depending on what is in your scene a Uber Shading rate can be lowered to 1 or 2 as Redave suggested but 8 is a good all rounder. I normally use 1 or lower when using Indirect Lighting via UberEnviroement. But boy does that increase render times a lot more.

    Post edited by Szark on
  • wowiewowie Posts: 2,029
    edited December 1969

    Oh yes, there's another thing i forgot to mention. Polygon count. The occluding object's polygon count also plays a part in the occlusion process with UberEnvironment.

    I've attached three images to this post. This are renders with UberEnvironment and 1 Directional Light. The first one is 64 samples, the second is 128 samples, and the third is 256 samples (after turning the limits off).

    Both cubes are made of 6 polygons (1 per side). Upping the samples help, but there's still blotchiness. These are taken with Shading Rate 128 and Maximum Trace Distance 50.

    600 x 600 - 76K
    600 x 600 - 77K
    600 x 600 - 79K
  • wowiewowie Posts: 2,029
    edited June 2012

    I replaced both cubes with new ones, but this time upped the divisions from 1 to 100. For the first image in this post, UberEnvironment occlusion sample was set to 64 and shading rate was kept at 128. Then for the second render, I changed the shading rate to 2.

    Hope this helps.
    Oh yes, forgot to mentioned this is with Occlusion with Directional Shadows.

    600 x 600 - 90K
    600 x 600 - 86K
    Post edited by wowie on
  • SzarkSzark Posts: 10,634
    edited December 1969

    wowie, great info I had no idea mesh resolution played a part. Thank you for that nugget.

  • vwranglervwrangler Posts: 4,660
    edited December 1969

    For what it's worth: I had that sort of issue with blotchiness on character textures and other surfaces a while back, and Phoenix1966 directed me to lower occlusion strength to less than 50% until it cleared up, and if that didn't work well enough on its own, to use the quality preset Set4xHi. The second option will slow down your render -- a lot -- but it also clears up the issue, especially used in combination with lower occlusion strength.

    I have sometimes tried just turning off occlusion altogether for some characters and surfaces, but that turns out to be weirdly hit-or-miss. (For most people, it's shadows that slow renders down; for some reason, my computer has hissy fits over occlusion. Weird.) I had one scene that was making me crazy because, with occlusion turned off on both characters, one was casting shadows and one wasn't -- it was a daylight image, so shadows were very necessary -- even though both were set to cast and accept shadows. Eventually, I just turned on occlusion for the character with the problem, and hey presto! shadows! (And render time for that image went from 5 minutes to 20, but such is life.)

    Anyway, hope this helps.

  • SzarkSzark Posts: 10,634
    edited December 1969

    Yes I always lower Occlusion Strength to 75% to start a scene with.

  • wowiewowie Posts: 2,029
    edited December 1969

    Personally, I prefer messing with Maximum Trace Distance first and then Occlusion Strength. If I understand correctly, maximum trace distance controls how much are the occlusion is applied and Occlusion Strength does what it says. In general, both lowers how much occlusion is applied.. Settings will probably need to be adjusted to your scene/needs.

    With just V4, I never did notice blotchiness with occlusion. The problem It's only when doing renders with rooms and the like. My estimated guess is that many of the props available tries to be as light as possible in polygon count.

Sign In or Register to comment.