How do I remove smoothing {Fixed}

XadeXade Posts: 216
edited August 2018 in Hexagon Discussion

I want to get a model into Blender by exporting as an OBJ but when I do the model imports as smoothed mesh with a few thousand polygons instead of a few hundred. I want to improve it beyond what hexagon can do. Please help! 

Post edited by Xade on

Comments

  • You can cancel (not collapse) the smoothing before you export it as OBJ.

     

    Or... see if maybe Blender is set to smoothing objects as they are imported, when it doesn't need to be for your case.

  • Syrus_DanteSyrus_Dante Posts: 951

    Make shure you have set the Mesh Resolution to Base on the item you want to export in the DazStudio Parameters pane.

  • XadeXade Posts: 216

    You can cancel (not collapse) the smoothing before you export it as OBJ.

     

    Or... see if maybe Blender is set to smoothing objects as they are imported, when it doesn't need to be for your case.

    There is no way to cancel the smoothing that I can see, this model is 10 years old.

    Blender doesnt import as a smoothed obj, as that would defeat the purpose of importing a base model. You use modifiers for that when the time comes..

    Make shure you have set the Mesh Resolution to Base on the item you want to export in the DazStudio Parameters pane.

    This is Hexagon, not Daz. I want to import an old model I made for my webcomic and improve it but all that imports into Blender is the smoothed, high polygon one

  • AscaniaAscania Posts: 648

    Dou you even HAVE a low-poly version of the model?

  • Syrus_DanteSyrus_Dante Posts: 951

    Sorry I must have been missed that this is a hexagon discussion thread.blush

    Hope you figure it out in Hexagon - otherwise if its not a morph you try to create you can redurce the polycount of a highres mesh in Blender with the Decimate Modifier set to Un-Subdivide with a even number of iterations. A setting of 2 iterations will "try" to reverse one level of subdivison on a highres mesh. You can see the faces count in the Modifier settings and if you change the Object Display settings to Wire & Draw all Edges you can see the modifier result on the mesh in object mode. This Un-Subdivide in Blender is a great feature and has helped me alot in the past.

  • There is a way to do what you want in Hexagon. But it looks like you've found a soloution elsewhere.

  • Syrus_DanteSyrus_Dante Posts: 951

    I want to add this is not a perfect solution - depending on the models topology it could produce ugly mesh with lots of tris and the UV-layout if there is one could get messed up. After I apply the Decimate Modifier I would also press the spacebar and search the command "Tris to Quads".

    If the mesh is a symmetric object I would box select one half of the mesh (with backside selection on) to delete it by symmetry (if there is no center edge I would cut one in) and add a Mirror Modifier - as far as I know the only way to produce symmetric topology in Blender. Next you can add edges with the Knife tool or delete selected edge(s) (without deleting the faces) with the "Delete Edge Loop" command (uncheck Face Split in the operator options to get n-gons) accessed by the spacebar search to maybe fix some topology issues with remaining tris and such.

     

  • XadeXade Posts: 216

    There is a way to do what you want in Hexagon. But it looks like you've found a soloution elsewhere.

    Well, that solution often mangles the model and messes up the uvs. Actually, I figured it out, set smoothing on, select 0 and export. However, there must be a way to delete the highest subdivision within hexagon but I have no idea how. :P

  • There is a way to do what you want in Hexagon. But it looks like you've found a soloution elsewhere.

    Well, that solution often mangles the model and messes up the uvs. Actually, I figured it out, set smoothing on, select 0 and export. However, there must be a way to delete the highest subdivision within hexagon but I have no idea how. :P

    You'll figure out how Hexagon works.

  • XadeXade Posts: 216
    edited August 2018

    Hexagon has too many issues for my liking. It crashes far too much and has too few tools. Blender is more stable and has more power than Hexagon ever thought of having. Of all the tools of Blender I wish daz had I would choose the rigging system. Daz's is cumbersome by comparison.

    Post edited by Xade on
  • Diomede_CarraraDiomede_Carrara Posts: 9,142
    edited August 2018

    The tabs for levels of smoothing are in the upper right of the Hexagon menu.  Look just below the tabs for symmetry.  Make sure smoothing is at 0 before exporting as an obj or saving as a hexagon file.

     

    If you modeled it as a high polygon model oh so long ago, it will remain a hi polygon model.  If you modeled it as a lower polygon model and applied smoothing in hexagon, that menu in the upper right, below the symmetry options, is where you did it.  Just turn off the smoothing that you had turned on way back when.  Do so by setting smoothing to 0.

     

    to 0 must smoothing be set.  Not to one, nor to another positive integer.  Do not adjust axes of symmetry; rather, look just below symmetry.  

    Post edited by Diomede_Carrara on
  • XadeXade Posts: 216
    edited August 2018
    Diomede said:

    The tabs for levels of smoothing are in the upper right of the Hexagon menu.  Look just below the tabs for symmetry.  Make sure smoothing is at 0 before exporting as an obj or saving as a hexagon file.

     

    If you modeled it as a high polygon model oh so long ago, it will remain a hi polygon model.  If you modeled it as a lower polygon model and applied smoothing in hexagon, that menu in the upper right, below the symmetry options, is where you did it.  Just turn off the smoothing that you had turned on way back when.  Do so by setting smoothing to 0.

     

    to 0 must smoothing be set.  Not to one, nor to another positive integer.  Do not adjust axes of symmetry; rather, look just below symmetry.  

    No worries, I got it. I actually have various stages of its development. I am a firm believer of major change = new save. I took care of this issue july 15, see:

    Xade said:

    Well, that solution often mangles the model and messes up the uvs. Actually, I figured it out, set smoothing on, select 0 and export. However, there must be a way to delete the highest subdivision within hexagon but I have no idea how. :P

    I think my staff came out pretty good. There's some minor things that need done to it like rework the weight painting a little, and maybe adding a few more joints, especially the points. Perhaps update the rigging completely from scratch, depending on how my new adventure with hair is going, but other than that it's great. Here's a quick IK pose of what I was working on. I'll add fixed to title so everyone knows the problem is resolved.

    Staff1.png
    703 x 861 - 366K
    Post edited by Xade on
Sign In or Register to comment.