Can't access "My Account"

edited December 1969 in New Users


I've just installed the free DAZ4.5RC but there's this serial number prompt that appears.
It says that I need to get the serial from my account but I can't access 'My Account' even though I'm already logged-in. It always shows the log-in page, after I enter my mail address and password, the page loads then the log-in page appears again.

I tried logging-out then logging-in back but still the same. Can't access 'My Account'.
The forum is accessible, just not 'My Account'. Is there an alternative way?

Thanks for reading.


  • ChoholeChohole Posts: 33,604
    edited June 2012

    OK, on the log in problem.

    Log out from the page where you are logged in, which in your case is the Forum page.

    Then login again.

    If the does not clear the problem, do the same thing again, but this time after you have logged out, close your browser and clear cache (and possibly also cookies) then re-open the browser and log in again.

    If you have downloaded DS4 recently, from the current 100% discount offer, then check this therad, forst post gives you information about serial numbers.

    I hope that helps.

    Post edited by Chohole on
  • edited December 1969

    Thanks for the help!

  • Richard HaseltineRichard Haseltine Posts: 98,306
    edited December 1969

    If you don't already have a serial number for DAZ Studio 4 Pro you can either run without a serial number, in Standard mode, with the request appearing each time you start or you can use the free serial number provided by DAZ here

Sign In or Register to comment.