"Hexagon Error" while attempting to start Hexagon offline

Everytime I try to start Hexagon when I'm offline I get this message "Hexagon Error XML parsing error: 'no element found' at line 1". It renders the program unuseable offline.  Any suggestions?

Comments

  • Mac or Windows? is this the release build or the current public beta?

  • blanston2blanston2 Posts: 12

    It's Mac, and the version is 2.5.2.109

  • MusicplayerMusicplayer Posts: 515
    edited July 2018
    blanston2 said:

    It's Mac, and the version is 2.5.2.109

    Was a solution found to this because I am experiencing the same problem so have had to revert back to using the previous version. frown

    Thanks.

    Post edited by Musicplayer on
  • ProtozoonProtozoon Posts: 273
    blanston2 said:

    It's Mac, and the version is 2.5.2.109

    Was a solution found to this because I am experiencing the same problem so have had to revert back to using the previous version. frown

    Thanks.

     

    blanston2 said:

    It's Mac, and the version is 2.5.2.109

    Was a solution found to this because I am experiencing the same problem so have had to revert back to using the previous version. frown

    Thanks.

    I found out a while ago Hex wants to read news from a server and didn’t start if didn’t have a internet connection. That error. In preferences news ticked off and it works. Learned that the hard way, in the middle of important work.

  • mindsongmindsong Posts: 1,075

    ouch. thanks for posting that detail/fix!

    --ms

  • MurgatroydMurgatroyd Posts: 1,122

    I'm getting this error even when I have an active internet connection. And because of it, I can't get to the preferences to solve it.

  • mindsongmindsong Posts: 1,075

    If you can browse to:

      C:\Users\==yourname==\AppData\Roaming\DAZ 3D\Hexagon 2

    and manually edit the preferences.xml file (w notepad or better), you should be able to disable the news setting by adding a line like the others:

        <preference id="news-download" type="bool" value="false"/>

    and restarting Hex.

    FWIW, I was also able to (exit Hex, and...) simply move all of those XML files and the empty 'brushes' directory out of that directory (to a safe place...), and restart Hex - it recreated default versions of them and seemed to run properly. Perhaps that would let you at least get running again, even if you have to reset your favorite preferences again.

    --ms

     

  • ProtozoonProtozoon Posts: 273
    edited August 2018

    I'm getting this error even when I have an active internet connection. And because of it, I can't get to the preferences to solve it.

    Also if you have ’>’ or ’<’ in key shotrcuts, it gives a xml error, because xml-language format breaks with those. In this case you have to delete or edit the shortcuts.scm file. Learned that the hard way also and was very hard to find out. If I remember right reinstall didn’t work, ’cause the shortcut file stays there.

    I think it is  c:\program files/daz 3d/hecagon2/data/Script/shortcuts.scm

    Post edited by Protozoon on
  • mindsongmindsong Posts: 1,075
    Protozoon said:

    I'm getting this error even when I have an active internet connection. And because of it, I can't get to the preferences to solve it.

    Also if you have ’>’ or ’<’ in key shotrcuts, it gives a xml error, because xml-language format breaks with those. In this case you have to delete or edit the shortcuts.scm file. Learned that the hard way also and was very hard to find out. If I remember right reinstall didn’t work, ’cause the shortcut file stays there.

    I think it is  c:\program files/daz 3d/hecagon2/data/Script/shortcuts.scm

    ouch...

    and I'm *saving* that tip...!

    --ms

  • ProtozoonProtozoon Posts: 273
    edited August 2018

    In my mind Hexagon should state in which file it encounters the xml.error. Hard to debug if it appears.

    Post edited by Protozoon on
  • MurgatroydMurgatroyd Posts: 1,122
    mindsong said:

    FWIW, I was also able to (exit Hex, and...) simply move all of those XML files and the empty 'brushes' directory out of that directory (to a safe place...), and restart Hex - it recreated default versions of them and seemed to run properly. Perhaps that would let you at least get running again, even if you have to reset your favorite preferences again.

    --ms

     

    Thanks, that worked.

  • mindsongmindsong Posts: 1,075
    mindsong said:

    FWIW, I was also able to (exit Hex, and...) simply move all of those XML files and the empty 'brushes' directory out of that directory (to a safe place...), and restart Hex - it recreated default versions of them and seemed to run properly. Perhaps that would let you at least get running again, even if you have to reset your favorite preferences again.

    --ms

     

    Thanks, that worked.

    bravo!, maybe others will have similar success in the future for our notes here!

    --ms

  • Thank you all for your suggestions, my experience was a little different:

    After doing a completely fresh install of Hexagon 2 I got an error message saying      hexagon_news_data.xml  no such file or directory, and the program froze.

    I went to:  Users\==yourname==\AppData\Roaming\DAZ 3D\Hexagon 2    as suggested, and duplicated one of the .xml files and renamed it hexagon_news_data.xml

    I then restarted Hexagon with no error message showing, and went into the preferences and unticked  'check hexagon news'  and ticked  'don't show the same news twice'

    Hexagon now starts every time with no problem. I'm very happy. We have a great community here.  heart

    smiley

  • mindsongmindsong Posts: 1,075

    yay!

    pay it forward when you become a master! :^)

    --ms

  • sqxstartsqxstart Posts: 0
    mindsong said:

    If you can browse to:

      C:\Users\==yourname==\AppData\Roaming\DAZ 3D\Hexagon 2

    and manually edit the preferences.xml file (w notepad or better), you should be able to disable the news setting by adding a line like the others:

        <preference id="news-download" type="bool" value="false"/>

    and restarting Hex.

    FWIW, I was also able to (exit Hex, and...) simply move all of those XML files and the empty 'brushes' directory out of that directory (to a safe place...), and restart Hex - it recreated default versions of them and seemed to run properly. Perhaps that would let you at least get running again, even if you have to reset your favorite preferences again.

    --ms

    thanks, idid it, it work on my mac

     

Sign In or Register to comment.