Getting a Fatal Error on Launch - Solved

brimstoneomegabrimstoneomega Posts: 313
edited April 2018 in Daz Studio Discussion

Hello, I've been getting this error for the last few days and it's been driving me nuts. Pretty sure it happened around the time that last Game Ready Driver came out for nVidia, and from the looks of where the error is originating it has something to do with Vulkan ( I could of curse be totaly wrong, I just followed the path file and it's something for Vulkan). I've rolled back on drivers reinstalled drivers, deleted and reinstalled Daz, re-updated windows 10, but have had no luck. Not sure where to go at this point, maybe I should submit a bug or error report to Tech help. I just wanted to exhaust my options before bothering them with this. I'd love to get this figured out because it's happening on my main PC. I do have a different PC and a Laptop and have not been having these problems on either of those, but they are far less powerful then my main rig where I'm having this problem. 

The problem happens when trying to start up Daz. The Splash screen pops up and does it's conecting and building thing and then right when it gets to where Daz itself should start it crashes.

Specs (if important)- i7 7700k, 16 gb 3200 RAM, EVGA 1070 FTW 8 gb, Windows 10 Pro

Here's the exception incase this means anymore to someone them it does to me.

DAZStudio.exe caused ACCESS_VIOLATION in module "C:\WINDOWS\System32\DriverStore\FileRepository\igdlh64.inf_amd64_250db833a1cd577e\igdrclneo64.dll" at 0033:0000000030EB0819, clGetKernelSubGroupInfoKHR()+50697 byte(s)

 

Sorry it bother you guys, I can usually figure this kind of stuff out myself, but this one has me stumped. Everything was working fine not too long ago, and when I went to check out the Ollie 8 bundle I purchased I strarted getting this every time I try to start up Daz.

Post edited by brimstoneomega on

Comments

  • ig at the beginning of the file name suggests something connected to the Intel graphics driver - does your machine have an Intel GPU integrated with the CPU, as well as a stand-alone nVidia GPU? If it does, check (somewhere in the Control Panel I believe) that DS is set to use the nVidia device.

  • brimstoneomegabrimstoneomega Posts: 313
    edited April 2018

    ig at the beginning of the file name suggests something connected to the Intel graphics driver - does your machine have an Intel GPU integrated with the CPU, as well as a stand-alone nVidia GPU? If it does, check (somewhere in the Control Panel I believe) that DS is set to use the nVidia device.

    Thank you! You were completly right! I went into the nVidia Control Panel and under "Manage 3D Settings" was able to have Daz use the gpu and now it's working again! You're a life saver, thank you so much!

     

    Post edited by brimstoneomega on
  • Glad it worked.

  • mars68mars68 Posts: 2

    I'm getting the same error message, but the nVidia Control Panel for my 1080ti doesn't show any way to force daz to use it. I've tried using DDU to uninstall all graphic drivers (thinking maybe the intel driver was at fault), and doing a clean install for the newest nVidia driver,
    Didn't help. The daz support person had me uninstall/rerinstall daz, but again no help. I can only get a reply from them every two or three days, so it'll take forever to solve it that way.
    Any suggestions would be very much appreciated. SPECS:
    Asus board - 64G ram - 1080ti - Win 10 pro with creators update. All updates current.

  • mars68mars68 Posts: 2

    A friend suggested something that works. I just deleted the dll file the error message points to, Didn;t check to see if daz rebuilt it, but it works now.

     

  • Richard HaseltineRichard Haseltine Posts: 74,193

    You deleted a driver .dll - DS won't rebuild it, snce it has nothing to do with DS, but it may have serious impact elsewhere. That's assuming it really was the same error.

  • I have the same issue exact same error. I have a GeForce graphic card and no where to set DAZ to use it. Afraid to delete a dll file.

  • Thank you! I deleted the DLL and now Studio launches.

  • hphoenixhphoenix Posts: 1,333
    edited July 2018

    igdrclneo64.dll is the OpenCL driver for the Intel Graphics adapter.  If you are not using your Intel Graphics GPU for OpenCL, removing it will stop the issue.  However, it may cause issues if the rest of the system still thinks OpenCL is available through your Intel GPU.  You'll also probably get events logged in your system logs when it tries to load it.

    You would be better off simply uninstalling the Intel drivers, unless you are using the Intel GPU port to drive your monitor.

     

    Post edited by hphoenix on
  • I was having this problem too.  I am using Windows 10 and the 64 bit version of Daz 4.10.  I had an onboard Intel graphics card and have just added an Nvidia card.

    Daz Studio wouldn't start - it didn't seem to make a difference what settings I chose in Nvidia Control panel.

    I couldn't find a way to uninstall the OpenCL drivers but I did find a way to disable it by editing a registry key (found on the Intel Developer forum).

    The registry key for the 64 bit version is at:

    HKLM\SOFTWARE\Khronos\OpenCL\Vendors

    I changed the value for the REG_DWORD with key "C:\WINDOWS\System32\DriverStore\FileRepository\igdlh64.inf_amd64_250db833a1cd577e\IntelOpenCL64.dll" from "0" to "1".

    I haven't tried but the forum said that the registry entry for the 32 bit version is at "HKLM\SOFTWARE\Wow6432Node\Khronos\OpenCL\Vendors".

  • I deleted igdrclneo64.dll and it fixed the problem - and also fixed another program (Vegas Pro 15) which was crashing, too.

     

  • tks for answer this work for me too!!!

    I deleted igdrclneo64.dll and it fixed the problem - and also fixed another program (Vegas Pro 15) which was crashing, too.

     

     

  • where do you find igdrclneo64.dll

  • TheKDTheKD Posts: 2,593

    Try C:\Windows\System32\DriverStore\FileRepository

Sign In or Register to comment.