Very slow viewport performance

ISIKOLISIKOL Posts: 307
edited February 2 in Daz Studio Discussion

hello everybody....im experience lately a very slow performance on the viewport...when using iray.... its extremeley slow even thought i have a powerful computer. I have 2 gpus ..one 970 and one 1080 ti! With an i7 and 32 gigs of ram.... 

i have tried all possible combinations in the render engine settings.... 2 gpus wit optix performace is currently enabled...i also,changed the settings from better to best in the preferences / viewport and still nothing...

is there anything else you propose me to do in order to see any change.? Im on windows 10 pro fall edition....

Even with one simple figure it takes a lot of time to preview and when im just hovering around the figure turns white and then starts loading the textures from scratch....

 

please help me on this....thanks...

 

Post edited by ISIKOL on

Comments

  • algovincianalgovincian Posts: 1,603
    ISIKOL said:

    hello everybody....im experience lately a very slow performance on the viewport...when using iray.... its extremeley slow even thought i have a powerful computer. I have 2 gpus ..one 970 and one 1080 ti! With an i7 and 32 gigs of ram.... 

    i have tried all possible combinations in the render engine settings.... 2 gpus wit optix performace is currently enabled...i also,changed the settings from better to best in the preferences / viewport and still nothing...

    is there anything else you propose me to do in order to see any change.? Im on windows 10 pro fall edition....

    Even with one simple figure it takes a lot of time to preview and when im just hovering around the figure turns white and then starts loading the textures from scratch....

     

    please help me on this....thanks...

    This has happened to me for figures that have a high sub-d - might be worth checking. Robbus Madgloom comes to mind (loads at sub-d 4).

    - Greg

  • ISIKOLISIKOL Posts: 307

    Hello my friend...even with sub d at 1 i have the same problems....

  • algovincianalgovincian Posts: 1,603

    You may try reading through this thread (you're not the only one):

    https://www.daz3d.com/forums/discussion/168856/daz-imposibly-slow-laggy-in-viewport-even-in-blank-scene

    Hope you can figure out what the issue is. BTW, I knew your name looked familiar . . . love your artwork!

    - Greg

  • FishtalesFishtales Posts: 3,445

    Go to Menu Windows/Panes/Draw Settings

    Make sure Draw Style is set for Iray.

    Under Drawing change Response Threshold and Manipulation Resolution until you are happy with the speed. I have them set at 10 and ¼ respectively.

    I hope that helps.

  • nonesuch00nonesuch00 Posts: 9,689

    I'm not using iRay preview for the viewport but openGL texture shaded for the viewport and I had similar problems with extreme DAZ Studio slowness until I make every Windows/Panes/Draw Settings the least intensive setting availble and saved. Now the extreme lagginess is gone.

  • PadonePadone Posts: 517
    edited February 4

    There could be many reasons for the viewport to be slow. I would advise you to start with a simple sphere and add up until you find what's the limit. If even a simple sphere is sluggish then it can only be drivers and/or a Windows update. Of course keeping a single viewport may help as well. Below some suggestions that I believe most useful.

    - Always use a separate gpu for the viewport so to have the main gpu free for Iray. This is the only way for complex scenes to avoid slowing down the response to user interaction. In modern systems, having a good integrated gpu in the processor, it is enough to wire the monitor to the mobo.

    - If the materials in the scene are complex then it helps a lot to use the interactive mode instead of the photoreal. Because the interctive mode itself simplifies materials to achieve a better speed. Of course you will also have a worse approximation, that may not be acceptable to you depending on your needs. So always do a comparison before switching to interactive.

    - In render settings set max samples to a reasonable low value to avoid unnecessary overloading of the gpu. In most cases 128 or below are good enought to have an acceptable representation in the viewport. Also it helps to set a low value in max ray bounces (for interactive) or max path lenght (for photoreal). In this case also you're manipulating the viewport quality to get speed so be aware of it. If you see strange things happening such as eyes turning black it may be necessary to allow for more bounces.

    Post edited by Padone on
  • I know this thread is old, but once again I was looking for a solution to this problem and didn't find the answer on the forum.  However, I did find one cause of slow viewport response and that was related to the Aux Viewport.  If the Aux Viewport is set to iRay, then it'll impact the response time of the default Viewport even when you're not looking at the Aux Viewport.  So, click the tab for Aux Viewport and make sure it's set to the fastest preview mode, then close the tabe if you're not using it.  Hope this helps somebody...

Sign In or Register to comment.