dForce items disappear during simulation

I've been having a lot of fun with dForce and started to model clothes to take advantage of it. However, while some of my clothes sim perfectly, others sometime (and only somes) totally fail. The simmed parts disappear. In the chaps below, the top garter/belt part has simulation strength set to 0, while the rest was set to 100%. I used custom settings I'd successfully used in an earlier draft of these pants. The second pic shows what happens the moment the simulation starts. I've had this problem with a dress, as well. Restarting and reloading the scene doesn't help, although the problem doesn't appear to be persistent if I bring in a saved wardrobe piece. All of the simulated geometry is the same mesh and connected to part of the frozen geometry (there's a belt and button over the garter that's unconnected; on the dress everything is a single, connected mesh). 

I tried resetting the material simulation settings to default, reloading, and restarting and none of that fixes the problem. The mesh is light and doesn't blow up during simulation. Any suggestions about how to fix this?

Screen Shot 2018-01-03 at 12.54.24 PM.png
668 x 675 - 215K
Screen Shot 2018-01-03 at 12.54.10 PM.png
699 x 666 - 195K

Comments

  • I get this as well. Only thing I can think of is that it's exploding so completely that it just vanishes.

  • Are you able to save the scenes after you encounter this? I havne't had much luck

  • Have not bothered saving the scene until I rest the sim. I don't think it's safe to save with an exploded mesh.

  • nonesuch00nonesuch00 Posts: 8,897

    I have same trouble with some clothing.

  • I kind of solved the problem by editing my mesh. Finding out what's causing the problem is difficult. My mesh was all quads, so there wasn't any obvious candidates for cleaning up. I took parts and sections out one at a time, tried simming it again (with just the mesh plus a ground plane to make it faster) and eventually identified a problem area I could delete. Thanksfully, for this, at least, it doesn't blow up my whole model. But annoying!!!

  • Studio94Studio94 Posts: 18

    I'm having the same problem - it would be good to try and figure out some sanity-check that can be applied to meshes.  Did you identify *what* was wrong with the bit of mesh you deleted?

  • Studio94Studio94 Posts: 18

    so minor update(s) 

    1) there no log entries for the problem

    2) Taking a simple single quad surface (with apparently all correct normals, from looking in Hexagon - although I guess it's easy to miss something tiny).

      - post-vanishing, I exported it as a .obj - all the vertices seem to have been transformed to a triplet of nans, UVs, faces etc are still correct.

    (doesn't help figure out where the mesh is broken, unfortunately).

     

Sign In or Register to comment.