Why is the shaded and nondescript darker areas of my Iray renders grainy and pixellated?

I'm impressed by the realism of the lighted areas of my Iray outdoor scenes (Palm Island, Summer Island) and use the palm Island sky/light dome and it works great for replicating outdoor lighting. . However, it is grainy in the shadows, making an otherwise great looking image compromised. Is there a way to remedy this? I render large to capture detail but i get  "grey noise" wherever the sun isn't shining directly on the objects.

Comments

  • The shaded areas are sampled less often and so aren't consistently lit, depending on exactly which path hit them. The only in-render fixes are longer renders or more light in the shadows (and then use Tone mapping to bring the result back where you want it ). Another option is to render larger and then downsample in an image editor, averaging out the noise.

  • Somewhere deep in the bowels of the program is a way to set the Shadow details. I forgot how to get there, as it seemed a bit Dark Webbish to me, and I know me: I'll break stuff LOL

  • BrycescaperBrycescaper Posts: 123

    If I increase the sample rate, the render would take longer, but would that help the graininess? What about lighting resolution? Would a higher resolution help smooth things out, or would either 'overexpose' and wash out the bright areas? I'm used to HDRI through Bryce but Iray seems like a different animal altogether. I always render large for detail and to my dismay the graininess is not smoothed out by increasing the render size. 

  • TheKDTheKD Posts: 845

    Yeah, basically you either got to render longer, or use something like ghost lights. For final renders, I ususally put min samples up to max, go into max sample options, add a few zeros and max that out. Turn time to 0, to take that out of the equation, and turn quality off. Then I let it render until it looks good enough. Outdoor scenes are usually not that long, indoor scenes without any help from ghost lights, or hiding walls ceilings and letting in some HDRI light take a lot longer.

  • Render even larger then downsize afterwards.

    Or, right-click on the Render Settngs tab and select Show Hidden. That's where the Shadow details are.

  • TheKDTheKD Posts: 845
    edited January 14

    Or, right-click on the Render Settngs tab and select Show Hidden. That's where the Shadow details are.

    Ugh, more hidden and undocumented stuff lol.

    Post edited by TheKD on
  • TheKD said:

    Or, right-click on the Render Settngs tab and select Show Hidden. That's where the Shadow details are.

    Ugh, more hidden and undocumented stuff lol.

    The settings are hidden when Photoreal iss et as the render mode - if you set the render mode to interactive they will be unhidden (and will actually do something useful).

  • TheKDTheKD Posts: 845

    The settings are hidden when Photoreal iss et as the render mode - if you set the render mode to interactive they will be unhidden (and will actually do something useful).

    Oh, so they don't actually do anything in photoreal mode? Then I guess they are hidden for a reason then! I was a bit wary of playing with them anyways lol, shadows are usually OK as is now, and didn't wanna mess it all up.

  • Interactive allows some options that are more like the biased rendering of 3Delight, including the ability to turn shadows off, but at the expense of disabling some other features, emissive surfaces for one - which seems pretty much a deal-breaker to me.

Sign In or Register to comment.