What the flark happened to the moon?

I've had no problems making spherical suns or moons before, but somehow, Bryce decided to play dirty with me.  I'm trying to render a nice moon over the horizon with a few clouds for a Daz background, but the moon isn't round this time.  It's more of a mangled meatball.

 

You can see in the one render how the sun is round despite the haze, but the moon, despite being in a similar position, doesn't want to cooperate. Is there some distortion in the atmosphere, viewing angle, or the camera I need to compensate for somewhere? I've left everything at the default settings except cloud cover and the size and texture of the moon, so I'm stumped.

Any ideas, Jedi masters?

Road trip to nowhere.jpg
3840 x 2160 - 8M
Moon test.jpg
1274 x 695 - 228K

Comments

  • ChoholeChohole Posts: 28,691

    Can you show us a screen shot of your sky lab, on the sun and moon section

     

  • HoroHoro Posts: 6,016

    It may be that the camera FOV is wide, then if any sphere is off the centre it gets distorted. Put the moon in the middle and/or reduce camera FOV and set Scale to 100% to verify. If the moon gets round, get back to the original settings and see whether you can adjust by offsetting camera Pan H.

  • JamahoneyJamahoney Posts: 1,527

    Yes, as Horo, suggests...I thought that the fov was the issue (click on the camera/perspective 'A' properties - usually, set at 60, but 80 is better).

    You can set Bryce to retain these properties - camera fov, position etc.,,- on normal launch, but I don't have the details, as such, but it is simple.

    Jay

  • Part of my problem is that I wasn't using a camera (not to my knowledge, anyway); I can see the camera sitting in the middle of the workspace--the second screenshot is what I typically see on any of my work--and I generally don't use the camera because I can't figure out how it works.  Because I've been using just the regular view in the workspace, I was surprised to see any kind of distortion.

    If I put it dead center as in #3, it's all good, of course. But with no camera in use, what would I be doing to cause distortion like that?  Or does the default view work as a camera on its own?

    To make things even more confusing, without touching any settings other than to view through the camera and move the FOV so that the moon is a little more to the left, it doesn't seem to be distorting as badly, if at all. 

    Sorry about the first two screenshots. I have two monitors and right now I'm too lazy to crop the images.

    Bryce screenshot.png
    2720 x 1024 - 3M
    Bryce screenshot 2.png
    2720 x 1024 - 4M
    Moon test.png
    1274 x 695 - 460K
    Moon test 2.png
    1274 x 695 - 294K
  • HoroHoro Posts: 6,016

    You are using the Directors camera, not the normal camera (click on the director's seat below left of the small preview to switch to the normal camera. FOV (field of view) is a function of focal length and a real camera with a lens with a short focal length (e.g. 24 mm) distorts towards the edges. This is not the case with longer focal lengths - a "normal" lens has 50 mm.

    By the way, you can save a picture from the application only to the clip board. Select Bryce (or whatever), hold down the CTRL and ALT keys, then hit the Print Screen key. This saves the application window, open a graphics application, create a new image and CTRL-V (paste) it.

  • S RayS Ray Posts: 179

    If you still want to use the director camera's view. Click the drop down arrow below the camera view arrow. Then do a camera to director command. This will place the camera at the directors ( default view ) Then you can adjust the FOV on the camera as Horo described.

  • JamahoneyJamahoney Posts: 1,527
    edited December 2017

    You'll also get distortion occurring while in Camera view: if you accidentaly/intentionally clicked the zooming-out icon (the '-' spyglass in the bottom right-hand of Bryce's screen).

    To correct, you might have to click the zooming-in icon ('+' spyglass) once or twice again, but then you will have to re-position the moon again on your Bryce screen (using Ctrl, Shift and Alt clicked together, while clicking on the screen with your mouse cursor).

    Jay

    Post edited by Jamahoney on
  • Jamahoney said:

    You'll also get distortion occurring while in Camera view: if you accidentaly/intentionally clicked the zooming-out icon (the '-' spyglass in the bottom right-hand of Bryce's screen).

    To correct, you might have to click the zooming-in icon ('+' spyglass) once or twice again, but then you will have to re-position the moon again on your Bryce screen (using Ctrl, Shift and Alt clicked together, while clicking on the screen with your mouse cursor).

    This might be what got me.  I'm thinking I may have accidentally tweaked something without knowing it. The instructions don't quite match up with the version of Bryce I have so I end up clicking things to see what happens.

    But I did get the moon to look better...

    Honey test 1.jpg
    515 x 713 - 274K
  • HansmarHansmar Posts: 1,242

    Yes, you have got it. Nice render.

Sign In or Register to comment.