Can't edit my own categories after re-importing metadata on new computer

Okay, so I finally got a new rig (yay!) and have successfully configured the library (on an external drive) and DIM to find all my content. (There will be a few plugins to re-install, but no big problem). I exported the User Data from the old machine, where I had been categorizing everything, and re-imported into the new machine. It all shows up in the right places, as it should (whew!) but I cannot move or rename any folders that were imported. I can make new categories and edit them no problem, but not the stuff that was restored, like it's read-only. Not what I was expecting.

I installed D|S 4.10 clean on the new machine, and the export was from another running D|S 4.9 (last version).  I had done it before on another machine months ago to try it out, but never worked on it after. I checked, and it has the same problem (can't edit imported user categories), and it is running D|S 4.9, too.

Help?

Comments

  • FixmypcmikeFixmypcmike Posts: 19,013

    What OS?  I haven't seen this before on reimporting User Data into a clean database.  Is it possible DIM or DS were run with elevated privileges (e.g. Run as Administrator on Windows)?

  • NorthOf45NorthOf45 Posts: 3,543

    Win10 64-bit on all three. Never changed privileges, everything was always installed "as-is". D|S and postgres are always running with me as the user, as reported by Task Manager. I did try copying a branch, and it is editable, but I can't remove the original. The folder icons in the imported data are a lighter grey, like the default category folders, with no "U" on it (I assume U is for User). The folders I create are darker with that U at the bottom.

  • FixmypcmikeFixmypcmike Posts: 19,013

    Are these folders inside the Default hierarchy or outside of it?

  • NorthOf45NorthOf45 Posts: 3,543
    edited November 2017

    Outside. Here's a little snippet of the Content Library pane. The "MyCategories" folder is imported from User Data. The "MyNewCategories" folder is one I created new. I have full read/write access to that, but read-only on "MyCategories".

    edit: Just noticed that the Delete selection in available on the imported libraries, but haven't tried it (no undo function). I could just copy them all to the new folder and delete the old ones. Just worried about that many operations in the database all at once. I'm talking around 6000 products, so 10's of thousands of file references. I could do a sub-category at a time.

     

    Content Librarysnip_000.JPG
    422 x 155 - 15K
    Post edited by NorthOf45 on
  • NorthOf45NorthOf45 Posts: 3,543

    Okay, copied everything to a new category tree and deleted the read-only one. I did it one subcategory at a time, but only took about an hour. Everything is back to normal, still, not the kind of thing I want to do often.

  • FixmypcmikeFixmypcmike Posts: 19,013

    How exactly did you export and reimport the user data?

  • NorthOf45NorthOf45 Posts: 3,543

    Export: Content DB Maintenance => Export User Data

    Import: Content DB Maintenance => Re-Import Metadata... => wait... => select everything (User Data, Products, user data overrides product data selected) => wait...

    I mentioned that the library is on an external drive. This particular one is a NAS drive (so I can access it from different machines, even remotely if I need). Internally it runs a Linux OS, but is completely transparent to the user. I just use it as a mapped network drive (has to have a standard drive letter for DIM, named volumes don't work, I discovered).

  • gitika1gitika1 Posts: 888

    I have experienced this as well. I got to the situation in the same manner as North.

    What prompted me to export my user data and re-import was that as my product volume has increased, I found I did not create categories in the best manner.  I made adjustments and referenced the product to the new category, but then the new reference would have duplicates of all of the files displayed in the folder.

    i.e. a dress for Genesis 8 was in the wardrobe for G8 category; then I decided it was necessary to further divide the wardrobe.  I created the subcategory 'Dresses', referenced the dress to there, deleted it from the G8 wardrobe category.  However when going back to dresses, the folder for that specific dress has/had two of each item - each pointing to the exact same file/location.

    I exported my data; reset the database, imported my data and now the categories are locked.  Noting the example in this thread, I am able to create a new directory and copy my categories there.  Unfortuanately, random products end of with the duplicate references again.  So it turns into a cycle ...

    Where else is the reference stored?  What am I missing?

    I have spent more time trying to organize content, then rendering =P

  • gitika1gitika1 Posts: 888

    Fixmypcmike - in another thread, you said that you edit the data in the user data file.  I am curious as to your method.   Actually, I would love to know more!!

    I have played around with opening it in both in notepad (wordpad would crash) and excel.  Excel displayed it quite nicely.

    If you would care to share your knowledge - it would be most appreciated.

  • cridgitcridgit Posts: 1,328

    I have exactly the same issue and reported it as a bug. Exported USER DATA should not be treated as VENDOR DATA when it is reimported which is what DAZ Stu(pi)dio seems to be doing. It should reimport USER DATA as USER DATA and make it editable. I'm fine if it doesn't want me to change the Default categories but don't tell me I can't change MY OWN darned categories.

     

  • NorthOf45NorthOf45 Posts: 3,543

    Duplicate entries can happen one of at least two ways. One is that CMS mishandled the metadata somehow and entered it more than once. I have had this happen when uninstalling and re-installing products, but it doesn't happen very often. Another is that some files are included in more than one product, but installed to the same place. You only see the last one, but there are entries in the database for all instances. When making references to those files, like in custom categories, you get a reference from each product that installed it.

    I have tried various methods of removing the duplicates, all successful, but with varying degrees of difficulty and confidence. (This is by no means a definitive guide, just what I have gleaned from the, um-m, experiences others have had). You can edit the metadata (right click on a folder in Content Library, or use Content DB Editor from the "hamburger" menu on the Content Library pane) one folder at a time to see which categories each file is in to remove the redundant or obsolete ones. There are some options in there I should probably familiarize myself with, so I'm not sure what the implications are. (Sync Product and LocalDatabase, Purge unlisted Assets from the Local Product Definition, Purge unlisted Categories from Local Asset Definitions)

    You could Export Metadata Per Product, which gives you a small xml file (similar to UserData, but easier to work with). You can remove the lines with those offending categories, which is basically what editing the metadata in D|S does, and re-import that mini-file, which should clear up the duplicates, unless they were in fact installed by different products.In that case you will get one xml file per product, not one file with both products.

    The UserData files go up to about 32MB each (my library is up to 4 exported files now), so a pretty hefty text editor would be needed (I use notepad++). I haven't actually modified the big files, since importing them goes back to the original problem of not being able to edit the User categories in Studio after restoring UserData in the first place :-\

    I have also found that if there is any trace left of a product after uninstalling it, I go to the Products heading and delete the sticky product from there, either under the product name or in the lost and found. That should remove any remaining orphaned references to a product that shouldn't be there any more, since you uninstalled it. It should be clean the next time it is installed.

    Whatever you try to do, I suggest making a new library with a small subset of some problematic products to practice on. You can have more than one set of libraries (Content Sets in Content Directory Manager) so you don't mess up the data you use now (only one Content Set can be active at a time). Just manually install/copy/unzip whichever products you want to fix (you'll probably need some prerequisites, like Genesis "whichever" Essentials) to a new library folder, include that in the directory list for the new Content Set and refresh the new library in the Content Library pane. When you've got a method that works, you can try it on your main library (Content Set).

    Okay, I think that hole is deep enough for now...

  • gitika1gitika1 Posts: 888

    Thanks North :)  I appreciate the time you spent sharing your experience(s).  The next time I find a product that goes rogue, I will look through the suggestions you have provided.

     I have found that if I export my user data, reset the database, and then import the user data and metadata; the amazing reproducing products disappear.  Of course, then my user data is no long "U" or editable, so I have to duplicate all of the categories.

     

Sign In or Register to comment.