White dots in renders

Orpheus13Orpheus13 Posts: 274

Hello,

Sometimes I get some white dots when I render to 2D (with Iray and some lights) and I don't know why. You will see it in the hair of this character, I'm not talking about the small bleed-out on her shirt.

Any idea why and how to remedy that ?

Tara Happy Punk.png
1000 x 769 - 288K
Post edited by Orpheus13 on

Comments

  • What's your lighting like? There's also a white speck on the lips, in just the right place for a bright light somewhere behind the camera. There are a few things that can cause this; over-glossiness on the lips and hair (incidentally, are you sure the hair has proper Iray materials?), the lighting setup needing a bit more adjustment, possibly the render should be given a bit more time to run.

  • ToborTobor Posts: 2,300

    Those are fireflies, which are usually caused by issues related to specular lighting and materials with a bright-white glossy setting.

    One thing you can do is double check that the firefly filter is turned on in the rendering panel. Another is to tone down any 100% white high-gloss textures. And yet another is to move the position of the light(s) a bit.

    Here's a post on another site that offers some generic advice for reducing/eliminating fireflies in Iray. (The link to the firefly removal script won't help you, as that's for another program.)

    http://www.designimage.co.uk/iray-performance-tips-to-reduce-fireflies/

  • Thank you, this will be useful. I've got quite a lot to learn, had to be sure this was coming from the lights.

  • And yes, it's quite possible that I put RSL versions of hair and lips, which would explain it I guess.

  • ToborTobor Posts: 2,300

    D|S will auto convert 3DL textures to Iray textures at the time of render, so Iray is getting its proper shaders. But it's better to convert these yourself (use the Iray Uber base shader), which then gives you Iray nodes to work with. You can then tweak the shader dials to suit.

  • Hey, everyone ! I had a lot of white/yellowish dots in my renders, especially at night. And I fixed the problem, at least in my particular renders. I was going crazy and ready to pull  my hair out !! And give up Daz studio but I figured it out !! Here is how I did it !! I had night render city scenes. I put sky domes such as Orestes Darkest night and had buidling lights and everything and still white/yellowish dots came out in my renders like grainy pictures !! What the heck ?!! Finally I stumbled on this blog. And in my experience it was the fireflies setting in your render settings !! The guy called Tobor above was right, at least with my render experience. I guess it depends on what you are doing. So I went to my render settings, then select filtering. Make sure firefly filter is enabled. Then I went to my nominal luminance and turned it up to 2, and white/yellowish dots on my renders, especially night ones are gone !! Hell yes. Thank you, Tobor, for leading me the way !! 

  • Thank you, Frankanz5!  I was having firefly trouble myself and had the filter on, but didn't know about that luminance thing.  Changing that setting helped make my latest render look way better, and it only took a little over 20 minutes to make.  Thus, I think that may have solved another problem I was having: my renders taking over an hour to make.

  • There are quite a few reasons for fireflies, most of them can be fixed by adjusting the nominal luminance setting in the firefly filter. If the image has too little light fireflies will appear and can be fixed by  increasing the nominal luminance to 10, 100, etc. If the image has too much light, shadow areas can produce fireflies, in which case reduce the nominal luminance to 0.1, 0.01 etc. Setting it too low ie 0.0000001 will render black.

  • There are quite a few reasons for fireflies, most of them can be fixed by adjusting the nominal luminance setting in the firefly filter. If the image has too little light fireflies will appear and can be fixed by  increasing the nominal luminance to 10, 100, etc. If the image has too much light, shadow areas can produce fireflies, in which case reduce the nominal luminance to 0.1, 0.01 etc. Setting it too low ie 0.0000001 will render black.

    Excellent stright forward info and this solved my render issue.  Thank You codex34_f5f1fb6f55!!!

  • nelsonsmithnelsonsmith Posts: 1,288

    VERY useful post,  with solid examples on what can fix the problem under certain conditions.  I wish more questions could get answered in such a straightforward manner.

Sign In or Register to comment.