Scalp on certain hairs showing on face as grain shadow

Hi. I have a few male hairs designed for Iray that when rendered produce a grainy shadow in the area where the clear part of the scalp is on the face right before the hairline. I know it is the scalp because it is in the exact shape of the scalp and if I hide it the problem goes away. It seems that something isn't quite as transparent as it should be. Is there anything  I can do to correct the problem?

 

 

«1

Comments

  • Serene NightSerene Night Posts: 13,998

    I have tried using geometry editor to make a hidden surface of the offending bit. But geo-editor can't really make a smooth cut on the scalp so it looks rather raggedy.

  • FishtalesFishtales Posts: 3,846

    I had that Problem and found it was the lighting. I got around it by moving the character or the light direction and it disappeared. Thinking back now it was probably something to do with a difference between the skin settings and the scalp settings but I never tried that. I did try shrinking the scalp but, if I remember correctly, that only partly helped.

  • Serene NightSerene Night Posts: 13,998

    I think it is more visible in shadow and dark scenes.... But it is definitely an artifcat of the transmapped hair scalp. It doesn't help that those scalps seem to be really big and cover half the forehead and way down to the cheekbones. It makes for a large gritty area.

  • IsaacNewtonIsaacNewton Posts: 1,015

    I have had this issue with several "hair items" with head caps, over a number of years. I have never found a proper solution. Some lighting situations/positions reduce the effect somewhat, but it is definitely a bug and about time it was fixed.

  • Serene NightSerene Night Posts: 13,998
    edited August 2017

    Here are some examples. you can see the textural difference enough, since the dark side of the face looks pretty good and so does the ear.. It isn't that the shadows haven't converged. It is a weird grainy jpg artifact look. I get it on all my transmapped scalp hairs. It is very noticible when you want to add filters in photoshop. It shows as scratchy shadow area where the scalp sits on the head.

    image-1.jpg
    2000 x 2286 - 5M
    image-2.jpg
    2000 x 2286 - 5M
    Post edited by Serene Night on
  • barbultbarbult Posts: 11,364

    I've seen similar issues, but in my case it disappeared with additional rendering iterations to reach higher convergence. Try a small spot render of an area including the transition area and let it render for a lot of iterations to high convergence. Does it look OK?

  • dawnbladedawnblade Posts: 966

    Not sure if this is at all related, but I ran into an issue in Iray with dark shading from hair on the face if the character was moved far away from 0,0,0.

    See here and @barbult's answer that saved me from pulling out my own hair: which is basically keeping your character at world center, and moving your props.

  • SimonJMSimonJM Posts: 5,121

    Could it be to do with Iray trying to honour the various SSS, etc., settings of the scalp (probably very similar to that associated with the rest of the hair) so you don't see the actual scalp, as such, just evidence of it being there - analagous to looking through a thin sheet of glass?

  • Serene NightSerene Night Posts: 13,998
    edited August 2017

    @SimonJML Iray certainly thinks something is there. It is casting a blurry shadow of some sort. Something that it detects and doesn't handle well. Because these scalps are also huge, the area of artifacts, is just not liveable. it  covers most of the cheek, half of the forehead. If the cap area was tinier this would be less of an issue. I could live with it closer to the hairline.. But not all the way down on the cheekbone.

    @ barbult: I've tried re-rendering the scalp area via spot. That sometiems works. But not always. Didn't work here..... But is not a guarateed method to get rid of the artifact look, especially in darker renders. It looks like some form of shadow is being cast, which to me is a bug. That area is supposed to be invisible and should not require special rendering techniques to get around. I basically have to re-render this character twice once for the scene, and once to try to hide the weird scalp shadow. It is simpler to re-render without the hair at all- and faster. Although you miss the shadows the hair provides and have to combine them in post.

    @ Dawnblade: I always render my characters at zero. I bring the environment to them. =-) It saves me time wtih lights and everything else.

    The only thing I am thinking of doing is just painting the scalp area on the character. Unfortunately, with the way g3m head area is made.... It is very difficult to detrmine a good natural hairline. Maybe I can somhow transpose the shape of the scalp texuture on the character's head.

     

     

    Post edited by Serene Night on
  • FishtalesFishtales Posts: 3,846

    That looks better than the one I had :)

     

    traveler-009.jpg
    1496 x 997 - 645K
  • Serene NightSerene Night Posts: 13,998
    Fishtales said:

    That looks better than the one I had :)

     

    oh dear! Well, i'm glad I'm not alone, but sad to see you too are having this issue.

  • Wendy_CarraraWendy_Carrara Posts: 19,812

    you could create just a scalp with the geometry editor, subdivide it a lot and edit that, and then hide the original on another load of the hair.

    It probably is the ambient and or specular channels etc causing it, you really only want diffuse, bump and opacity.

  • FishtalesFishtales Posts: 3,846

    I returned to it after I posted and tried changing the scalp settings to match the skin but it didn't make any difference.

  • barbultbarbult Posts: 11,364

    One other thing you can check is to be sure the opacity map for the scalp is grayscale (not RGB) and has a gamma of 1 (or 0, which Daz Studio will interpret as 1 if the image is grayscale). You can convert an RGB to grayscale in Photoshop. Also, be sure the "invisible" area of the map is pure black.

  • Serene NightSerene Night Posts: 13,998
    barbult said:

    One other thing you can check is to be sure the opacity map for the scalp is grayscale (not RGB) and has a gamma of 1 (or 0, which Daz Studio will interpret as 1 if the image is grayscale). You can convert an RGB to grayscale in Photoshop. Also, be sure the "invisible" area of the map is pure black.

    Neither hair was gray scale. Both were RGB. I converted them to grayscale. the cutout area is black, but this did not alter the scalp issue it looks like it was before.

     

  • barbultbarbult Posts: 11,364

    My bag of tricks is empty. sad

  • RedzRedz Posts: 1,322

    I can't seem to replicate the issue, though I have seen the cap issue when the figure is a distance from zero. However I recall also having an issue with a hair for Dusk. I seem to remember that the cap fit needed adjustment in that case. Two suggestions. Turn glossy layered weight to zero in case it's a glossy/reflectivity issue. The other would be to expand the cap a little using the fhmexpandall morph (for short cropped hair in your example) by a percent or two in case it's an issue of the skin and cap sharing the same space and iray not liking it. Failing that if you could share your light settings I'll try to recreate the problem. 

  • Serene NightSerene Night Posts: 13,998
    th3Digit said:

    Iyou could create just a scalp with the geometry editor, subdivide it a lot and edit that, and then hide the original on another load of the hair.

    It probably is the ambient and or specular channels etc causing it, you really only want diffuse, bump and opacity.

    I don't have the talent to create anything in geo editor I'm afraid. I need some texture there on the scalp- otherwise the fibermesh looks mangy.

  • Serene NightSerene Night Posts: 13,998
    edited August 2017
    Redz said:

    I can't seem to replicate the issue, though I have seen the cap issue when the figure is a distance from zero. However I recall also having an issue with a hair for Dusk. I seem to remember that the cap fit needed adjustment in that case. Two suggestions. Turn glossy layered weight to zero in case it's a glossy/reflectivity issue. The other would be to expand the cap a little using the fhmexpandall morph (for short cropped hair in your example) by a percent or two in case it's an issue of the skin and cap sharing the same space and iray not liking it. Failing that if you could share your light settings I'll try to recreate the problem. 

    Thanks for offering to help. I have had this issue for a while. Not just with this hair, but with other hairs too which use scalp technology especially with darker skins and certain lightss. where the scalp cap is visible. Altering the glossy layer weight did not do anything discernable. Making the scalp bigger by 2-10 an -4  percent likewise no discernable difference.

    Lights used here are:

    1. Emissions props (neon light)

    2. JM Promo lights number 1

    3. Ultragenesis HDRI Bokeh set light 001 

     

    He is at zero but his y-tran is at 9.31. It made no difference to move him up or down to the artifact quality of the scalp.

    I have tried to parent the hair to the scalp from funky hair- which is Boyd's usual hair. It does the same thing but a bit less as the scalp cap is smaller.

     

     

    scalp.jpg
    664 x 788 - 276K
    Post edited by Serene Night on
  • RedzRedz Posts: 1,322

    Thanks Serene, I've tried a few test renders with an approximation of your light settings. At lower iterations I can see the grainy pattern clearly, but when the render is allowed to run to completion (95-100% converged with default Iray settings) the grain resolves completely. I can't see a difference between 1500 iterations and the render with no hair cap. Your render is darker and has emissive geometry, plus as you say different skin and environment settings may be having an effect. My suspicion is that the render needs more time/samples to converge completely, or more light in the scene. There are lots of posts about dark scenes and mesh lights making it difficult to achieve full convergence in Iray. I don't think the issue is with the opacity maps, as replacing them with a pure black image makes no discernable difference. I'm sorry I can't shed any more light on the problem (no pun intended).

    However, you can hide the offending parts of the cap using the geometry editor quite easily. Select the cap and switch to Wire shaded view. In tool settings (Window-Panes-Tool Settings) choose Geometry editor and in the viewport select the faces on the scalp you wish to hide. Right click on surfaces and select create surface from selected, then click the eye icon beside your newly assigned surface to hide the geometry. You can add or remove more faces by right clicking the new surface. This is also a handy technique for hiding hair under hats and hoods, and well worth learning IMO.

    CapOpacityTests.jpg
    2000 x 3000 - 4M
    geoeditor.jpg
    1218 x 783 - 422K
  • SimonJMSimonJM Posts: 5,121

    I have this hair and have tried ro replicate the issue and have, thus far, failed.  I looked at the surafces andd note that teh Scalp material zone has, amongst other things, an Opcaity map and a Bump map.  Try dialing Cutout Opacity down to 0 and changing Base Bump to none.

  • Serene NightSerene Night Posts: 13,998

     

    SimonJM said:

    I have this hair and have tried ro replicate the issue and have, thus far, failed.  I looked at the surafces andd note that teh Scalp material zone has, amongst other things, an Opcaity map and a Bump map.  Try dialing Cutout Opacity down to 0 and changing Base Bump to none.

    I'll try this. haven't try changing the base bump. 

    @redz making a new mat zones and making it hidden  was one of the first techniques I tried but I found the scalp cap was very jagged when I tried to do this so it was hard to get a smooth line close to the hairline . I do want the scalp just not the rest as I think the hairline is one of the better caps I've used and actually has a male hairline but most scalp do have a lot of facial overhang and this one is pretty big.

    I do think it is lights as i have the issue with other scalps not just yours  but I am  mystified why Iray can't process the clear parts of hair as it should be doing. I do allow for full convergence quite often and still have the same issue. Not just this hair it other scalp hairs Yes probably cooking it forever would improve things but it should be able to handle this process. I want to be able to use dark scenes with men with short hair in them.at any rate I have tried spot rendering the hair too and not gotten any better results

     

  • fastbike1fastbike1 Posts: 2,894

    This looks like another one of thoses problems that only affect certain systems under certain conditions, thus making it virtually impossible to trace.

    I have run several test on identical products, environments, lighting and position when others have reported similar issues and don't have the same problems.

    There does seem to be a connection to the lighting/position for some cases since a schange in position/angle has made the problem disappear.

  • Serene NightSerene Night Posts: 13,998
    edited August 2017

    The base bump on the scalp  is not active  as far as I can see nothing is selected and I changed the value to zero. Dialing cutout opacity to zero and it still renders pixelated. Hiding the scalp using the eye option does remove the scalp and resolve the artifact issue.

    The problem still is the scalp interacts oddly with Iray and certain lights. I don't feel it is specific to my computer as the same problem existed on my previous computer there clearly is something that Iray has a problem with involving certain lights and the scalp mat. Unfortunately I own many hairs that use scalps as a base.

    Post edited by Serene Night on
  • One thing I noticed is having a light and an environment/sun+sky sometimes causes it.  When I removed the point light and just used the environment or sun+sky the problem went away even though I made no changes to the surface for the scalp.

  • SixDsSixDs Posts: 2,040

    Hi. I haven't had experience with fibremesh hairs, which I believe this is, am I correct? If so, is the fibremesh hair itself actually part of (i.e. grown from) the scullcap mesh? Is the hair itself treated as a separate material zone from the scullcap/scalp?

  • Serene NightSerene Night Posts: 13,998
    edited August 2017

    I encounter the issue with hairs that use the scalp technology in certain lighting.The scalp is showing up.. Not sure why.

    Post edited by Serene Night on
  • IceColdRender-erIceColdRender-er Posts: 1
    edited May 2018

    I've been grappling with a similiar issue in Daz Studio 4.10, I don't know if it's the same issue you all are having, but when hairs have a scalp it is visible and casts a dark shadow on the forehead head. I searched and found another topic about this, also with no real solution. But then I started playing with sliders on the surfaces tab and I found a solution:

    Select the hair in scene > Go to surfaces tab > Select the hair > Select the scalp > go to volume > scattering > 1st: change the 'SSS direction' to 1.0,  2nd: Rasie the 'SSS Amount' until you see the darkening on the forehead disappear (the default is 0 I usually only have to go to 0.010 or so). SSS Mode should be 'Mono' and 'Scattering Measurement Distance should be 0'

    I hope anybody who has this issue can be helped by this as well.

    Update:

    Depending on the skin you might see some increased noise or blue to white speckles appearing on the face of the character when you used these settings. It has never been so much I couldn't emliminate it with oversampling but it's worth noting. Perhaps add as little SSS as needed to fix the issue? Also with some hairs changing the SSS mode from chromatic to mono was enough to fix the scalp issue.

    Post edited by IceColdRender-er on
  • This is my first post in here and I wanted to thank everyone for all of the information I've read over time.

    I wanted to put my 2 cents in just in case someone is in the same boat as me. I have been having a similar issue with any hair/scalp on any different models/skins and I couldn't figure out what was up.

    To speed up viewport rendering, I know I like to enable the Interactive setting in render mode (in the render settings), but once I rendered using Photoreal instead, I was not able to recreate my issue.

    I'm guessing you may've checked this but it definitely resolved my issue on rendering. Viewport still shows the discoloration though. This may be a dumb issue I'm having and it might not be related with this post.

    First is a Render from Interactive Mode, then a render from Photoreal, then the Viewport:

    Interactive01.PNG
    1120 x 761 - 1M
    Photoreal01.png
    1119 x 762 - 1M
    ViewPortView.PNG
    1136 x 794 - 1M
  • Ashedraz3rAshedraz3r Posts: 2

    I've been grappling with a similiar issue in Daz Studio 4.10, I don't know if it's the same issue you all are having, but when hairs have a scalp it is visible and casts a dark shadow on the forehead head. I searched and found another topic about this, also with no real solution. But then I started playing with sliders on the surfaces tab and I found a solution:

    Select the hair in scene > Go to surfaces tab > Select the hair > Select the scalp > go to volume > scattering > 1st: change the 'SSS direction' to 1.0,  2nd: Rasie the 'SSS Amount' until you see the darkening on the forehead disappear (the default is 0 I usually only have to go to 0.010 or so). SSS Mode should be 'Mono' and 'Scattering Measurement Distance should be 0'

    I hope anybody who has this issue can be helped by this as well.

    Update:

    Depending on the skin you might see some increased noise or blue to white speckles appearing on the face of the character when you used these settings. It has never been so much I couldn't emliminate it with oversampling but it's worth noting. Perhaps add as little SSS as needed to fix the issue? Also with some hairs changing the SSS mode from chromatic to mono was enough to fix the scalp issue.

    Thanks for the tip. This fixed the issue for me I had since ages. :) SSS amount to .001 and I left the other settings to default did it for me. blush

    This is my first post in here and I wanted to thank everyone for all of the information I've read over time.

    I wanted to put my 2 cents in just in case someone is in the same boat as me. I have been having a similar issue with any hair/scalp on any different models/skins and I couldn't figure out what was up.

    To speed up viewport rendering, I know I like to enable the Interactive setting in render mode (in the render settings), but once I rendered using Photoreal instead, I was not able to recreate my issue.

    I'm guessing you may've checked this but it definitely resolved my issue on rendering. Viewport still shows the discoloration though. This may be a dumb issue I'm having and it might not be related with this post.

    First is a Render from Interactive Mode, then a render from Photoreal, then the Viewport:

    Thanks. This works as well. laugh

Sign In or Register to comment.