MCSketch wont open node visually

I made a huge node in MCSketch.

Now, MCSketch refuses to open it visually and suggests to open it textually. As things are going, I don't have a backup and I would like to add some nodes without spending several hours rebuilding this UI.

Of course, no tool is offered to open it visually...

Does anyone has had this issue and, if so, is there a solution available? I could infer most of the file structure (still some parts obscure to me at the end of the file). Does anyone have information on that file structure? (I could try to repair it).

Comments

  • The only time I've had that happen is when I'm trying to open a file that's already been language localized. MCSketch doesn't understand the number that gets put in place of the string literal. Is that the problem? Sometimes I've gone in and replaced all those numbers with an empty string just to get the UI to open. You could also try pulling the text out into some kind of editor that help show matching braces.

    Good luck.

  • PhilemoPhilemo Posts: 840

    The only time I've had that happen is when I'm trying to open a file that's already been language localized. MCSketch doesn't understand the number that gets put in place of the string literal. Is that the problem? Sometimes I've gone in and replaced all those numbers with an empty string just to get the UI to open. You could also try pulling the text out into some kind of editor that help show matching braces.

    Good luck.

    Thank you Eric for your help.

    I'll try that

Sign In or Register to comment.