Cute Bob Hair Strange Behavior

I'm working with this asset: https://www.daz3d.com/cute-bob-hair-for-genesis-3-and-8-females

And I've found some unusual behavior. Please see the screen shots.

When I first apply the air to the model, the hairs themselves aren't out of place but it isn't fitted properly. So I go to change that (mess with Cranium size) and I can get that to work. But then, there are rogue hairs sticking straight out (see screenshots).

Any thoughts?

1.jpg
1820 x 1897 - 2M
2.jpg
1820 x 1897 - 1M
3.jpg
1820 x 1897 - 1M

Comments

  • DarkRepastDarkRepast Posts: 140
    edited October 22

    So I reinstalled. Applied the hair. The hair does the weird 'throw out pieces in all directions' totally at random. I wasn't even moving the camera. Just started scrolling through some assets and boom, the hair went crazy.

    Post edited by DarkRepast on
  • What character are you applying the hair to?
  • DarkRepastDarkRepast Posts: 140

    I tried it on multiple characters however, the one in the screen shot is Audrey:

     

    https://www.daz3d.com/audrey-hd-for-bridget-8

  • pazlenpazlen Posts: 3

    Having the same problem, this is on Aiko 8.  Hair applies fine, do anything with the scene and it loses its form. 

    Aiko8 Cute Bob issues.png
    640 x 360 - 211K
    Aiko8 Cute Bob issues 02.png
    640 x 360 - 221K
  • RedzRedz Posts: 1,367

    Hi Darkrepast. Sorry you’re having issues with the hair. I’ve had a look and it’s an errant rigidity group that is clashing with some head morphs and causing this problem. I have no clue how this happened or how it escaped my attention, but I do know how to fix it. A product update may take some time, so if you prefer a DIY fix, I can give you a guide to explain how to delete the rigidity group. With the hairs (not the cap) selected in the scene tab, go to Tool Settings - Geometry Editor and choose Vertex Selection from the options near the top of the geometry editor pane. You will see a list of rigidity groups. Right click on the bottom group, named R7, and choose remove the selected group. If you already have your character morph applied then you will need to perform one more step before you see the fix. With the hair still selected in the scene tab, go to the dropdown menu at the top right of the scene tab and choose Assets - Clear Generated Morphs. Hopefully your hair will now play nice with the character morph.

    Video of fix

     

  • pazlenpazlen Posts: 3

    Thanks for the workaround!  Worked for me!  

     

    Aiko8 Cute Bob Fixed 01.png
    480 x 270 - 79K
  • DarkRepastDarkRepast Posts: 140
    Redz said:

    Hi Darkrepast. Sorry you’re having issues with the hair. I’ve had a look and it’s an errant rigidity group that is clashing with some head morphs and causing this problem. I have no clue how this happened or how it escaped my attention, but I do know how to fix it. A product update may take some time, so if you prefer a DIY fix, I can give you a guide to explain how to delete the rigidity group. With the hairs (not the cap) selected in the scene tab, go to Tool Settings - Geometry Editor and choose Vertex Selection from the options near the top of the geometry editor pane. You will see a list of rigidity groups. Right click on the bottom group, named R7, and choose remove the selected group. If you already have your character morph applied then you will need to perform one more step before you see the fix. With the hair still selected in the scene tab, go to the dropdown menu at the top right of the scene tab and choose Assets - Clear Generated Morphs. Hopefully your hair will now play nice with the character morph.

    Video of fix

     

    Thank you so much!! This is amazing!

Sign In or Register to comment.