Funky eyelash shadows with Iray (AKA don't stray from world center)

UPDATE:  If you are looking for a workaround skip down to the 12th entry where I figure out what the problem is.

I'm having a problem with eyelash transparency in Iray that creates a thick dark shadow above and below the eyes.  It's as if the spotlight doesn't see the transparency part of the lashes.  It looks like the hair is a problem too, just not as bad.

The scene is V6 with updated Iray Optimized G2F material.  The set, wardrobe, and hair have all been updated with Iray Uber Base.  The only lights are mesh lights built into the set (Stonemason's Utopia Deck C) and a photometric spotlight on the face which is causing the problem.  (see first picture)  The spot Light Geometry is set for Disc to make the light softer.  I've discovered if I set it back to Point that the eyelash problem goes away.  That's a harder light than I want but would be acceptable if it didn't create a different problem - funky shadows on the gloves and chest.  (see second picture)  Tried lighting the face with a mesh light, same problem with the eyelash shadows.

I'm at my wits end.  I've tried adjusting every setting I can think of on the spotlight, the eyelash surface, and the uniform.    Anyone know how to resolve these two issues?

 

V6 runs 07 perspective view frame 305 disc key light - eyelash and hair shadows.jpg
1280 x 720 - 175K
V6 runs 07 perspective view frame 305 point key light - chest and glove shadows.jpg
1280 x 720 - 133K
Post edited by eric susch on

Comments

  • It looks more like a glitch in the transparency applied to the eyelash mesh. Can you render again, zoomed in so we can just see the middle of the face? There might be something off about the transparency that isn't easy to figure out without a closer look.

    What about the eyelash material settings? Can you post screenshots of the Surfaces tab with the Eyelash material selected? The optimised Iray converter does a pretty good job most of the time with the non-skin bits and pieces, but every now and then it produces very subtly not-quite-right results that need a bit of tweaking.

  • ECU of the eyes and screenshot of the eyelash surface settings.  Thanks for looking at this SpottedKitty!

    V6 runs 07 ECU2 frame 305 disc key light - eyelash and hair shadow.jpg
    1280 x 720 - 157K
    V6 runs 07 Eyelash surface settings.jpg
    950 x 1200 - 293K
  • ScavengerScavenger Posts: 2,623

    I've run into this..only way I've solved it is to revert from the iray shader to the orrignal one...I'm sure there's a better way.

  • mjc1016mjc1016 Posts: 14,756

    Check the map in the Cutout Opacity.  Click on the map and then select Image Editor.  If the Gamma isn't 1.0 set it to that and see if that helps.

  • eric suscheric susch Posts: 62
    edited September 2015

    Cutout Opacity Gamma is already set to 1.00.

    Reverting the surface back to 3Delight is an interesting idea.  I'll try some experiments to see what happens...  Still would like to figure out what causes this (other than soft light.)

    Post edited by eric susch on
  • ToborTobor Posts: 2,121

    Cutout Opacity and gamma are two different things. You'd adjust the gamma in the image editor for the eyelash transparency. The Cutout Opacity is the percentage value of opaqueness of the underlying mesh. You can verify this by taking the Cutout Opacity to 0.0, which effectively hides it (you may need to remove the transparency map to see this).

     

  • ToborTobor Posts: 2,121

    I also see that you have a zero-based displacement map (backgorund is black), but using +/- displacement swings. The black displacement map is for Poser; the values for displacement that you are using are for D|S. In D|S the "zero" (no displacement) is 127 (or is it 128?, I can never remember).  You can spot a displacement map for D|S because it has a gray background instead. First thing to check is if your texture set has any D|S displacement maps. If so, change out the one you're using. You may also need to adjust the displacement strength.

     

  • Tobor said:

    Cutout Opacity and gamma are two different things. You'd adjust the gamma in the image editor for the eyelash transparency. The Cutout Opacity is the percentage value of opaqueness of the underlying mesh. You can verify this by taking the Cutout Opacity to 0.0, which effectively hides it (you may need to remove the transparency map to see this).

     

    Yes, I understand.  I should have been more clear.  The Image Gamma is 1.00 in the Image Editor of the eyelash grayscale image (RyBelle_lashes.jpg) that is loaded in the Cutout Opacity control.

    I also tried removing the eyelash transparency graphic from Cutout Opacity and set the CO to 0.0.  This removed the eyelashes as expected but did NOT remove the shadows around the eyes.  I was a bit surprised by that.

  • In the hopes that reverting back to a 3Delight surface would resolve the issue I tried:

    Replacing the eyelash surface with the dzDefault shader.

    Reloading the entire V6 Belle material onto the figure. (Also tried Stephanie 6, Lilith 6, and V5 Bree)

    Loading an entirely new Victoria 6 model from scratch with no surface adjustments and set it next to my model.

    None of these things resolved the shadows around the eyes.

  • FishtalesFishtales Posts: 2,316

    I had that problem and found it was the ?Ray Trace? setting in the Render settings. I had it set at 3, when I put it back to -1 it went away

  • eric suscheric susch Posts: 62
    edited September 2015

    OK, here's a new and disappointing twist.  My project is an animation of V6 running and the pictures I've posted are of frame 305.  If I render frame 000 there is no problem with eyelash shadows!!!  The problem becomes apparent as she runs farther from the center of the world!!!

    I've done a few tests and I've come up with a way to repeat the problem with minimal assets:

    Start a new project
    Render settings to Iray - Environment Mode Scene Only
    Load Genesis 2 Base Female (G3F works too!)
    Add a Camera and frame it on her head
    Add a New Spotlight and point it at her head
    Set the Light Geometry on the spotlight to Disc (also works with other settings that are not Point.)
    Render through the camera.  Everything is fine.
    Parent the Camera and Light to G2F (so they stay with the figure)
    With G2F selected in the scene tab, change the zTranslate to 2000 in the Parameters tab
    Render through the camera.  You should see the eyelash shadow problem.

    The light's orientation seems to be a factor too.  For example, if you yTranslate the figure by 2000 the render is fine, but if you then rotate G2F so the light points back to the center of the world the eyelashes go dark.

    As far as I can tell you can't use any soft light on a character's face when you are more than 500 units from the center of the world and the light is pointing toward or away from world center.  Even mesh lights are a problem.  I'm guessing this is a bug in DAZ Studio or the Iray renderer, not a problem with the eyelash surface.

    DAZ Studio 4.8.0.59 Pro Edition (64-bit)

    Post edited by eric susch on
  • ToborTobor Posts: 2,121
    edited September 2015

    Deleted post ... see below

    Post edited by Tobor on
  • OK, here's a new and disappointing twist.  My project is an animation of V6 running and the pictures I've posted are of frame 305.  If I render frame 000 there is no problem with eyelash shadows!!!  The problem becomes apparent as she runs farther from the center of the world!!!

    I've done a few tests and I've come up with a way to repeat the problem with minimal assets:

    Start a new project
    Render settings to Iray - Environment Mode Scene Only
    Load Genesis 2 Base Female (G3F works too!)
    Add a Camera and frame it on her head
    Add a New Spotlight and point it at her head
    Set the Light Geometry on the spotlight to Disc (also works with other settings that are not Point.)
    Render through the camera.  Everything is fine.
    Parent the Camera and Light to G2F (so they stay with the figure)
    With G2F selected in the scene tab, change the zTranslate to 2000 in the Parameters tab
    Render through the camera.  You should see the eyelash shadow problem.

    The light's orientation seems to be a factor too.  For example, if you yTranslate the figure by 2000 the render is fine, but if you then rotate G2F so the light points back to the center of the world the eyelashes go dark.

    As far as I can tell you can't use any soft light on a character's face when you are more than 500 units from the center of the world and the light is pointing toward or away from world center.  Even mesh lights are a problem.  I'm guessing this is a bug in DAZ Studio or the Iray renderer, not a problem with the eyelash surface.

    DAZ Studio 4.8.0.59 Pro Edition (64-bit)

    That is a great description, thanks for the running it through far enough to get what some instructions that should be easy to replicate.

     

    In order to make sure this one doesn't slip through the cracks, please file a ticket with our support team over here: https://helpdaz.zendesk.com/requests/new

     

    Hopefully we can figure this out and get the fix in the next release of Daz Studio.

  • ToborTobor Posts: 2,121
    edited September 2015

    Ah, now I see. Even without a displacement map it shows up. The eyes themselves are messed up, too.

    On edit: I see that dramatically increasing the emitter size (500-700 cm), and adjusting the luminosity to compensate from the increased area, largely gets around this. However, it alters the quality of the light that may not work for your scene.

    I was also able to improve the looks a little byc hanging to a 3D emitter shape, such as sphere, and using a smaller (150-200 cm) size. Since the light is now coming from the full surface of the sphere, the luminosity has to be adjusted upward accordingly.

     

     

    Post edited by Tobor on
  • barbultbarbult Posts: 8,061

    I followed your instructions, and this is what I got with Eva 7 at Z=2000. The hair, eyes and eyelashes obviously have problems. At Z=0, it rendered fine.

     

    Eva 7 x=2000.jpg
    1236 x 1600 - 756K
    Eva 7 x=0.jpg
    1236 x 1600 - 843K
  • @DAZ_Rawb

    I sent in a support ticket this afternoon.  Hopefully it can be fixed in the next update.

    Cheers!

  • evilded777evilded777 Posts: 1,863

    wow.  I have yet to see anything like this. I'm going to have to experiment.

     

    Great description of the problem!

  • Does anyone know whether this issue has been addressed in the latest beta of studio? I tried to read through the lists of fixed bugs in the beta forum post, but my eyes glazed over from trying to understand it...

  • Looks like this wasn't fixed in the next version as tech support promised.  Still broken in DAZ Studio 4.9.1.30

  • nonesuch00nonesuch00 Posts: 5,550

    I have this problem with the 'Girl 7' throwing a pitch on the 3DU Toon Generations Baseball Field. 1st I scaled up the baseball field by 200% or 250% and then moved Girl 7 far from the center of the scene/world onto the pitcher's mound, posed, rendered and she looks like she is wearing black eye grease like baseball and football players wear. Lucky coincidence. The bad render is in my DAZ Gallery. LOL, yes I put mistakes in there too as I'm a beginner.

  • Arnold CArnold C Posts: 727

    I have this problem with the 'Girl 7' throwing a pitch on the 3DU Toon Generations Baseball Field. 1st I scaled up the baseball field by 200% or 250% and then moved Girl 7 far from the center of the scene/world onto the pitcher's mound, posed, rendered and she looks like she is wearing black eye grease like baseball and football players wear. Lucky coincidence. The bad render is in my DAZ Gallery. LOL, yes I put mistakes in there too as I'm a beginner.

    In this case I'd rather move the Baseball Field (in opposite to reality we can move the environment laugh) and let Girl 7 reside at/near world center.

Sign In or Register to comment.