Underground King Issue With Invisible Shirt in Daz Studio 4

CathyMCathyM Posts: 240
edited December 1969 in Daz Studio Discussion

Hi! I am hoping someone might be able to help with this, as well as letting me know how this is possible - I have tried loading the Underground King clothing for M4 into Daz 4.0 http://www.daz3d.com/shop/underground-king-m4 - the pants, the boots and the pendant show up fine, however there seems to be a strange problem with the shirt- it shows up in the scene as if it's there, but it doesn't appear in the view, and if you render, it still doesn't appear. I've checked to make sure it's 100% opacity, I've tried changing colors, nothing works. Although, if I pose M4 while this invisible shirt is fitted to him, parts of it become invisible behind him, like wings or something, and when I click on them they name body parts. (Shoulders, etc.)

I can load this shirt fine in Daz Studio 3 Advanced. I tried saving it as a scene and then merging, but it's still invisible. I am confused as to how this is possible, and how I can fix it... Any help would be greatly appreciated! :-) -Cathy


  • Richard HaseltineRichard Haseltine Posts: 49,431
    edited December 1969

    Will the shirt load into a scene on its own? Exactly which version of DS4 are you using (Help>About DAZ Studio)?

  • CathyMCathyM Posts: 240
    edited December 1969

    Hi Richard! I'm using Daz Studio Pro. Here are some pictures to show what is happening. The shirt "loads" into Daz Studio 4 but is invisible. I also tried loading it into Daz Studio 3 and saving it as a scene, then opened that scene in Daz Studio 4 - the shirt was still invisible, even though it shows up in the scene list as if it's in the scene.

    In Daz Studio Advanced - the shirt will load by itself, onto M4 and is posable. I saved the scene and imported it into a new scene in Daz Studio 4. As you can see, the posed M4 came through fine, but the shirt, now visible, exploded. (I also tried importing the scene with the shirt on M4 in a zero'd pose, and the M4 shows up fine, also pants and boots, but the shirt, though listed, is invisible.)

    The attached pictures may be all mixed up - one shows the invisible Underground King shirt as it appears in Daz Studio 4.0 - one shows the shirt as it appears on M4 in Daz 3 - the 3rd picture shows the scene from Daz 3 imported into Daz 4 - the shirt has exploded - the 4th picture shows the back view of the exploded shirt. The last picture is how the zero'd pose on M4 and shirt scene saved from Daz 3 appears in Daz 4.

    Any help understanding this would be greatly appreciated!. :-) -Cathy

    700 x 416 - 53K
    700 x 430 - 43K
    700 x 563 - 101K
    700 x 708 - 112K
    700 x 373 - 44K
  • Richard HaseltineRichard Haseltine Posts: 49,431
    edited December 1969

    I don't have this set, but my first suspicion would be the group names. Could you do this please:

    Open the Figure Setup Pane (Window>Panes(Tabs)>Figure Setup
    Right-click in the pane's OBJ/Group panel, on the left, and import a new OBJ - find and import the OBJ for the shirt. Don't worry about which preset you use, it won't matter for this. The readme product list should tell you where to find the OBJ.
    In the panel, expand the entry for the OBJ so you can see its list of groups.
    Please take a screenshot of that list and post it here.

  • CathyMCathyM Posts: 240
    edited August 2012

    Hi again Richard! Thanks so much for helping with this - I'd really like to know what's going on just for the sake of learning -
    Here's a screenshot showing the list as requested - also the 2nd screenshot shows what the scene and surfaces lists are for the invisible shirt when it's loaded into Daz 4.

    Just noticed in the Scene view - the left side has a hand mentioned, the right does not - and hand does not appear in the list at all in the Figure Setup list - don't know if that is important

    700 x 198 - 26K
    568 x 665 - 50K
    Post edited by CathyM on
  • BejaymacBejaymac Posts: 1,208
    edited December 1969

    I just got a copy of the CR2 for this from a friend, they are having the same issue.

    The problem is the scale dials for the lsleeve & rsleeve bones, they are "Empty Ranges", in DS4 that means 0% scale ie no mesh shows up in the scene, so you need to either directly edit the dials in the CR2 or edit the dial properties in DS4 and export a new CR2

  • Richard HaseltineRichard Haseltine Posts: 49,431
    edited August 2012

    Well, the group names look sensible so I don't think it's what I first thought. Unfortunately I don't have a second thought, though if this is an item you've had for a while you might try resetting in case there's been an update.

    It is a little odd having a hand only one side, but having bones without any mesh is quite common - it helps to keep the bone above that does have mesh stable when posing.

    Edit Ah, I see you have an answer.

    Post edited by Richard Haseltine on
  • BejaymacBejaymac Posts: 1,208
    edited August 2012

    Looks like I have another mystery to look into with this CR2, why isn't the RHand showing up in DS4 when it's there in the CR2

    *shrugs* keeps me out of mischief ;-P


    ROFL Not much of a mystery the RHand, Neck & Head bones are hidden in the CR2

    Post edited by Bejaymac on
  • CathyMCathyM Posts: 240
    edited December 1969

    Hi Bejaymac! Glad that you were able to figure out what the problem is with this shirt - but erm I am pretty unexperienced at the mechanics of Daz myself, and haven't ever tried doing any editing - is it something that just anyone could do? You say to edit the dials in the cr2, but I am not sure what that means - or edit the dials in DAZ and export a new cr2? Where would these dials be (parameters or surfaces or...?) and what are they called? And if I export a new CR2 - will it still have morphs and movements, or will I need to figure out how to "rig" it? You said the right hand in the list in the scene view is "hidden" but I can't see how you can know this? Is there some way to unhide it? Should it be?

    I just bought this in March but will try resetting it to see if anything has been changed. Thanks again to you both for helping with this :-)

  • BejaymacBejaymac Posts: 1,208
    edited August 2012

    Sorry I keep forgetting that most users don't know how or what to edit, I've been doing it that long that it's second nature for me to open a Poser file in a text editor, and read through it until I find and fix the problem.

    Method 1

    In DS select the "rsleeve" in the scene tab, then open the Parameters tab and select "General" and you should see the same as I have in the picture, to the right of the words "Empty Range" you should see a little cog, left click it and choose "Parameter settings", in the popup you want to change the Max & value settings (circled in red in the pic) to 100% and then click on "Accept". Now do this for the other three scale dials and then head back to the scene tab and select "lsleeve", now do the same for these 4 scale dials, as you finish each dial on this bone you should start to see a mesh appear in the viewport, it'll be a mess until you finish the last dial, but it means that your doing it right.

    How you save your changes is up to you, you can either save it as a scene file, or use File > Export to save a new CR2.

    Method 2

    Open the CR2 in a decent text editor (anything except notepad) and go to line 296392, there you'll see a chunk of code like I have in the second pic, all of those "0" that I've "circled" (got shaky hands lol) need to be changed to "1". Now jump to line 479556 where you'll find the exact same chunk of code and do the same thing to the same 8 "0" here, then it's a case of save your changes.

    If your text editor doesn't have a go to line function then you need to use the find function, and search for "actor rSleeve:1", the sixth one will put you in the right section and it's a case of scrolling down 130 lines until you find the code in the pic, the you do a search from the start of the document for "actor lSleeve:1" and it'll be the sixth one for this one too.

    1029 x 700 - 90K
    754 x 576 - 312K
    Post edited by Richard Haseltine on
  • Richard HaseltineRichard Haseltine Posts: 49,431
    edited December 1969

    Added padding to image so that it resizes and doesn't break the page layout.

  • CathyMCathyM Posts: 240
    edited December 1969

    Thanks so much Bejaymac for your help! How fantastic to be able to figure things out like that - is it from programming knowledge that you knew how to fix something like this? Anyways I am so grateful for your assistance! I've attached a picture of a work in progress, done in Daz 4 with Michael 4 and Genesis both appearing in the Underground King outfit - THANKS! :-) -Cathy

    800 x 803 - 106K
  • BejaymacBejaymac Posts: 1,208
    edited December 1969

    Sort of, I've been editing Poser files almost from the minute I got Poser 4 all those years ago, I also spent several years modding games where bug hunting usually meant "reading" the files looking for errors, so it a bit of knowledge and a bit of instinct that's developed from those over the years.

Sign In or Register to comment.