How to make hair ignore ears

DkgooseDkgoose Posts: 1,439
edited December 1969 in The Commons

How does one add hair to any of the Genesis 2 characters with elf ears and have the hair load normal? It always forms around the ears but I want he ears to stick out not be covered in hair, thanks on advance for any replies

Comments

  • FixmypcmikeFixmypcmike Posts: 17,698
    edited December 1969

    Select the hair and go to Parameters,, make sure "Show Hidden Morphs" is on, and look for the auto-generated morph for the ears.

  • JaderailJaderail Posts: 0
    edited December 1969

    Then turn those off. Note some times this just makes the hair poke OUT of the ears in odd places. But it is all we have. I often hunt hairs that show the ears to use on my figures just to avoid that problem.

  • HeraHera Posts: 1,674
    edited December 1969

    Thanks this was awesomely helpful, I've been having this problem too, but I never knew there was a way to solve it :-)

  • zawarkalzawarkal Posts: 1,018
    edited December 1969

    Something that I just thought of a short time ago...

    Once you have your figure morphed and set up as desired. Duplicate a copy of your figure. Turn off the elf ears morph and possibly even turn on a no ears morph. Fit the hair to the duplicate no ear copy of your figure.

    Turn off the visibility of the duplicate figure and be sure that any posing/morph changes applied to one figure are also applied to the other figure to keep the alignment straight.

    Depending upon the hair model you might want to add a morph to split the hair below and around the ear.

    I had thought about exporting just the head and importing as an obj but I do not think the autofit feature of the hair will work after that.

    Not perfect, but it is a workaround.

  • JoeQuickJoeQuick Posts: 1,289
    edited March 2014

    disable auto follow in the properties of your elf ear morphs. do this before conforming the hair.

    I've attached an image that shows where to find this option on any morph.

    disableautofollow.jpg
    1917 x 1080 - 399K
    Post edited by JoeQuick on
  • Lord MajesticLord Majestic Posts: 44
    edited December 1969

    So far as I can see the Auto Follow setting isn't saved when you save a scene or asset , you have to switch it off again every time you re-load it.

    Or is there some way to make it save I'm missing?

  • JoeQuickJoeQuick Posts: 1,289
    edited December 1969

    So far as I can see the Auto Follow setting isn't saved when you save a scene or asset , you have to switch it off again every time you re-load it.

    Or is there some way to make it save I'm missing?

    You can save out the morph and replace the auto follow one.

  • Lord MajesticLord Majestic Posts: 44
    edited December 1969

    Joequick said:
    So far as I can see the Auto Follow setting isn't saved when you save a scene or asset , you have to switch it off again every time you re-load it.

    Or is there some way to make it save I'm missing?

    You can save out the morph and replace the auto follow one.
    I'm not sure what you mean:

    Do you mean save a null morph that does nothing? Yeah I figured that out, but it wouldn't be much simpler if the Auto Follow setting was saved when you saved a scene or figure. To be honest I don't really see much point in having that setting if it doesn't save.

  • mjc1016mjc1016 Posts: 15,001
    edited December 1969

    As a scene or subset..no I don't think it does. As a proper support asset or as a morph (or updated morph) it should. I'd probably save it as a different version...something like mygreathair_NO_AF.

    In reality it is much more useful for content creators or at content creation time than it is afterwards.

  • JoeQuickJoeQuick Posts: 1,289
    edited March 2014

    Do you mean save a null morph that does nothing?


    no

    Yeah I figured that out

    did you?

    wouldn't be much simpler if the Auto Follow setting was saved when you saved a scene or figure. To be honest I don't really see much point in having that setting if it doesn't save.

    Right, so save the morph with autofollow disabled. Click the little box to disable autofollow on the source figure, and then save the new changed morph.

    3.jpg
    1917 x 1080 - 393K
    2.jpg
    1917 x 1080 - 447K
    1.jpg
    1917 x 1080 - 429K
    Post edited by JoeQuick on
  • Lord MajesticLord Majestic Posts: 44
    edited December 1969

    Yeah I had tried that, but it didn't seem to work, when you loaded it back in Auto Follow was back on again. But I've been playing around with it and seem to have got it working now. The issue was that if you save the scene with a figure in it with 'Scene Asset(s)' you have to close it and load that version, then do the above. If you just carry on and do it in the original scene it doesn't work.

    Thanks for the help.

  • starionwolfstarionwolf Posts: 3,280
    edited March 2014

    Joequick said:
    disable auto follow in the properties of your elf ear morphs. do this before conforming the hair.

    I've attached an image that shows where to find this option on any morph.

    The large version screenshot is too big for my monitor. Can you please make it smaller or crop the image? Firefox doesn't show any scroll bars that allow me to pan the image. My desktop is set to 1024x768. Thank you.

    Post edited by starionwolf on
  • ValandarValandar Posts: 1,417
    edited December 1969

    Joequick said:
    disable auto follow in the properties of your elf ear morphs. do this before conforming the hair.

    I've attached an image that shows where to find this option on any morph.

    The large version screenshot is too big for my monitor. Can you please make it smaller or crop the image? Firefox doesn't show any scroll bars that allow me to pan the image. My desktop is set to 1024x768. Thank you.

    Right click the picture, and choose "View Image". Then it'll autoscale to fit the window, and if you click it to bring it fullsize it'll have scroll bars.

  • MystiarraMystiarra Posts: 34,863
    edited December 1969

    can autofollow include the gn and g2m male gens in it's following?

    Thanks. :)

  • WendyLuvsCatzWendyLuvsCatz Posts: 25,271
    edited December 1969

    if it can the result would look like a willy warmer built into your pants ;-P

  • ChromaDrakeChromaDrake Posts: 288
    edited December 1969

    Joequick said:
    disable auto follow in the properties of your elf ear morphs. do this before conforming the hair.

    I've attached an image that shows where to find this option on any morph.

    Just wanted to say thanks Joe! Very nice of you to include a screenshot clearly showing what needed to be done, that was a very good explanation.
  • Swawa3DSwawa3D Posts: 231
    edited November 2014

    Just wanted to add depending on the situation, I sometimes find it easier to not auto conform the hair to the figure. I just attach it to the head like a prop and then shape it manually through scale, morphs, d-formers, etc. Although I usually try to conform it first to see how well it works. I often use a ton of morphs on genesis and fit Gen 4 hair to it. The other techniques mentioned are very useful too, whatever works best for the situation.

    Post edited by Swawa3D on
  • ChromaDrakeChromaDrake Posts: 288
    edited December 1969

    Swawa3D said:
    Just wanted to add depending on the situation, I sometimes find it easier to not auto conform the hair to the figure. I just attach it to the head like a prop and then shape it manually through scale, morphs, d-formers, etc. Although I usually try to conform it first to see how well it works. I often use a ton of morphs on genesis and fit Gen 4 hair to it. The other techniques mentioned are very useful too, whatever works best for the situation.
    Yeah, sometimes it is just easier to move a prop onto a figure and parent it that way rather than conforming it. I haven't tried that with hair that much, I should experiment more :)
  • Oh man, thanks so much for this!  I just ran across this thread after some rather frustrating attempts to get the hair behind the elf ears.  Now, I know how to shut off that pesky autofollow!

  • nicsttnicstt Posts: 9,254

    One of the reasons I use VWD; to dynamically pose the hair. It takes some time to learn the software though.

Sign In or Register to comment.