No lights on Objects? possible?

RuphussRuphuss Posts: 2,364
edited December 1969 in New Users

is there a way to have an object not to be effected by lights and or shadows in dazstudio 4.6
this question comes up because i'm trying to work with backdrops again

Comments

  • SylvanSylvan Posts: 2,505
    edited December 1969

    If you use the renderer inside DAZ (so no Lux or Reality) you can choose to not use shadows.
    That way an item will be luminated but won't cast any shadows.
    If I'm not mistaken, every light that has been added within DAZ won't cast shadows until you tell it so in the parameters tab.

  • RuphussRuphuss Posts: 2,364
    edited December 1969

    ist not about casting ist about receiving
    but thx for trying to help

  • JimmyC_2009JimmyC_2009 Posts: 8,891
    edited December 1969

    Are you using Edit > Backdrop, or are you using a Plane of your own with an image on it?

    Using the built in backdrop does not receive shadows for me. If you are using a Plane with an image, then why not just render your scen3e as a PNG, and add the backdrop in Photoshop?

  • Richard HaseltineRichard Haseltine Posts: 61,063
    edited December 1969

    If you use uberSurface, rather than the default DAZ Shader, for the backdrop prop it does have an Accept Shadows option that can be switched off.

  • EleleElele Posts: 1,095
    edited October 2013

    Howdy,

    you can set the ambient color to white and the diffuse STRENGTH to zero.
    (also set specular strength to zero and don't have it accept or cast shadows as suggested)

    Cheers,
    Elele.

    Post edited by Elele on
  • SzarkSzark Posts: 10,592
    edited December 1969

    Elele said:
    Howdy,

    you can set the ambient color to white, the diffuse STRENGTH to zero.
    (also set specular strength to zero and don't have it accept or cast shadows as suggested)

    Cheers,
    Elele.

    added to what Elele said throw the diffuse map into the Ambient Colour channel too.
  • EleleElele Posts: 1,095
    edited December 1969

    Szark said:
    Elele said:
    Howdy,

    you can set the ambient color to white, the diffuse STRENGTH to zero.
    (also set specular strength to zero and don't have it accept or cast shadows as suggested)

    Cheers,
    Elele.

    added to what Elele said throw the diffuse map into the Ambient Colour channel too.

    If you load the map in ambient channel too, it will still interact with light or alter the image in some other way if i remember correctly.

  • SzarkSzark Posts: 10,592
    edited October 2013

    Nope lowering Diifuse Strength to 0% with Ambient on will stop any interaction even with the diffuse map placed into the Ambeint Colour channel. This is how many Sky Domes are set up.

    Post edited by Szark on
  • EleleElele Posts: 1,095
    edited December 1969

    Szark said:
    Nope lowering Diifuse Strength to 0% with Ambient on will stop any interaction even with the diffuse map placed into the Ambeint Colour channel. This is how many Sky Domes are set up.

    Just looked up my old skydome thread: You get this kind of oversaturated effect when you load the image again in the ambient channel (see pic). This might be a handy effect, but the point is that it changes the original image.

    t3.JPG
    463 x 500 - 19K
  • SzarkSzark Posts: 10,592
    edited December 1969

    I stand corected weird how so many products have it set up my way though but yes the result you showed shows me all those products taught me the wrong lesson. I love being shown I am wrong, great for learning, thank you Elele

  • EleleElele Posts: 1,095
    edited December 1969

    All roads lead to Richard & FixMyPCMike, they helped me out with the same problem :)

  • SzarkSzark Posts: 10,592
    edited December 1969

    and I always contridicted what Richard said about this, sorry Richard.

  • TotteTotte Posts: 11,200
    edited December 1969

    Szark said:
    and I always contridicted what Richard said about this, sorry Richard.

    I think Richard should print this out and frame it ;-)

  • SzarkSzark Posts: 10,592
    edited December 1969

    :P @ Totte

  • RuphussRuphuss Posts: 2,364
    edited December 1969

    i'm not a programmer so i ask:
    is it very hard to create an option on objects not
    to receive light or /and shadows
    just like the Option to cast shadows or not under Display

  • TotteTotte Posts: 11,200
    edited December 1969

    ruphuss said:
    i'm not a programmer so i ask:
    is it very hard to create an option on objects not
    to receive light or /and shadows
    just like the Option to cast shadows or not under Display

    The way 3Delight works AFAIK, this is a "job" for the object surface shader on that particular object and not something for the light shader. I do lack sufficient 3Delight shader language skills to give a meaningful description on exactly how such a shader would be written though.

  • EleleElele Posts: 1,095
    edited December 1969

    ruphuss said:
    i'm not a programmer so i ask:
    is it very hard to create an option on objects not
    to receive light or /and shadows
    just like the Option to cast shadows or not under Display

    Have you tried
    to set the ambient color to white and the diffuse STRENGTH to zero (also set specular strength to zero and don’t have it accept or cast shadows as suggested), or is this not what you are looking for?

    (you can do this in the surface tab when you have your object selected in the scene)

  • Richard HaseltineRichard Haseltine Posts: 61,063
    edited December 1969

    As I said above, if you use uberSurface, rather than the default DAZ Shader, for the backdrop prop it does have an Accept Shadows option that can be switched off. You need to select the surface (s) of the item you want to be unaffected by shdows with the Surface Selection tool, then go to Shader Presets>omnifreaker>UberSurface, hold down the ctrl key (cmd on a Mac) and double-click the !Uber Surface Base file, then in the dialogue that opens select ignore for Maps so that it doesn't remove the texture. Open the Surfaces pane, type shadow into the box at the top (with the Editor tab active) and turn off the Accept Shadows property.

  • RuphussRuphuss Posts: 2,364
    edited December 1969

    Advanced Ambient Light is the solution for me now as i can flag an object to have light on it or not

Sign In or Register to comment.