Noisy Shadow (after activating Shadow Softness)

cschneicschnei Posts: 0
edited December 1969 in Daz Studio Discussion

If i activate "Shadow Softness" on a Distand or Spot Light the shadow gets noisy/pixelated/grainy.

The render settings in this picture are set to default.
But i tried every possible value to remove this noise.

Can someone give me a hint, how to remove this noise.

Noisy_Shadow_2.png
500 x 500 - 179K
Noisy_Shadow.png
500 x 500 - 135K

Comments

  • SzarkSzark Posts: 10,592
    edited December 1969

    Advanced Render settings > Shading Rate too high, lower the value try 0.50 - 0.20 (possibly lower)
    and /o Advanced Render Settings Shadow Samples to low, try 24

  • cschneicschnei Posts: 0
    edited December 1969

    Looks better, but still noisy.

    After your recommendation, i tried the following settings.

    Shadow Samples = 64
    Shading Rate = 0.01

    The first picture shows the default render settings, the second 64/0.01.

    Any other recommendation. Cause 64/0.01 are the maximum and minimum values of the two setting sliders.

    NoiseShadow64ShadingRate0_01.png
    927 x 1017 - 638K
    NoiseShadowDefault.png
    927 x 1017 - 725K
  • VanguardVanguard Posts: 475
    edited December 1969

    try setting the pixel X and Y samples to 24 or over

  • SzarkSzark Posts: 10,592
    edited December 1969

    Sorry for the delay but I have done some testing myself and I get the same results as you and for the life of me can't figure this out. This IMHO shouldn't be. Granted we are using primatives with no textures but even then it should be that grainy even increasing Pixel Samples X and Y didn't fix the issue completely.

  • cschneicschnei Posts: 0
    edited December 1969

    Wow, thx for testing it by yourself.

    If i use the Uber Environment Park. The noise is really extreme.

    After searching for it, i found pictures of people which dont' have this problem.
    So there must be a solution to it.

    UberEnv_Park_Noise.png
    920 x 575 - 565K
  • MattymanxMattymanx Posts: 6,236
    edited December 1969

    you are using UBer environment or normal lights???


    if uber, then you need to adjust settings for UE as well as your advanced render settings

  • cschneicschnei Posts: 0
    edited December 1969

    I tried normal lights (first picture) and Uber Environment (last post).

    Both resultet in noise.

    But the tip of "Vanguard" worked!!!
    (sry, i missed your post on first sight)

    The noise is much smaller if i use a pciture filter of x=16 and y=16.
    This is the max value i could use.

    If i use a pxeil filter of 20 i get white/empty quads all over the rendered pictures.

  • MattymanxMattymanx Posts: 6,236
    edited December 1969

    For the first image, what were the surface settings for the primative plane catching the shadow?

    What were the settings of the light and what type of light was it?

  • cschneicschnei Posts: 0
    edited December 1969

    I used the standard and default values for everything.

    I created a standard plane (without changing any creation or surface value)
    I created a distant light (only changing the shadow value from none to raytraced (software) and increasing the softness value from zero to 30).

    Thats all.
    I used the default values for everything else.

    The values from Vanguard help to reduce the noise.
    But its still visible if i use the following values:

    Shadow Samples: 64 (max)
    Shading: 0.4
    Pixel Filter: 16/16 (max)

Sign In or Register to comment.