Why do my objects hop at the start of physics simulation?

edited December 1969 in Carrara Discussion

Hi

I'm familiarizing myself with the physics controls and options in Carrara 8.5 Build 132 (64 bit).

I've set up a basic sphere-dropping-onto-stacks-of-cubes scene which is mostly working as expected, but for some reason the cubes hop off the floor plane a small amount at the second frame and I can't figure out why.

There were no keyframes in any of the cubes' timelines prior to when I set their motion to Physics. I have verified that they are sitting in contact with the floor plane by placing them using collision detection.

For reference, the cubes are 1.46 feet on a side, and the hotspot is at .73 feet in each.

When I look at the Z position of a single cube sitting on the floor plane I can see the value increase in the second frame from .73 to .84 feet, and it never goes back down ("gravity" will not pull it back down to the floor plane). It will then remain at that height until something hits it. At this point there is a visible gap between the bottom of the cube and the floor plane (which is set at 0 feet Z position).

If I set the cube's Z position to .84 feet in the first frame, it does not hop - the Z value will remain at .84 feet.

Cubes sitting above the bottom cube have a similar gap and similar behavior - if I figure out the height they're hopping up to and then set the initial height to that value then they will be stationary until something hits them,

I tried turning off physics on the sphere just to see if it would make a difference, but it had no effect.

I have also made sure the floor plane is not moving - it has no keyframes at all.

What am I missing? What force is making my cubes hop? I just want them to sit stationary on the floor before the sphere hits them. I saw a tutorial on YouTube that said that in Carrara 7 there would be weird explody behavior under certain physics situations. Is this what's happening? Just a physics bug that hasn't been fixed? Or is there something I'm overlooking?

Thanks!
-Mike

Comments

  • evilproducerevilproducer Posts: 8,868
    edited December 1969

    I was skimming- Did you say if you were using the Bullet Physics solver or the original Carrara physics solver?


    Anyway, a possibility is the materials you tell your physics simulation to use, for instance: Rubber, wood, metal, etc. They each have their own attributes, such as friction, bounce, etc. You need to set the physical properties of the objects that have physics for their motion and also for objects that are static in the scene, such as the ground or obstacles.


    As I understand it, the objects all have a slight offset, or at least they needed to in the old physics solver. Not sure about bullet. In the old physics solver, if you started a simulation with objects already touching or intersecting the solver wouldn't calculate a collision between the touching objects. This could be where you're getting your jump: Offest plus a bouncy material.

  • edited December 1969

    Thanks for the rapid reply! As per your suggestion I set the materials to various types and even did some custom ones with bounce set to 0 for both the floor plane and the cube, but the hop still happens.

    I invoked Physics using the drop-down in the Motion tab of the Properties tray I'm assuming that's not the Bullet Physics solver you mentioned. I can't find any reference to the Bullet Physics solver in any of the menus - is that an ad-on or plugin, or am I just not looking in the right place?

  • evilproducerevilproducer Posts: 8,868
    edited December 1969

    mycranium said:
    Thanks for the rapid reply! As per your suggestion I set the materials to various types and even did some custom ones with bounce set to 0 for both the floor plane and the cube, but the hop still happens.

    I invoked Physics using the drop-down in the Motion tab of the Properties tray I'm assuming that's not the Bullet Physics solver you mentioned. I can't find any reference to the Bullet Physics solver in any of the menus - is that an ad-on or plugin, or am I just not looking in the right place?


    It should be included in Carrara 8 and later. That should include the 8.5 beta. I don't have Carrara 8. I use Carrara 7.2 which only has the original physics solver. I'm not sure where you look to access Bullet.


    Another part of the issue could be the offset the solver uses. You may be able to adjust it. I would look first under the physics tab for your objects first. I'm doing a render at the moment or I'd see if I can find it.

  • ManStanManStan Posts: 0
    edited December 1969

    scene/physics/bullet Drop collision distance to 5%
    You also may give the first second or two of the animation to settling.

  • 3DAGE3DAGE Posts: 3,274
    edited December 1969

    HI mycranium :)

    As Stan has pointed out, the main issue is probably Collision distance, (especially if your objects are sitting on a surface)

    the other possible issue (apart from the material settings, and collision distance) is Gravity.

    In some situations, you actually want to restrict the influence of gravity on an object,
    for example,: a building made of physics blocks.
    if gravity is on from frame one, then the blocks will collide from frame one, and this can produce unwanted movement, EG: shuffling and hopping of the blocks.

    You can replace the default Scene gravity, with a Direction force,. which has a strength value which can be key-framed, and animated.
    so you can have no gravity at frame one, then key-frame the strength value to add gravity when it#s needed.

    Here's a physics basics starting guide.

    https://dl.dropbox.com/u/7907045/First_step_Physics_C8.pdf

    Hope it helps :)

Sign In or Register to comment.