Why do Genesis' Elf Ears cause a problem?!

DrowElfMorwenDrowElfMorwen Posts: 393
edited December 1969 in Daz Studio Discussion

Basically, my hair props will not stop distorting if I use an elf ear morph on Genesis.

I have an elf character whom I transferred over to Genesis from M4 using GenX. Part of the morph included elf ears. Now, when I placed a hair on this Genesis elf, it distorts to match the ears--not what I want it doing! The hair above/behind the ears goes all weird and pointy. Now, thinking this might have been because of my morph, I took it out and re-did him... but as soon as I gave Genesis the elf ear morph that comes as part of Genesis anyway, any hair I attach does the same thing. It doesn't matter if it was an M4-to-Genesis hair or a straight up genesis hair. It all gives me the same problem. Needless to say this is horrible for renders, and I tried fixing it with a D-Form. It still looks horrid.

I really hope there is some solution to this.

Also, I use DAZ Studio 4.5 on Windows 7; not that I think it should matter since it's a Genesis problem, but, I figure someone might ask.

Comments

  • LindseyLindsey Posts: 1,609
    edited January 2013

    Here's how to fix that.

    1. Select the hair, go to the Parameters Tab.
    2. On the Active Pane Options (white square upper right on the Parameter's tab), select "Show Hidden Properties"
    3. You'll see the morph for the elf ears the hair has applied.
    4. Just dial to 0 and the hair will return to it's normal shape!

    ScreenShot005.jpg
    1293 x 818 - 81K
    Post edited by Lindsey on
  • SickleYieldSickleYield Posts: 7,154
    edited December 1969

    That's a great simple solution! I'm going to try it myself. :)

  • Harry DresdenHarry Dresden Posts: 365
    edited December 1969

    That's a great simple solution! I'm going to try it myself. :)

    Actually, it's the only solution short of chewing off your arm. ;)

  • mjc1016mjc1016 Posts: 15,001
    edited January 2013

    That's a great simple solution! I'm going to try it myself. :)

    Actually, it's the only solution short of chewing off your arm. ;)

    I've never know that to be particularly effective...because then you are disarmed and have no way of fighting off the hordes of pointy-eared, freaky-haired zombie elflings...

    Post edited by mjc1016 on
  • SimonJMSimonJM Posts: 4,824
    edited December 1969

    Beware saving and later loading a scene where you've done this - I think you will need to redo the undoing of the morph on the hair.

  • SickleYieldSickleYield Posts: 7,154
    edited December 1969

    mjc1016 said:
    That's a great simple solution! I'm going to try it myself. :)

    Actually, it's the only solution short of chewing off your arm. ;)

    I've never know that to be particularly effective...because then you are disarmed and have no way of fighting off the hordes of pointy-eared, freaky-haired zombie elflings...

    Seriously, the masticatory amputation method sucks at fixing conformation issues. Don't do that.

  • Harry DresdenHarry Dresden Posts: 365
    edited December 1969

    Well the reason why chewing on limbs is sometimes a last resort is because the pain involved usually distracts from the pain of certain failure. :lol:

  • mjc1016mjc1016 Posts: 15,001
    edited December 1969

    SimonJM said:
    Beware saving and later loading a scene where you've done this - I think you will need to redo the undoing of the morph on the hair.

    A more permanent fix involves updating the assets involved to turn off Auto Follow...

    I think Bejaymac wrote out the procedure in one of the other threads on this subject.

  • vwranglervwrangler Posts: 2,939
    edited December 1969

    SimonJM said:
    Beware saving and later loading a scene where you've done this - I think you will need to redo the undoing of the morph on the hair.

    What I've found is that once you figure out which morphs are causing the issue -- eyelashes and long hair are particularly annoying these days, for some reason -- simply locking the sliders involved seems to take care of it for that particular file.

    The weird thing is that it's so bizarrely random. I really don't understand why some morphs get passed into hair and some don't, and for some characters they cause problems while others are fine. For example, I've used Damaris hair on more than one character without an issue, but then I stuck it on one and the eyelashes caused it to warp all over the place. I had to dial out every single lash morph in the hair and lock them down.

  • dan.shivedan.shive Posts: 0
    edited December 1969

    It's all about auto-follow and whether anything you care about overlaps with a morphed area that has auto-follow applied. Something worth noting is that turning off (or on) auto-follow on a morph after followers have been fitted to the character won't make any difference until after saving and reloading. Once the generated shape morph is added to the follower, auto-follow is basically on or off until such a time as the scene reloads and re-evaluates such things.

    To the point, it's probably easiest to just show hidden properties in parameters, set offending morphs on the follower to zero, and lock them. Or, if you don't use ANYTHING that will benefit from auto-follow, consider editing auto-follow out of those morphs and saving modified morph assets.

  • kitakoredazkitakoredaz Posts: 3,526
    edited January 2013

    Something worth noting is that turning off (or on) auto-follow on a morph after followers have been fitted to the character won’t make any difference until after saving and reloading. .

    dan.shive is right.

    change auto-followed morph parameter value to zero , as Lindsey telled.
    it must work to remove problem about current status. and it must need.

    once morph generated to the hair. "check off " auto followed can not work.
    need to remove and reloading the hair without fit- to, then check off "auto-follow"
    save it as morph, or save modified assets, it keep "non auto-follow" permanently.
    the way is tweaking genesis morph files.

    another way is tweaking , change "auto-generated" morph, type as "overwritten original morph" of the Hair
    then save the locked condition.

    1 ,sellect the "hair"
    serch auto-followd morph, as Lindsey said, on the controller, use parameter setting,

    type change "Modifier/shape/generated" to " Modifier/shape"
    then lock the value as zero. or use limits. then "0" min "0" max, may work.

    it can work about the scene or scene subset which saved as.

    (it simply, as if overwrite auto-followd morph with your setting,
    but actually I did not "save the morph" again.)

    if hope to keep the setting about Hair, parmanentlly, I may need to save it as morph, or use, "save modified assets" about Hair..
    then overwrite generated morph, by original setting morph.

    after that, the morph are saved , as one of original hair morphs in morph directory of the hair.
    keep the "locked value"

    (edit "rock" to "lock" @@;)

    typechange.JPG
    597 x 446 - 58K
    Post edited by kitakoredaz on
  • kitakoredazkitakoredaz Posts: 3,526
    edited December 1969

    1 change type to "modified shape", of the generated morph to the hair.

    2 check on use limits , then min 0 to max 0, (Empty Range)
    the morph can not work never.

    3 save the hair as scene subset,(or save the morph again,,)

    I can use the hair subset , (or the hair,,if save as morph)
    which can not generate the genesis ear morph any more.

    when tweak genesis ear morph,, ds try to generate morph.
    but,, the hair has same name morph already,,
    and the morph can not work, just keep zero value ^^

    it seems best way for me.

    (if only change value to zero, and lock ,, when off fit to from genesis,
    the hair set value the morph as minus value, then lock the value.
    it seems not good so need to use limits,, ^^; )

    nonearmorphsub.JPG
    854 x 645 - 104K
  • Scott LivingstonScott Livingston Posts: 4,275
    edited December 1969

    Thank you Lindsey! I was aware of this fix, but that was the clearest explanation of it that I have seen.

    And thank you everyone who posted about the issue with saving and reloading, and what to do about it. I learned some new things!

    I've updated my Hair Tutorial with this information (Lindsey, I hope you don't mind that I've quoted you).
    http://www.daz3d.com/forums/discussion/5646/

  • RenpatsuRenpatsu Posts: 828
    edited December 1969

    SimonJM said:
    Beware saving and later loading a scene where you've done this - I think you will need to redo the undoing of the morph on the hair.

    According to the change log and the bug tracker the save/load issue should have been fixed in 4.5.1.32, so this should actually function properly in the latest public release 4.5.1.56. I did not test it myself ... yet

    Fixed #48338 : Modified hidden auto-follow morphs in Genesis conformers do not survive scene DUF save→load cycle

    Change Log 4_5_1_56

    https://bugs.daz3d.com/view.php?id=48338

  • kitakoredazkitakoredaz Posts: 3,526
    edited December 1969

    Renpatsu ^^

    SimonJM did not say about "Modified hidden auto-follow morphs in Genesis."

    As you know,, the morph of genesis which change earshape and the morph generated to the Hair are different.

    he said if change value of generated morph to the hair, ,(I think it is very useful and good way too)
    when save it as scene or scene subset.,the value of generated morph of the Hair can not keep the value

    Though I did not test them top,, but I believe duf scene file can not record and set the value of generated morph of the hair.
    We may need to change type of generated morph if hope so.
    .

  • RenpatsuRenpatsu Posts: 828
    edited January 2013

    Renpatsu ^^

    SimonJM did not say about "Modified hidden auto-follow morphs in Genesis."

    As you know,, the morph of genesis which change earshape and the morph generated to the Hair are different.

    he said if change value of generated morph to the hair, ,(I think it is very useful and good way too)
    when save it as scene or scene subset.,the value of generated morph of the Hair can not keep the value

    Though I did not test them top,, but I believe duf scene file can not record and set the value of generated morph of the hair.
    We may need to change type of generated morph if hope so.
    .

    SimonJM's response was towards the change of the hidden auto-follow properties in the hair (which get applied from Genesis initially via auto-follow) not getting saved properly, the same the bug report is about.

    Modified hidden auto-morphs in Genesis conformers

    Conformers as in e.g. hair.

    I just loaded Genesis, loaded some hair, applied elf ears, modified the hidden auto-follow property on the hair to 0%, saved as DUF scene and reloaded. This worked in 4.5.1.56 64-bit on MacOsX.

    Post edited by Renpatsu on
  • SimonJMSimonJM Posts: 4,824
    edited December 1969

    Renpatsu said:
    Renpatsu ^^

    SimonJM did not say about "Modified hidden auto-follow morphs in Genesis."

    As you know,, the morph of genesis which change earshape and the morph generated to the Hair are different.

    he said if change value of generated morph to the hair, ,(I think it is very useful and good way too)
    when save it as scene or scene subset.,the value of generated morph of the Hair can not keep the value

    Though I did not test them top,, but I believe duf scene file can not record and set the value of generated morph of the hair.
    We may need to change type of generated morph if hope so.
    .

    SimonJM's response was towards the change of the hidden auto-follow properties in the hair (which get applied from Genesis initially via auto-follow) not getting saved properly, the same the bug report is about.

    Modified hidden auto-morphs in Genesis conformers

    Conformers as in e.g. hair.

    I just loaded Genesis, loaded some hair, applied elf ears, modified the hidden auto-follow property on the hair to 0%, saved as DUF scene and reloaded. This worked in 4.5.1.56 64-bit on MacOsX.

    Can't test at the moment, but I am sure it failed for me, with latest (4.5.1.56) version on 64-bit windows. I presume this auto-follow thing is on a per-morph basis?

  • DrowElfMorwenDrowElfMorwen Posts: 393
    edited December 1969

    Lindsey, thank you so much!!! Problem fixed!

  • kitakoredazkitakoredaz Posts: 3,526
    edited December 1969

    I just loaded Genesis, loaded some hair, applied elf ears, modified the hidden auto-follow property on the hair to 0%, saved as DUF scene and reloaded. This worked in 4.5.1.56 64-bit on MacOsX.

    I understand. Renpatsu you are right. it can work about the scene.

    Now I checked with ds 4.5.1.56 64bit ver ,windows 7 .

    if I change value of auto-follow morph ,and save genesis and hair, as scene it can keep value
    with genesis.

    I usually saved hair as scene subset, then select genesis another scene.
    load subset hair. so geensis generated the ear morph shape again.

    if save the hair as subset, must need change auto followd morph type , then set limits min 0 and max 0.
    the hair can be use with every scene genesis. (even though I off fit the hair, then fit to another figure, need not modify)

Sign In or Register to comment.