Congratulations! You are a March Madness BONUS BUYER!

Enjoy 10% OFF* ALL PURCHASES STOREWIDE or enjoy 30% OFF items with a SKU number lower than 16000 & 30% OFF items from Runtime DNA.

Offer valid for intended recipient only
* 10% discount DOES apply to Gift Cards and Memberships. **Items must be in cart simultaneously for discount to apply.
[ collapse ]

Making the light invisible

How do you make the light inivisible in render while the actual light is still working? Is it possible to just make the "physical parts" of the light invisible while the actual lighting is still there?

Comments

  • FirstBastionFirstBastion Posts: 3,569

    If you use a mesh light,  you can set the cutout opacity to a negligible number like .001 to effectively hide the lightplane while the emitter still casts all the light. 

  • If you use a mesh light,  you can set the cutout opacity to a negligible number like .001 to effectively hide the lightplane while the emitter still casts all the light. 

    Can you kindly show me a screen shot? all i see are ray,base, and edge opacity

  • pdspds Posts: 394

    If you use a mesh light,  you can set the cutout opacity to a negligible number like .001 to effectively hide the lightplane while the emitter still casts all the light. 

    Can you kindly show me a screen shot? all i see are ray,base, and edge opacity

    Cutout opacity is in the Surfaces tab toward the bottom. You need to have the mesh light node selected in the Scene tab first. Also, be sure your render mode is set to IRay.

  • This si the technique used in the Ghost Lights product.

  • TabascoJackTabascoJack Posts: 751
    edited January 12

    And if you're talking about photometric lights (such as spotlights, pointlights, etc.) there is a "Render Emitter" button in the light's parameters.  Set it to "Off", which tells Daz not to render the light itself.

    Post edited by TabascoJack on
  • And if you're talking about photometric lights (such as spotlights, pointlights, etc.) there is a "Render Emitter" button in the light's parameters.  Set it to "Off", which tells Daz not to render the light itself.

    But will the lighting still be active? 

  • Note that if a 'render emitter:off' geometry is behind something with transparency, it can glitch (see: hair glowing halo effect)

     

  • pds said:

    If you use a mesh light,  you can set the cutout opacity to a negligible number like .001 to effectively hide the lightplane while the emitter still casts all the light. 

    Can you kindly show me a screen shot? all i see are ray,base, and edge opacity

    Cutout opacity is in the Surfaces tab toward the bottom. You need to have the mesh light node selected in the Scene tab first. Also, be sure your render mode is set to IRay.

     

    pds said:

    If you use a mesh light,  you can set the cutout opacity to a negligible number like .001 to effectively hide the lightplane while the emitter still casts all the light. 

    Can you kindly show me a screen shot? all i see are ray,base, and edge opacity

    Cutout opacity is in the Surfaces tab toward the bottom. You need to have the mesh light node selected in the Scene tab first. Also, be sure your render mode is set to IRay.

    I still can't find it in tthe surfaces tab. Is it in the shaders? 

  • Can't find the cutout opacity, I'm planning to make the lights invisible withouut turning off the lights but I just can't find the cutout opacity. Can someone tell me clearly where exactly it is?

  • PedroCPedroC Posts: 39
    edited January 16

    For emiters mesh, Iray material:

    Surface tab >  "surface item list"  > Geometry

     

    For ligths you can't make them "invisible", maybe lights tab > Light > Area > render Emiter : Off

    Post edited by PedroC on
  • HavosHavos Posts: 2,708
    PedroC said:

    For emiters mesh, Iray material:

    Surface tab >  "surface item list"  > Geometry

     

    For ligths you can't make them "invisible", maybe lights tab > Light > Area > render Emiter : Off

    By reducing the cutout opacity to a very small value you can effectively make them invisible whilst they continue to cast light.

  • PedroC said:

    For emiters mesh, Iray material:

    Surface tab >  "surface item list"  > Geometry

     

    For ligths you can't make them "invisible", maybe lights tab > Light > Area > render Emiter : Off

    Oh alright, I'm using painter's light. I just want the "physical" part of the lights to be invisible but still retain the lighting.

  • PedroCPedroC Posts: 39
    edited January 16
    pds said:

    If you use a mesh light,  you can set the cutout opacity to a negligible number like .001 to effectively hide the lightplane while the emitter still casts all the light. 

    Can you kindly show me a screen shot? all i see are ray,base, and edge opacity

    Cutout opacity is in the Surfaces tab toward the bottom. You need to have the mesh light node selected in the Scene tab first. Also, be sure your render mode is set to IRay.

     

    pds said:

    If you use a mesh light,  you can set the cutout opacity to a negligible number like .001 to effectively hide the lightplane while the emitter still casts all the light. 

    Can you kindly show me a screen shot? all i see are ray,base, and edge opacity

    Cutout opacity is in the Surfaces tab toward the bottom. You need to have the mesh light node selected in the Scene tab first. Also, be sure your render mode is set to IRay.

    I still can't find it in tthe surfaces tab. Is it in the shaders? 

    Are you using an Iray material ?

    Post edited by PedroC on
  • Merged threads since they were aspects of the same topic.

  • L'AdairL'Adair Posts: 2,308
    edited January 16

    Cutout Opacity is found under the Surfaces>Editor tab. Select the mesh light in the Scene tab, then select the mesh light in the Editor. Double-click the Mesh light in the editor tab and you should see subsections of the parameters. Click on Geometry and Cutout Opacity will be the first parameter listed. Alternatively, you can select the mesh light in the Editor and type Opacity in the filter field and Cutout Opacity will be the only parameter listed.
     

    Where to find Cutout Opacity in Daz Studio parameters


    As I stated in another thread, Kindred Arts posted a tutorial on how to create Ghost Lights here, which you may find helpful. (I used what I learned in that short tutorial thread before the Iray Ghost Light Kit was released, but I still bought the product when it came out, and consider it one of my better investments.)

    where-to-find-cutout-opacity.jpg
    565 x 617 - 159K
    Post edited by L'Adair on
  • PedroC said:
    pds said:

    If you use a mesh light,  you can set the cutout opacity to a negligible number like .001 to effectively hide the lightplane while the emitter still casts all the light. 

    Can you kindly show me a screen shot? all i see are ray,base, and edge opacity

    Cutout opacity is in the Surfaces tab toward the bottom. You need to have the mesh light node selected in the Scene tab first. Also, be sure your render mode is set to IRay.

     

    pds said:

    If you use a mesh light,  you can set the cutout opacity to a negligible number like .001 to effectively hide the lightplane while the emitter still casts all the light. 

    Can you kindly show me a screen shot? all i see are ray,base, and edge opacity

    Cutout opacity is in the Surfaces tab toward the bottom. You need to have the mesh light node selected in the Scene tab first. Also, be sure your render mode is set to IRay.

    I still can't find it in tthe surfaces tab. Is it in the shaders? 

    Are you using an Iray material ?

    Im using painters light on Genesis 2. I select the back lighting from painters light and I just can't see a cut out opacity but it does have render emitter off. Actually I think it's already invisible when the render emitter is off I just thought it's not because the back light is really strong but do you think painters light can still have cutout opacity?

  • fastbike1fastbike1 Posts: 1,287

    If it's a spot or point the Render Emitter >Off setting will allow the effects of the light without the light body showing in the render.

  • L'AdairL'Adair Posts: 2,308
    PedroC said:
    pds said:

    If you use a mesh light,  you can set the cutout opacity to a negligible number like .001 to effectively hide the lightplane while the emitter still casts all the light. 

    Can you kindly show me a screen shot? all i see are ray,base, and edge opacity

    Cutout opacity is in the Surfaces tab toward the bottom. You need to have the mesh light node selected in the Scene tab first. Also, be sure your render mode is set to IRay.

     

    pds said:

    If you use a mesh light,  you can set the cutout opacity to a negligible number like .001 to effectively hide the lightplane while the emitter still casts all the light. 

    Can you kindly show me a screen shot? all i see are ray,base, and edge opacity

    Cutout opacity is in the Surfaces tab toward the bottom. You need to have the mesh light node selected in the Scene tab first. Also, be sure your render mode is set to IRay.

    I still can't find it in tthe surfaces tab. Is it in the shaders? 

    Are you using an Iray material ?

    Im using painters light on Genesis 2. I select the back lighting from painters light and I just can't see a cut out opacity but it does have render emitter off. Actually I think it's already invisible when the render emitter is off I just thought it's not because the back light is really strong but do you think painters light can still have cutout opacity?

    "Mesh Lights" are geometry (mesh) with emissive surfaces. A plane, a sphere, part of a larger model, etc. Cutout Opacity is an Iray parameter on objects. Painter's Lights combines Render Setting environments with spotlights. Spotlights do not have Cutout Opacity. You would want the Render Emitter set to off. If the light is too strong, you would want to lower the value in the Luminous Flux (Lumen) parameter of the light,

Sign In or Register to comment.