Generation X2 and Morphs, Characters, Presets and Poses?

I'm fairly new to all of this, so clearly I don't understand all the terms or technological frameworks going on with DAZ Studio, and I think that is part of the problem I am experiencing with Generation X2. 

Sometimes I transfer a morph or a character and it works great on the destination. Sometimes it turns the destination figure into a monster when I activate the morph, and other times, nothing happens at all... or you know, maybe the eyebrows raise or the lips change shape - but the actual character or morph I was trying to transfer isn't the end result. 

Playing around with it today at some length, I feel like I'm near some sort of realization of what I am doing wrong, as well as getting a better understanding of the difference between figures, characters, poses, presets, morph injections, and legacy poser formats versus DAZ studio formats... which, I think are ALL going to have some sort of impact on if what you want to transfer from one generation to another will work right or not. 

I'm hoping some of the old pros around here can help me better understand this and if my thinking is on the right track. 

We'll use a transfer from a source figure of Victoria 4 to a target shape of Genesis for this example.... 

I load Victoria 4.2 either using the GenX plugin "source" button

or by loading her in DAZ studio (using PowerLoader to select V4.2 Aiko 4 Morphs and V 4.2 base Morphs and Morphs++, with Generate ExP Files checked, including support for all listed products) 

If I look at BODY and head nothing is selected. If I "Select" "On For All Non Zero Values", still nothing is selected. All values are zero. 

Now... if I have loaded the Victoria 4 character in DAZ studio, select her in the scene tab, and in the Parameters tab I dial Aiko4 to 1.00...  Victoria 4.2 base's BODY changes to Aiko4. 

If I then select HEAD in the scene tab, then drill down to Morphs/Shapes in the Parameters tab and dial Aiko4 to 1.00, her HEAD changes to Aiko 4 too.

Go back into the GenX tab and "Select" "Get Values From Figure In Scene", *still* nothing is selected. Then "select" "transfer for all non zero values"... 

And STILL nothing is selected. OK. So that is a bust. If I select Mode "Select morphs (with properties), Shape, Victoria 4 (Legacy) and Target Genesis and click Transfer, I get the dialog...

"No morphs selected for transfer. Continue anyway? (Creates clone Morphs if missing.)"

So I delete Victoria 4 from the Scene tab. and click reset in the GenX tab. 

Now, in the content library tab, I open Poser Formats\My DAZ 3D Library\Figures\DAZ People and drag the Aiko 4 icon there (which has a little icon of a Script in the upper left hand corner), into the Transfer tab of the GenX tab... 

I get a loading dialog that reads "resolving script calls" and it loads Victoria 4 as the source, In the window below, if I expand Body and head, I see that the Aiko4 morphs are now listed, where they weren't listed above. If I "select" "On for all non zero values" I see that in Body Aiko4 has a check and in head Aiko4 has a check. 

Below in Mode I select "Selected morphs (with properties)

In Shape I select Victoria 4 (Legacy)

Target Genesis and click Transfer I get a dialog "Target figure is not supported for selected source or shape". Ok... WTF... So... INSTEAD... 

I click OK, and in Target I select Genesis 2 Female and click Transfer... 

This is more like it... I get a dialog, Transferring morph: Aiko4 and then a Morph Properties Dialog with an identifer, a name, a group, a region... all the good stuff.. I click accept, I get a Morph Properties dialog for the base head. 

clear the scene and load Genesis 2 Female Base... Switch to the main viewport... select Genesis 2 Female in Scene tab, select parameters... Drill down to Actor\Generation X... select Victoria 4 (Legacy) and dial to 1.00... Yup, there she is... 

Dial Aiko4 to 1.00 - yup, there is her body... No head though... Can't find a different morph dial for her head anywhere, even if I just select the HEad from the Scene tab. There is no Generation X subcategory there. If I select "All" in the Parameter's tab and filter by Aiko, I see Aiko 6 body, (2) Aiko4, Aiko 6 head and Aiko 6 as the only filtered results.

 So, back to GenX... maybe I should have just slected "Mode: Create single morph." That sounds right, if I don't want to have separate controls for the body and head, to at least get this working... 

I'll change Mode and leave everything else alone, and click Transfer again. 


Morph Properties comes up again. Identifier "Aiko4test" Name "Aiko4_test" 

Click accept. 

New scene... reload Gen 2 base female... 

Select G2F in Scene, in Parameters, drill down to Generation X. Set Vic4 Legacy to 1. There she is... 

Scroll down a bit, I see Aiko4_test. Let's dial that up to 1...

 ‚ÄčTHERE she is... big head, huge eyes, curvy body, on G2F. Something has gone terribly wrong with her genital crease. That is frightening. I'll have to figure that out later. 

Follow up post with some questions coming. Stick around if you might have some answers, because I've got some questions... 















 

Comments

  • Let's try the same thing as above with Sephanie 4. Ok... that all works... 

    I load G2F, change to Vic 4, find the slider for Stephanie4forG2F, slide it... and everything disappears, including the grid, in the viewport. Dial it back down to 0, and everything reappears. The Aiko4 morph still works fine. 

    Let's try it this way instead. In the content library I click on the Stephnie 4 script in the poser DAZ People folder. PowerLoader launches... I check the S4 morphs, uncheck the Aiko 4 morphs. Leave Base Morphs and Morphs++ checked. Click accept. S4 loads in the Viewport, I select her in the Scene tab. Go into the GenX tab... 

    Now, interestingly, in the Source button, originally it only said Genesis, Genisis 2 Female, Genesis 2 Male, Genesis 3 Female, Genesis 3 Male, and a line separating additional entries for Victoria 4.2 and the Kids 4 - evidently source figures don't show there until you load them the first time. OK... I'm not going to select Stephanie 4, because she didn't work. I'm going to select Victoria 4.2 as the source...

     In "Select" "On for All Non Zero values" confirm nothing is selected, all values are zero. 

    "Select" "Get Values from Figure In Scene" with Stephanie 4 selected. Still all values are zero. "Select" "Transfer for all Non Zero Values," again. Still nothing. 

    I mean, in my viewport, either way, I'm seeing Stephanie 4 - but she won't transfer right. Why? I don't know. 

    So, I tried using 3D Universe's Teen Ashley. That character is located in the Poser POSE folder and the icon has the word, "Shape" in the upper right hand corner over a bar running up the side that says "Character Pose". 

    If I use S4 as the source base figure, as designed, and transfer via GenX, I get the same problem. The minute I touch the dial everything in the viewport goes grey. If I use Victoria 4, it works as a GenX2 morph for G2F. 

    BUT... I have to use "Apply Pose" in GenX - so even though she changes the entire look of V4.2, she isn't actually a moprh, she is a POSE, right? 

    But other Freebie Characters I try the same way... load Victoria 4 as the Source Character, click Apply Pose, navigate to the folder and load the "pose" morphs for V4 head and body... 

    They don't cause any signifcant change in the target G2F character I create. 

    I can't figure that out. Why does the Akio4 Character Script work fine, but the S4 character script doesn't? 

    Why does the Ashley Character Pose work fine, but many freebie character poses don't? 








     

    , now I have options for Aiko 4 and Stephanie 4. 
     

     before it only said 

    And what is the best way to delete the test morphs I create that don't work? Up until this point I've been navigating in the directory to where those morphs are and deleting them from the file system, but today I noticed a morphs tab. I can select the generation from the pulldown menu... G2F in this case... 

    Then there are buttons beneath that for GenX or All. Let's select GenX... 

    Now I have a folder hierarchy view in the workspace window... Folders, Genesis, Genesis 3 Female, Victoria 4, Victoria 4 (clone) and Victoria 4 (Legacy) and a bunch of transfered morphs beneath that in the root. They all have checks enabled by them. 

    If I expand the folders, I see the names of the test morphs I created as I wrote this up. 

    In the Victoria4 (Legacy) folder I see "Stephanie 4". If I click on that entry it highlights.

    Beneath the workspace window are 5 buttons...

    Morph: Enable Disable
    Backup: Restore Remove
    File: Delete

     Ok... the Morph: Enable / Disable buttons add or remove the checks next to the morphs. 

    So I'm going to guess that File: Delete removes the highlighted Morph from the file system. Ok... that worked. At least, that morph is gone from the list yet. I haven't checked to see if it is actually removed as a file. 



     

  • Found an excellent tutorial on Generation X2 at ShareCG

    http://www.sharecg.com/v/82453/view/3/PDF-Tutorial/GenX-Plugin-Tutorial

     

Sign In or Register to comment.