Ships of the Line - MEGA THREAD - **Updated 2019-03-28**

1234568»

Comments

  • MattymanxMattymanx Posts: 5,964
    njs said:

    About a week ago, I registered myself on Foundation3D. I haven't been able to download lightsabers from the resources yet because I may have to be patient for my account to be activated.

    So it may be a week or a month before I get a valid script from them.

    Might be a lot longer then that but I do not know.  Its not somethig I have control over

  • njsnjs Posts: 54

    You're absolutely right, it could take even longer than a month.

    However, the administrators have control over it for now.

    But I'm glad that I was able to register on there.

  • MattymanxMattymanx Posts: 5,964
    edited March 28

    Thank you for mentioning that.  I just went to F3D and found the thread about it.  I will pass on the info.

     

    http://www.foundation3d.com/forums/showthread.php?t=21850

    Post edited by Mattymanx on
  • tkdroberttkdrobert Posts: 2,240
    edited March 28

    I never got in over there.  I tried months ago.

    Edit: I just saw your post on the Star Trek page.  I can't access the site from work.  I'll try and register later tonight.

    Post edited by tkdrobert on
  • MattymanxMattymanx Posts: 5,964
    tkdrobert said:

    I never got in over there.  I tried months ago.

    Please try again.

Sign In or Register to comment.