Any tricks to render hair faster?

XdyeXdye Posts: 0
edited December 1969 in Daz Studio Discussion

I would like to know if there is any trick to render hairs faster. My problem is that i set up lights for high quality onto a figure, I achive a very realistic render of a figure that takes about 3-5 min to render but then when i add the hair to the figure it takes like 30-40 min to render.

I would like to know if there is some method to render just the hair without occlusion, to explain myself, i put an uberenviorment to the scene and i would like to render the figure with occlusion shadows but the hair just with ambiental light. is that possible? Or there is at least some trick to lower the render time even if its not so good?


  • SickleYieldSickleYield Posts: 7,512
    edited December 1969

    I'm very willing to be corrected if wrong, but I don't think DAZ has an option to have items react differently to the lighting that way.

    Hairs have layered transparency. Layered transparency takes a long time to render in DAZ (also in Poser). Usually we just have to accept the higher render cost. You can also:

    -When possible, use a geometry hair with no transmaps. Adam Thwaites at MOSTDigitalCreations has made some, and Oskarsson has one in his store at Renderosity.

    -Choose your transmap hairs carefully. Don't use Aerysoul's curly one, StudioArtVartanian's Spartacos hair, or others that are made for higher system requirements and take forever to render on anything less. You can ask around about this before buying a hair. (SAV's other hairs are mostly much faster, incidentally; I use their Sissy LeBeaux set quite a lot.) My 3Dream/Mairy hairs are usually fairly efficient, too.

    Usually the longer and denser a hair is, the more layers it has, and the longer it will take.

  • IndigoneIndigone Posts: 86
    edited December 1969

    You can turn off raytracing on the hair material zones if you are using Uber Surface shaders. I don't think the daz default shader has that option, but Uber surface (and uber hair) do have it. Just select all the hair material zones and click it off. Click off Ambient Occlusion too. If you need to see a screen shot, let me know and I'll try to put one up.

    Usually if it increases that much when you add hair, you have probably got lights that raytrace, and that's what slows rendering to a crawl on transparencies.

    Hope it helps.


  • XdyeXdye Posts: 0
    edited December 1969

    Wow it worked, i used ubersurface and turned off oclusion and raytracing, and the hair even looks more real than with occlusion.

    It took me 6 min to render while the other way it would take more than 20. Thank you very much. The pic is the proof, 6 min to render i think is nice quality for this time.

    791 x 836 - 234K
  • SickleYieldSickleYield Posts: 7,512
    edited December 1969

    Good trick! I'll have to try it myself. :)

  • pwiecekpwiecek Posts: 1,377
    edited December 1969

    This is probably NOT what you want to hear, but there are a LOT of postwork tools made specifically for hair.

  • IndigoneIndigone Posts: 86
    edited December 1969

    Great!! Glad you got it running. Render looks awesome.

Sign In or Register to comment.