Daz Install Manager (DIM) 1.4.0.80, Now Available! (*UPDATED*)

145791014

Comments

  • FixmypcmikeFixmypcmike Posts: 19,013
    hookflash said:
    hookflash said:

    Anyone else having issues with content installed via DIM 1.4.0.46 not showing as installed in Smart Content in Daz? I'm having to reimport metadata in Daz every time I install via DIM now, which is pretty annoying. 

    Repeatedly or from one session? It's possible, if you closed DS and then opened DIM, that PostgreSQL was not available when DIM was running and so did not get updated.

    It's happened with my last 2 purchases, with a reboot in between. The connection between Daz and DIM seems to have gotten broken somehow (but not entirely broken, since I'm still able to reimport metadata to fix things).

    Can you check that DS and DIM are still using the same Content Database path?

  • hookflashhookflash Posts: 151
    hookflash said:
    hookflash said:

    Anyone else having issues with content installed via DIM 1.4.0.46 not showing as installed in Smart Content in Daz? I'm having to reimport metadata in Daz every time I install via DIM now, which is pretty annoying. 

    Repeatedly or from one session? It's possible, if you closed DS and then opened DIM, that PostgreSQL was not available when DIM was running and so did not get updated.

    It's happened with my last 2 purchases, with a reboot in between. The connection between Daz and DIM seems to have gotten broken somehow (but not entirely broken, since I'm still able to reimport metadata to fix things).

    Can you check that DS and DIM are still using the same Content Database path?

    Yep, confirmed that it's the same CMS path. Really weird. I did a database reset within Daz, so I'll find out next time I make a purchase whether that resolved things (I'm not too hopeful).

  • TaozTaoz Posts: 8,922
    Sevrin said:

    Got an error when trying to update DIM, and then when I went to get a fresh installer, I get this error.

    I got that one too on one PC, it was Malwarebytes locking the file so I had to shut it down to continue.   It's been doing that a lot lately which is very annoying so I've complained about it - it just seems to be locking any new exe file it does't know without any further notice.  It has an option for popping up a dialog where the user can choose to whitelist the file so it doesn't get blocked, but it simply doesn't work, it just blocks files silently anyway. 

  • TaozTaoz Posts: 8,922

    1.4.0.46 now insisted on updating again, but still same version.  This is the second time it has done this.  1.4.0.35 also did that once.

  • Well, this has stuffed up my system! It's trying to install the DAZ programs to my runtime (E: RUNTIMES) instead of where my programs are (F: Programs). I have an SSD drive as my C drive, and no matter what I do, DAZ does weird things and insists on putting files on the C Drive. This new DIM version is screwing it all up even more! I now seem to have program and library files all over my C, E and F drives. And it won't install a bunch of stuff it told me I have to have - I get the same messages someone earlier on this board did. I am struggling enough with space, I really didn't need a rogue installation. SIGH! I have to go finish a job now, will spend time later going through all the replies here. Very disheartening. :(

  • DoctorJellybeanDoctorJellybean Posts: 5,458

    Well, this has stuffed up my system! It's trying to install the DAZ programs to my runtime (E: RUNTIMES) instead of where my programs are (F: Programs). I have an SSD drive as my C drive, and no matter what I do, DAZ does weird things and insists on putting files on the C Drive. This new DIM version is screwing it all up even more! I now seem to have program and library files all over my C, E and F drives. And it won't install a bunch of stuff it told me I have to have - I get the same messages someone earlier on this board did. I am struggling enough with space, I really didn't need a rogue installation. SIGH! I have to go finish a job now, will spend time later going through all the replies here. Very disheartening. :(

    Did you use Basic Settings or Advanced Settings to specify the locations?

    I would have thought that the SSD drive would be used for applications, due to the speed.

  • Well, this has stuffed up my system! It's trying to install the DAZ programs to my runtime (E: RUNTIMES) instead of where my programs are (F: Programs). I have an SSD drive as my C drive, and no matter what I do, DAZ does weird things and insists on putting files on the C Drive. This new DIM version is screwing it all up even more! I now seem to have program and library files all over my C, E and F drives. And it won't install a bunch of stuff it told me I have to have - I get the same messages someone earlier on this board did. I am struggling enough with space, I really didn't need a rogue installation. SIGH! I have to go finish a job now, will spend time later going through all the replies here. Very disheartening. :(

    Install Manager or Central? If it's Install manager check the path settings

  • IvyIvy Posts: 6,816

    when I updated dim today I got a new message and every time i open dim since which has been 3 times ( I am trying to reload some content.)  i keep getting this automatic install message is there anyway to turn it off so it does not come back wanting to automatically install daz studio or content on my system?

    Capture.JPG
    853 x 877 - 110K
  • DoctorJellybeanDoctorJellybean Posts: 5,458
    Ivy said:

    when I updated dim today I got a new message and every time i open dim since which has been 3 times ( I am trying to reload some content.)  i keep getting this automatic install message is there anyway to turn it off so it does not come back wanting to automatically install daz studio or content on my system?

    Uncheck all the checked DAZ Studio component items, then uncheck Show Automatically and click Start Queue. As nothing is checked , nothing should be installed and that window should close.

  • IvyIvy Posts: 6,816
    Ivy said:

    when I updated dim today I got a new message and every time i open dim since which has been 3 times ( I am trying to reload some content.)  i keep getting this automatic install message is there anyway to turn it off so it does not come back wanting to automatically install daz studio or content on my system?

    Uncheck all the checked DAZ Studio component items, then uncheck Show Automatically and click Start Queue. As nothing is checked , nothing should be installed and that window should close.

    Thank you for your reply so I need to uncheck everything & then uncheck show automatically to stop it from popping up....    Okay I was afraid to check anything I did not want to install any new copy of daz studio at this time that is why I wanted to ask how to stop it. So  after that I should be able to just manually install what I need then? .. cool thanks

  • IvyIvy Posts: 6,816

    Thanks again DoctorJellybean  that worked

  • DoctorJellybeanDoctorJellybean Posts: 5,458

    You are welcome.

  • KeryaKerya Posts: 10,700
    Ivy said:

    when I updated dim today I got a new message and every time i open dim since which has been 3 times ( I am trying to reload some content.)  i keep getting this automatic install message is there anyway to turn it off so it does not come back wanting to automatically install daz studio or content on my system?

    Uncheck all the checked DAZ Studio component items, then uncheck Show Automatically and click Start Queue. As nothing is checked , nothing should be installed and that window should close.

     

    That worked for me too! Thank you!!!!!!!!!!!!!!!

  • DoctorJellybeanDoctorJellybean Posts: 5,458
    edited July 2020
    Kerya said:
    Ivy said:

    when I updated dim today I got a new message and every time i open dim since which has been 3 times ( I am trying to reload some content.)  i keep getting this automatic install message is there anyway to turn it off so it does not come back wanting to automatically install daz studio or content on my system?

    Uncheck all the checked DAZ Studio component items, then uncheck Show Automatically and click Start Queue. As nothing is checked , nothing should be installed and that window should close.

     

    That worked for me too! Thank you!!!!!!!!!!!!!!!

    yes

    Post edited by DoctorJellybean on
  • Well, this has stuffed up my system! It's trying to install the DAZ programs to my runtime (E: RUNTIMES) instead of where my programs are (F: Programs). I have an SSD drive as my C drive, and no matter what I do, DAZ does weird things and insists on putting files on the C Drive. This new DIM version is screwing it all up even more! I now seem to have program and library files all over my C, E and F drives. And it won't install a bunch of stuff it told me I have to have - I get the same messages someone earlier on this board did. I am struggling enough with space, I really didn't need a rogue installation. SIGH! I have to go finish a job now, will spend time later going through all the replies here. Very disheartening. :(

    Install Manager or Central? If it's Install manager check the path settings

     

    Install Manager. I have checked all the install directories, they have not changed, but still today it's reading 12 items installed (which installed just before I sent my desperate message) and 7821 to install - ie it is not looking at the correct folder for my installed items. Same issue with the Central, and in Studio I had to resolve the issue by re-importing metadata. So now I have no idea what has changed. 

  • barbultbarbult Posts: 17,142

    Well, this has stuffed up my system! It's trying to install the DAZ programs to my runtime (E: RUNTIMES) instead of where my programs are (F: Programs). I have an SSD drive as my C drive, and no matter what I do, DAZ does weird things and insists on putting files on the C Drive. This new DIM version is screwing it all up even more! I now seem to have program and library files all over my C, E and F drives. And it won't install a bunch of stuff it told me I have to have - I get the same messages someone earlier on this board did. I am struggling enough with space, I really didn't need a rogue installation. SIGH! I have to go finish a job now, will spend time later going through all the replies here. Very disheartening. :(

    Install Manager or Central? If it's Install manager check the path settings

     

    Install Manager. I have checked all the install directories, they have not changed, but still today it's reading 12 items installed (which installed just before I sent my desperate message) and 7821 to install - ie it is not looking at the correct folder for my installed items. Same issue with the Central, and in Studio I had to resolve the issue by re-importing metadata. So now I have no idea what has changed. 

    Is your DIM manifest archive directory correct? If you look in that folder, are all the manifest files there?

  • barbult said:

    Well, this has stuffed up my system! It's trying to install the DAZ programs to my runtime (E: RUNTIMES) instead of where my programs are (F: Programs). I have an SSD drive as my C drive, and no matter what I do, DAZ does weird things and insists on putting files on the C Drive. This new DIM version is screwing it all up even more! I now seem to have program and library files all over my C, E and F drives. And it won't install a bunch of stuff it told me I have to have - I get the same messages someone earlier on this board did. I am struggling enough with space, I really didn't need a rogue installation. SIGH! I have to go finish a job now, will spend time later going through all the replies here. Very disheartening. :(

    Install Manager or Central? If it's Install manager check the path settings

     

    Install Manager. I have checked all the install directories, they have not changed, but still today it's reading 12 items installed (which installed just before I sent my desperate message) and 7821 to install - ie it is not looking at the correct folder for my installed items. Same issue with the Central, and in Studio I had to resolve the issue by re-importing metadata. So now I have no idea what has changed. 

    Is your DIM manifest archive directory correct? If you look in that folder, are all the manifest files there?

     

    Ummmm... what am I looking for, where, please? Thanks!

     

  • barbultbarbult Posts: 17,142

    Click on the gear icon in the upper right corner f DIM. Select Basic Settings. It shows a link for Manifest Archive. Is that link correct? Click the link. Are your DIM manifest files there? Manifest files are  DSX files that DIM saves so it knows what it has installed. If they get moved or deleted, DIM won't know what it has previously installed. If you installed Daz Central at some time, it may well have mucked with your DIM file paths. People have been screaming loudly about that problem in the forum. 

  • barbult said:

    Click on the gear icon in the upper right corner f DIM. Select Basic Settings. It shows a link for Manifest Archive. Is that link correct? Click the link. Are your DIM manifest files there? Manifest files are  DSX files that DIM saves so it knows what it has installed. If they get moved or deleted, DIM won't know what it has previously installed. If you installed Daz Central at some time, it may well have mucked with your DIM file paths. People have been screaming loudly about that problem in the forum. 

    Yes, it all happened after I installed Central. Suddenly Studio, Central and DIM saw different things. I have just checked the manifest folder, and only a few most recent items are in there - eeek! So the other 7800-odd installations aren't there! Did Central just remove everything in the manifest folder? Dio I have to install everything again? Thanks for your help!

  • DoctorJellybeanDoctorJellybean Posts: 5,458
    barbult said:

    Click on the gear icon in the upper right corner f DIM. Select Basic Settings. It shows a link for Manifest Archive. Is that link correct? Click the link. Are your DIM manifest files there? Manifest files are  DSX files that DIM saves so it knows what it has installed. If they get moved or deleted, DIM won't know what it has previously installed. If you installed Daz Central at some time, it may well have mucked with your DIM file paths. People have been screaming loudly about that problem in the forum. 

    Yes, it all happened after I installed Central. Suddenly Studio, Central and DIM saw different things. I have just checked the manifest folder, and only a few most recent items are in there - eeek! So the other 7800-odd installations aren't there! Did Central just remove everything in the manifest folder? Dio I have to install everything again? Thanks for your help!

    See if the manifest folder which contains the files for the missing installed content exists. If it does, then move the files to the manifest folder as specified in DIM.

  • See if the manifest folder which contains the files for the missing installed content exists. If it does, then move the files to the manifest folder as specified in DIM.

    Okay, I am doing a search for DSX... it's taking a while, nothing yet. Will let you know. Thank you so much!

  • See if the manifest folder which contains the files for the missing installed content exists. If it does, then move the files to the manifest folder as specified in DIM.

    Okay, I am doing a search for DSX... it's taking a while, nothing yet. Will let you know. Thank you so much!

    Found them! Copied them to the new location, restarted DIM, and it's seeing them. THANK YOU! :)

  • DoctorJellybeanDoctorJellybean Posts: 5,458

    See if the manifest folder which contains the files for the missing installed content exists. If it does, then move the files to the manifest folder as specified in DIM.

    Okay, I am doing a search for DSX... it's taking a while, nothing yet. Will let you know. Thank you so much!

    Found them! Copied them to the new location, restarted DIM, and it's seeing them. THANK YOU! :)

    You are welcome.

  • DIM is now telling me it has to install "Alembic for DAZ..." - but when I try to install, it gives me a dialogue box requiring a path to install to - where do I put that, please? Thanks!

  • DoctorJellybeanDoctorJellybean Posts: 5,458

    DIM is now telling me it has to install "Alembic for DAZ..." - but when I try to install, it gives me a dialogue box requiring a path to install to - where do I put that, please? Thanks!

    DAZ Studio should be listed in the Applications tab in Advanced Settings, which also display the path. If it isn't, then the path to install Alembic is (assuming you are using 64 bit)

    C:\Program Files\DAZ 3D\DAZStudio4\plugins

  • DIM is now telling me it has to install "Alembic for DAZ..." - but when I try to install, it gives me a dialogue box requiring a path to install to - where do I put that, please? Thanks!

    DAZ Studio should be listed in the Applications tab in Advanced Settings, which also display the path. If it isn't, then the path to install Alembic is (assuming you are using 64 bit)

    C:\Program Files\DAZ 3D\DAZStudio4\plugins

    Oh great, it refuses that path (On my computer it's F:\DAZ Programs\DAZ 2019\DAZ 410\DAZ 3D\DAZStudio4\plugins - seems VERY complicated!!)...

  • DIM is now telling me it has to install "Alembic for DAZ..." - but when I try to install, it gives me a dialogue box requiring a path to install to - where do I put that, please? Thanks!

    DAZ Studio should be listed in the Applications tab in Advanced Settings, which also display the path. If it isn't, then the path to install Alembic is (assuming you are using 64 bit)

    C:\Program Files\DAZ 3D\DAZStudio4\plugins

    Oh great, it refuses that path (On my computer it's F:\DAZ Programs\DAZ 2019\DAZ 410\DAZ 3D\DAZStudio4\plugins - seems VERY complicated!!)...

    Plus, it's suddenly decided I need a whole lot more stuff including Studio (AGAIN!), and it isn't seeing install paths for any of them! Aaargh! I'm going round in circles! I rue the day I installed Central! I think I'm just going to uninstall the whole damned lot and start again. Like I have the time! Sigh!!

     

  • DoctorJellybeanDoctorJellybean Posts: 5,458

    Sometimes it's best and easier to start from scratch.

  • FixmypcmikeFixmypcmike Posts: 19,013

    If you're setting the path in DIM, leave the "/plugins" off the path.

  • MadbatMadbat Posts: 381

    I get the following error when I try to install. 1.4

    Error copying packaged file from archive

    C:/Users/et-etc/DAZ3D/DAZ3DDIM.exe

    abort|retry|ignore.

    I cannot unistall whatever mess was installed. It will not run.

     

Sign In or Register to comment.