Error - can't open file

Mosk the ScribeMosk the Scribe Posts: 886
edited December 1969 in Carrara Discussion

I've been working on a file for a couple of hours. I then saved and closed so I could put it in the queue to render. When I try to open the file, I get this popup:

File: c:\dazdevel\hudson_home\jobs\nb_carrara_85\build\carrara85\src\mccore\source\common\MCToken.cpp
Line 416
An end of file error occurred while executing open . . . .

Get the same message with a recent copy of the file which used a different camera - so can't open either.

I'm using Windows 7, 64 bit system with 24GB RAM;
Carrara 8.5 Pro 64 bit

File size is just over 4GB. Has several genesis figures sledding down a hill via a motion path.

Any idea what the problem is?
Any workaround so I can open file and render it?
In some ways Carrara seems more stable, but I still run into many errors like this (except most don't have any error message) - and it is hard to describe how frustrating this is.

Thanks for any help.


  • FenricFenric Posts: 351
    edited November 2013

    The most common cause (by a very long way) is extra bytes at the end of the file preventing it from uncompressing. Rename the file "" and unzip it: Either WinZip or 7Zip can do the job (on a mac, you can just double-click it).

    I caution everyone to never save by quitting Carrara. If you go to close, and you get the dialog box "Do you want to save?" and you DO want to save, then hit CANCEL, go back and save, then quit. BUT Carrara 8.5 will sometimes cause this error regardless of when you save, particularly with Genesis in the scene.

    I know it's a huge file, but you are still best off saving uncompressed and using the OS's built-in file compression if you need to save space (both Windows and MacOS have built-in compression these days. Mac's is just less convenient to use)

    Post edited by Fenric on
  • Mosk the ScribeMosk the Scribe Posts: 886
    edited November 2013

    Hey Fenric -

    I don't think I compressed the file (I routinely uncheck the box so it saves without compressing, though I suppose it's possible I missed that)

    Tried renaming and tehn used 7Zip to extract but I get message:
    0 Can not open file as archive

    Anything else I can try?

    (NOTE - I downloaded a copy of WInZip but that didn't help either - when I try to unzip, I get: The Following file could not be opened or is not a valid Zip file - and I get that whether I rename or

    Is there a way to open the car file in a text editor and manually remove the extra stuff at the end of the file??
    (I tried right clicking to Open with Notepad++ but get message saying file is too large; cannot open with notepad++)

    A I simply hosed :-( or are there other things to try?


    Post edited by Mosk the Scribe on
  • FenricFenric Posts: 351
    edited December 1969

    There are other possible forms of damage to the file, but I have never been able to recover them - if it isn't the compression bug, you might be out of luck.

  • Mosk the ScribeMosk the Scribe Posts: 886
    edited December 1969

    I was afraid of that, but thanks anyway.

  • edited December 1969


    I have received similar errors when I import a .obj file *wavefront* and then save the file as Carrara native format. Several different files. One is a Poser file with the .obj files. Another is a wavefront file alone. Interestingly if I import it to DAZ 4.6, save as .duf, then import to Carrara I receive no errors. I have attached captures of the various error messages. It is interesting in that it is not the same message each time.

    Any thoughts?

    541 x 277 - 27K
    583 x 325 - 37K
    642 x 444 - 67K
Sign In or Register to comment.