Fonts displying wrong on site buttons, any ideas? (Solved)

Dave SavageDave Savage Posts: 2,418
edited June 2012 in The Commons

What is going on with this forum and website?

Since it was all "improved" I can't see any of the buttons, they all show up only as jibberish.

All button and thread titles on the forum are the same, so I hope this works as I'm working blind here.

Any suggestions anyone?

Post edited by Chohole on


  • ChoholeChohole Posts: 33,604
    edited December 1969

    I have split this off into it's own thread.

    We think this is probably bad font substitution on your system or a corrupted font database or a language setting.

    What sytem/browser/language etc are you using.?

  • Dave SavageDave Savage Posts: 2,418
    edited December 1969

    I'm on a Mac OS10.5.8
    It's like this in Safari and Firefox
    English language.

    This is the only website I've come across that shows up like this... The rest of the internet is doing fine. :)

  • ChoholeChohole Posts: 33,604
    edited December 1969

    Well you have us totally puzzled. we haven't come across this before.

    edited the thread title, maybe some one else will have an idea.

  • Dave SavageDave Savage Posts: 2,418
    edited December 1969

    As another example of what the forum looks like to me:

    Even all the buttons in the new post composition window are overlayed with this gooble-di-gook... Though some of the text is still in readable English.

    I only found out by chance because I got the Daz newsletter and fancied a closer look at Black Pearl pirate outfit.
    I clicked the link in the email and it took me to the Daz website but it looked like the pic I posted earlier.
    I got suspicious thinking it may have been a spoof email, so quit Safari and tried to use the bookmark I had set up in Firefox.
    As I haven't been around for a few months, that didn't work as you've updated the site and stuff, so I Googled the correct one and signed in to find the same thing.

    Thanks for trying to help out, I appreciate it lots.... hopefully someone will be along with a solution. :)

  • Dave SavageDave Savage Posts: 2,418
    edited December 1969


    The problem is sorted and it was all my computers stuuuuupid fault.

    Doing what my training taught me to do, I figured I'd back track and look at what I'd installed most recently.
    It turned out that one of the fonts I loaded from a DVD containing a job I'd been working on was causing a font problem.
    I found it by systematically going through all the fonts in Fontbook and turning off the ones I never use.
    When I got to Helvetica Neue Bold & Black it was showing the same gobble-di-gook that the forum was showing.
    Deleted those fonts and everything's back to normal.

    Now I can sleep... :)

Sign In or Register to comment.