Look at my Hair (LAMH) Official Thread: update 1.6.0.1 released

16566676971

Comments

  • sapatsapat Posts: 1,403

    When I used to do the 3dl version this always worked, but I'm trying to use the iray and the 'to obj' is not working even if it's left for hours.  So i've just been using the 'attach preset' then highlight all the parts like fur body, fur tail and fur ears then load the basic iray shader to them.  I change a few settings, and it works. I used the medium length lamh fur on the HW Big Dog with 800000 hairs, and it rendered in 4 minutes and 30+ seconds. Just wish the to obj process worked for me and didn't take forever.  There has to be a way for AM to make it work better and more efficiently.

     

     

    HW Big Dog Iray LAMH Medium Lengtht - 121818.jpg
    710 x 814 - 93K
  • OdaaOdaa Posts: 1,178
    sapat said:

    When I used to do the 3dl version this always worked, but I'm trying to use the iray and the 'to obj' is not working even if it's left for hours.  So i've just been using the 'attach preset' then highlight all the parts like fur body, fur tail and fur ears then load the basic iray shader to them.  I change a few settings, and it works. I used the medium length lamh fur on the HW Big Dog with 800000 hairs, and it rendered in 4 minutes and 30+ seconds. Just wish the to obj process worked for me and didn't take forever.  There has to be a way for AM to make it work better and more efficiently.

     

     

    Holy crap, Sapat, you're a genius! Going to try this on the tiger presets for the Unicorn when I get home!

  • Is the "to obj" only having a problem if you use the iray catalyzer preset? I was having trouble exporting to fiberhair a few days ago, it seemed like it would crash with the catalyzer presets but not the regular lamh presets. Not sure if that is normal or a known issue.
  • sapatsapat Posts: 1,403
    Odaa said:
    sapat said:

    When I used to do the 3dl version this always worked, but I'm trying to use the iray and the 'to obj' is not working even if it's left for hours.  So i've just been using the 'attach preset' then highlight all the parts like fur body, fur tail and fur ears then load the basic iray shader to them.  I change a few settings, and it works. I used the medium length lamh fur on the HW Big Dog with 800000 hairs, and it rendered in 4 minutes and 30+ seconds. Just wish the to obj process worked for me and didn't take forever.  There has to be a way for AM to make it work better and more efficiently.

     

     

    Holy crap, Sapat, you're a genius! Going to try this on the tiger presets for the Unicorn when I get home!

    I'm happy how it turned out, and the great thing is I didn't export as fiberhair and still got a super fast render.  The free LAMH short and medium dog furs are from HW.

  • sapatsapat Posts: 1,403
    Is the "to obj" only having a problem if you use the iray catalyzer preset? I was having trouble exporting to fiberhair a few days ago, it seemed like it would crash with the catalyzer presets but not the regular lamh presets. Not sure if that is normal or a known issue.

    I have the Catalyzer, but after I bought it I found out itt's only for AM animals unless I'm understanding it wrong.  So no, I have't tried anything from catalyzer.  I've have to try catalyzer and see.  I haven't had any crashes with the regular LAMH full version.

  • ragtatterragtatter Posts: 6

    I apologize if this has already been addressed in the thread. I've done some digging/searching and didn't find it.

    I've been trying to apply fur where it starts as one image map at the base, and shifts to another image map at the tip.

    So far, this is the workflow I've been using

    #1. Apply LAMH preset I've created

    #2. On "Dog 8_Grp_0_RMan_Coat", I change the Tip Color to the map I want to use.

    #3. I open the LAMH Editor and export to Fiberhair

    #4. I attempt to render, only to have the end result show only the "root color" image map, ignoring the "tip color" that I set.

     

    I'm sure I'm probably missing a very obvious step, but for the life of me I can't figure it out. Any help would be greatly appreciated.

  • freni-kynfreni-kyn Posts: 376

    I purchased the full version of lamh 1.6 a while back and tried it out but at that time my graphic card was not able to handle it well and since I was using mostly iray I just stopped using it.  However I need it now and have tried to use it but when I open the pane for it there is no editor button.  Could someone please tell me what I'm doing wrong?  I can not find the info in the pdf, however the pdf was for an older version.  Including a screen capture of the tab.

    lamh.JPG
    457 x 672 - 42K
  • TheKDTheKD Posts: 977

    Odd, on my tab, where it shows "Get More Presets" button on yours, is where the "Show Lamh Editor" button is on mine

  • freni-kynfreni-kyn Posts: 376
    edited January 8
    TheKD said:

    Odd, on my tab, where it shows "Get More Presets" button on yours, is where the "Show Lamh Editor" button is on mine

    I have even wondered if. when I reinstalled everything. the trial version got installed instead of the full version.  But when I look at the registration it has all the correct info so I'm not sure what to think.  I want to update it with the iray version but not until I can get it running correctly.

     

    Post edited by freni-kyn on
  • freni-kynfreni-kyn Posts: 376

    I resolved the issue by uninstalling lamh with dim.  At that point it suddenly saw the player in there too.  Not sure why I was not getting an error message about that.  But then I had to do both a manual and dim uninstall of the player and reinstal the full program.  I seem to be up and running now.  :)

  • OdaaOdaa Posts: 1,178
    edited January 8
    ragtatter said:

    I apologize if this has already been addressed in the thread. I've done some digging/searching and didn't find it.

    I've been trying to apply fur where it starts as one image map at the base, and shifts to another image map at the tip.

    So far, this is the workflow I've been using

    #1. Apply LAMH preset I've created

    #2. On "Dog 8_Grp_0_RMan_Coat", I change the Tip Color to the map I want to use.

    #3. I open the LAMH Editor and export to Fiberhair

    #4. I attempt to render, only to have the end result show only the "root color" image map, ignoring the "tip color" that I set.

     

    I'm sure I'm probably missing a very obvious step, but for the life of me I can't figure it out. Any help would be greatly appreciated.

    If it's all one color, all over the dog, I would just go to whatever Iray hair shaders you own and find something that sort of matches. I have played with other people's LAMH presets that use the animal's underlying texture to make patterned fur coats (eg, tiger stripes), but I've never managed to get the converted Fiberhair version to retain the patterning.

    Post edited by Odaa on
  • Odaa said:
    ragtatter said:

    I apologize if this has already been addressed in the thread. I've done some digging/searching and didn't find it.

    I've been trying to apply fur where it starts as one image map at the base, and shifts to another image map at the tip.

    So far, this is the workflow I've been using

    #1. Apply LAMH preset I've created

    #2. On "Dog 8_Grp_0_RMan_Coat", I change the Tip Color to the map I want to use.

    #3. I open the LAMH Editor and export to Fiberhair

    #4. I attempt to render, only to have the end result show only the "root color" image map, ignoring the "tip color" that I set.

     

    I'm sure I'm probably missing a very obvious step, but for the life of me I can't figure it out. Any help would be greatly appreciated.

    From my own experience, I have never been able to work out how to have a "different" tip color than a root color show when exporting fiberhair.  I have tried several times and in several different ways, but have never been successful.  I believe differing tip and root colors are, in practice, limited to 3DL rendering; at least until the creators can work out a solution which makes LAMH natively compatible with Iray.  Catalyzer is totally great, but it only works on presets designed specially for it, which unfortunately is not currently possible for the general public.

    Odaa said:

    If it's all one color, all over the dog, I would just go to whatever Iray hair shaders you own and find something that sort of matches. I have played with other people's LAMH presets that use the animal's underlying texture to make patterned fur coats (eg, tiger stripes), but I've never managed to get the converted Fiberhair version to retain the patterning.

    The converted fiberhair version does retain the pattern, but not if you subsequently apply an Iray shader to the converted hair.  When you first export to fiberhair, LAMH generates a special texture map which "copies" the underlying texture, but applies it to the differently UV'ed hair geometry.  By default, this generated texture is stored in the same folder as the exported geometry obj file, and is applied to the exported hair.  If you convert to Iray, either "Ctrl + click" on the shader preset you are applying, and then select "Ignore" image maps, or else, after applying your new shader, load the texture map that LAMH generated into the "Diffuse" channel of the material.

  • Hey Everyone,

    I only very recently discovered LAMH.  I kept seeing all these presets listed in my content & wondered what they were.  Wow.

    I'm primarily a Lightwave user so have been experimenting bring things over there and having pretty good luck.  If you've ever tried to do hair in Lightwave, it's ... painful.  Still coming up to speed with the full version of LAMH, but so far it's really wonderful.  Has a few glitches still but I'm keeping notes of the landmines.

    I did contact Alessandro directly a few days ago (a bit tough to track down actually) and he indicated that direct export of the Rman items as curves would be a big asset & is considering adding to the feature set. What that means in simple terms is that FiberHair could be exported & used in animation.  Maybe not in Daz, but who knows.

    Anyway, my question today is in regard to Catalyzer.  

    I came across an older thread that sort of indicated that Catalyzer shave groups could be exported to LAMH.

    Is that true?  If so, how?

    If not, it needs to be a feature request.


    M.

  • Catalyzer shave groups do not need to be exported to LAMH.  They are meant for rendering LAMH in Iray, but to render them you have to hit the "render" button in the catalyzer pane, and not from the standard "render settings" pane.  If you are using a different render engine, do not load the Catalyzer figure, but the standard LAMH figure, and export to fiberhair or obj, as required.

    There was a teaser video months back showing how they were hoping to have the LAMH follicles editable and posable directly from DAZ in LAMH 2.0.  I really am looking forward to any further developments they come up with.  In the meantime, I just buy all the fuzzy animals I find to encourage them to hurry up... :)

  • Right.  I can render via the Catalyzer UI of course, but looking to somehow export/convert the Catalyzer Rman Group/Body into an LAMH Rman group & body so that they can subsequently be exported as actual geometry or FiberHair, or eventually as curves.   Not all of the AM figures are set up for LAMH presets of course & would really be nice to be able to convert.

    So, it's sounding as if thats a goal, but not yet implemented.  That correct, more or less?

    As an aside, I'm somewhat of a supporter of artists & independant programmers. I'll often buying products that I might not have an immediate use for, but want to see it progress.  AM falls into that category, but more as I really love animals & plan to continue collecting his menagerie.

  • All the AM figures which have Catalyzer presets, also have 3DL LAMH presets, which you can use to export to actual geometry or to rman curves.  You just have to load the right one before you start.

  • Ah.  Ok, thanks.  I'll check that out then.

  • UthgardUthgard Posts: 439
    sapat said:

    When I used to do the 3dl version this always worked, but I'm trying to use the iray and the 'to obj' is not working even if it's left for hours.  So i've just been using the 'attach preset' then highlight all the parts like fur body, fur tail and fur ears then load the basic iray shader to them.  I change a few settings, and it works. I used the medium length lamh fur on the HW Big Dog with 800000 hairs, and it rendered in 4 minutes and 30+ seconds. Just wish the to obj process worked for me and didn't take forever.  There has to be a way for AM to make it work better and more efficiently.

     

     

    Wait, what? You mean you are able to render lamh presets in Iray without converting them to fiberhair or obj, just by applying the Iray Uber shader to the relevant surfaces? Because I just tried it and I couldn't, but this is one of those cases where I will absolutely love to be proven wrong.

  • OdaaOdaa Posts: 1,178
    edited January 10
    Uthgard said:
    sapat said:

    When I used to do the 3dl version this always worked, but I'm trying to use the iray and the 'to obj' is not working even if it's left for hours.  So i've just been using the 'attach preset' then highlight all the parts like fur body, fur tail and fur ears then load the basic iray shader to them.  I change a few settings, and it works. I used the medium length lamh fur on the HW Big Dog with 800000 hairs, and it rendered in 4 minutes and 30+ seconds. Just wish the to obj process worked for me and didn't take forever.  There has to be a way for AM to make it work better and more efficiently.

     

     

    Wait, what? You mean you are able to render lamh presets in Iray without converting them to fiberhair or obj, just by applying the Iray Uber shader to the relevant surfaces? Because I just tried it and I couldn't, but this is one of those cases where I will absolutely love to be proven wrong.

    I had the same result when I tried what you describe; I thought perhaps sapat was running a newer version of the plugin than I was, and that's why it worked for them and not for me.

    Post edited by Odaa on
  • From my own experience, I have never been able to work out how to have a "different" tip color than a root color show when exporting fiberhair.  I have tried several times and in several different ways, but have never been successful.  I believe differing tip and root colors are, in practice, limited to 3DL rendering; at least until the creators can work out a solution which makes LAMH natively compatible with Iray.  Catalyzer is totally great, but it only works on presets designed specially for it, which unfortunately is not currently possible for the general public.

     

    Okay, so, when I try to render it in 3DL, I get absolutely no fur at all. I have honestly never tried rendering anything with 3DL before, so I can't even begin to guess where I'm going wrong. Please help me for I am stupid.

  • If you are rendering in 3DL, you have to make sure you load the LAMH figure preset, rather than the Catalyzer one.  In your viewport, the animal should look like it is thinly covered in long, lime green hairs.  If it doesn't, then you don't have the LAMH preset loaded.

  • HaruchaiHaruchai Posts: 451
    edited January 11
    Odaa said:
    Uthgard said:
    sapat said:

    When I used to do the 3dl version this always worked, but I'm trying to use the iray and the 'to obj' is not working even if it's left for hours.  So i've just been using the 'attach preset' then highlight all the parts like fur body, fur tail and fur ears then load the basic iray shader to them.  I change a few settings, and it works. I used the medium length lamh fur on the HW Big Dog with 800000 hairs, and it rendered in 4 minutes and 30+ seconds. Just wish the to obj process worked for me and didn't take forever.  There has to be a way for AM to make it work better and more efficiently.

     

     

    Wait, what? You mean you are able to render lamh presets in Iray without converting them to fiberhair or obj, just by applying the Iray Uber shader to the relevant surfaces? Because I just tried it and I couldn't, but this is one of those cases where I will absolutely love to be proven wrong.

    I had the same result when I tried what you describe; I thought perhaps sapat was running a newer version of the plugin than I was, and that's why it worked for them and not for me.

    I have tried this before and it didn't work so I wondered if CWRW had done something specific in the presets. I tried again with the above model and presets. No luck. I would be interested if Sapat knew what settings they changed when they said 'I change a few settings, and it works'

    Post edited by Haruchai on
  • you may want to test the hair at v ery low hair count, and increase the root /tip size under settings, and when you export, to see how much l oad it'll put on the scene and time. 

  • If you are rendering in 3DL, you have to make sure you load the LAMH figure preset, rather than the Catalyzer one.  In your viewport, the animal should look like it is thinly covered in long, lime green hairs.  If it doesn't, then you don't have the LAMH preset loaded.

    I had the preset loaded. I found the problem, though! There was a checkbox unclicked that should have been clicked. XD

  • dbdigital2dbdigital2 Posts: 256

    I tried looking around this thread but so far haven't come accross the requirements.  What version of Daz Studio is required to run 1.6?  Wondering if I can update with this current setup or not.  I am on 4.8 currently.

  • manekiNekomanekiNeko Posts: 619

    I just want to poke my head in and say... I still use LAMH, I reinstall it (and copy the plugin files) over to every version of DS). I use it on older critters, A LOT. Like noggins rat, like housemouse, the Millenium cat, etc. The on l y difference is that for Iray, you have to export to fiberhair if you do your own non-catalyzer presets. Many of Alessandro's animals have their own catalyzer presets, which I adore, but currently other peple can't use them. ALso make sure figures you use LAMH on are A: not parented to something and B: have regular non iray shaders, i think it helps. Also not subdivided. 

    I need to remember how to save and share my LAMH presets and make some of them available... I'm also working on a "fuzzy" hair displacement for a rodent mouse for Alessandro's rodentia because it's so small :) I've got a "temp" mouse morph (which I'm not sharing because it blew the rigging to crap, sigh) that i'm using for mouse pics until Alessandro finishes the mouse he's started (yes, guys, he started a mouse, and no, i haven't stopped pestering him for it, either! Hahahaha!)  For those that forget, I'm obsessed with mice :) 
    I've gotta share the noggins rat and house mouse LAMH presets and oso fuzzy presets for Christmas.

     

    And, if anyone has the veeeeeeeery old CP lab mouse (white lab mouse) I may share that too. Below: Noggin's Rats and House mouse, last is the CP mouse and free JT mouse (which uh has awful rigging but can be somewhat used?) with OsoFurry shader geoshells. I keep dreaming of getting Alessandro's new mouse shape... it's all I want for Christmas!!! (besides health insurance, new glasses, a trip to the dentist, and a coat for my son).... :P

     

    adorable! heart

    so... 2nd time i goggle and find your name with a mention of a lamh preset for noggin's rat on the forum (one was like in 2015).. but no link to a preset, nor could i find it or any other ratty one on the lamh site... was overjoyed as lamh came out back then, but my system crashed every time, couldn't use it (the free player). now augmenting my pagefile seems to have fixed the issue, at least when i work slowly - and i'm getting out all my old critters too! the rat is one of my faves :) any chance to get a link to your/a preset?

  • Roman_K2Roman_K2 Posts: 762
    freni-kyn said:

     I seem to be up and running now.  :)

    Not me! sad I just tried it AGAIN on a new install of DAZ Studio 4.10 in Windows 7. I downloaded LAMH with DIM yesterday. In "my account" I noticed there was only one serial number for LAMH... so I tried that along with my "old" Activation Code and bingo, it keeps going around in circles eg. "Restart DAZ Studio and enjoy" only I don't get any enjoyment - just a prompt to re-enter the numbers, over and over.

  • Hey all,

    Making some excellent progress with LAMH but running into some confusion with the Follicles panel between ver 1.6 of the plug, but ver. 1.5 of the docs.  

    On pg. 12 of the 1.5 PDF, there's tiny image with:

    Figure 11: Follicles actions from left to right: add all, delete all, select by surface, split group, duplicate group

    ... but then no further explanation.  If those last two are enabled tools, might there be a vid w/ more details on their use?

    What I'm trying to do is end up with are smaller final hair group objects that I can then export and have more control in Lightwave. I'm keeping to the LAMH defaults for now to see what I can get away with.  Smaller critters have worked quite well, but starting to hitting the limits with the White Tiger.  The Moose is right out.  That OBJ export was over 3 Gb so need to figure out a different plan of attack.

    Anyway, with the example of the White Tiger, there are two RMan groups, I'm assuming for the material assignments, but the end result is just one group with all the fur of the entire figure.  

    I somehow managed to do what I'm wanting a couple days ago with the Editor, but haven't been able to retrace my steps. Damn aging gray matter!

    So how does one go about that process?  Seem's like those split & duplicate tools would come in real handy for that but ...

    Here are some samples out of Lightwave 2018:

     

    NuFurrdBeaverMossyForest.jpg
    1280 x 720 - 420K
    FurdbatInMossyForest.jpg
    1280 x 720 - 452K
    SnarlingWolf.jpg
    1280 x 720 - 398K
    PityPandaWoodsAlaskanMorning_SubD.jpg
    1280 x 720 - 466K
  • Hello,

    I purchased a license back in Jan, I activated and it worked. After not using DS for a while, on starting LAMH, it is asking for activation again. The "Personal code" is not the same as last time (in fact, in the drop down menu there are 6 different personal codes, none are the same as original). So the question is, does LAMH need to be ativated on a regular basis with a different personal code? It will be a pain since the PC it is used on is not connected to the internet.

    No, LAMH does not need reactivated at regular times.  However, sometimes Windows 10 updates will trash the computations needed for verification.  Send a request for a fix.

    Kendall

    Hello everyone,

    I have asked before, but haven’t found an answer yet. Does anyone know what the fix is for the trashed computations on Win 10 64bit? Can someone post the fix here for everyone to see? I am thinking of purchasing LAMH full, but reading through this entire thread has me very nervous that it will be a waste of time and money.

    I am running Win 10, DAZ Studio 4.10 is installed on a different drive, and my content library resides on a NAS.

    Thanks in advance! I really just want to put some cute fur on the HW House Cat.

  • HaruchaiHaruchai Posts: 451
    edited January 25

     

    Hello,

    I purchased a license back in Jan, I activated and it worked. After not using DS for a while, on starting LAMH, it is asking for activation again. The "Personal code" is not the same as last time (in fact, in the drop down menu there are 6 different personal codes, none are the same as original). So the question is, does LAMH need to be ativated on a regular basis with a different personal code? It will be a pain since the PC it is used on is not connected to the internet.

    No, LAMH does not need reactivated at regular times.  However, sometimes Windows 10 updates will trash the computations needed for verification.  Send a request for a fix.

    Kendall

    Hello everyone,

    I have asked before, but haven’t found an answer yet. Does anyone know what the fix is for the trashed computations on Win 10 64bit? Can someone post the fix here for everyone to see? I am thinking of purchasing LAMH full, but reading through this entire thread has me very nervous that it will be a waste of time and money.

    I am running Win 10, DAZ Studio 4.10 is installed on a different drive, and my content library resides on a NAS.

    Thanks in advance! I really just want to put some cute fur on the HW House Cat.

    I have reverified LAMH four or five times due to reinstalls and never had an issue and I'm running WIN 10 64bit and my content is on an external drive.

    Post edited by Haruchai on
Sign In or Register to comment.