Digital Art Zone

 
     
Carrara 8.5 beta possible bug - any work around
Posted: 13 October 2012 05:59 AM   [ Ignore ]
Active Member
RankRank
Total Posts:  437
Joined  2008-07-18

I’m using C8.5 beta and quite often when I try to drag a prop onto a figure to parent it (say to put something in the character’s hand), I will get a non-specific error saying An Error occurred while executing Move Tree.  Often the prop then flies off to a new position in the screen at that point.

This happens when trying to parent target helpers as well.  And on several occasions right as I’ve been completing or finalizing my animations, a previously parented item will seem to vanish from the screen (the name remains in hierarchy but can’t find item on display, doesn’t render, and I’ve checked toggles for Visible and Show Object in 3D view) -  this then prompts me to try to add that prop back and parent it - leading to the error.

I also run into non-specific ‘Failed to save’ errors when trying to save my file - which means if I don’t try to work through or work around the errors and render what I can, I’m really stuck, because I can’t simply re-open the file without starting over.

I am working with NLA clips and Genesis, and I know there had been many problems with that earlier.

1) Would this fall within the area of known problems?
2) Any partial workarounds come to mind for getting a prop to follow along as if parented to a figure’s hand? 

I need to put a wand in and re-render something as character walks along (just the wand without figure and background).

Tried adding a Target Helper to scene and having that track hand, and parenting wand to target helper - but tracking doesn’t keep the TH locked on hand.

Tried exporting bvh in case that could help let me transfer animation - get non specific error.

Didn’t know if any of Fenric’s tools could save the day??  (ERC or Pose Helper??)
Or detaching skeleton then using it to carry the wand?


Thanks for any suggestions.

Profile