Digital Art Zone

 
     
DS 4.5 not saving zeroed out morphs in Hair
Posted: 06 October 2012 02:15 AM   [ Ignore ]
Power Member
Avatar
RankRankRank
Total Posts:  2302
Joined  2010-12-18

Many of you may be familiar with how hair follows elf ears and the workaround, and that is where I am having a problem now.

In 4.x I would show hidden properties for the hair and zero out the elf ear morph. When i would save the daz file this was remembered.

Now with 4.5 I have to keep zeroing out the ear morph every time I load the scene. Anyone else experience this issue? I’m not sure if this is exclusive to one hair style or not, I’m kinda in a rush on a project and will try a different one later. the hair I’m using in a bunch of renders now is 1930’s Female Hair for Genesis.

 Signature 

My deviantArt Pinup Gallery

Profile
 
 
Posted: 06 October 2012 05:22 AM   [ Ignore ]   [ # 1 ]
Active Member
Avatar
RankRank
Total Posts:  925
Joined  2007-01-04

Technically speaking none of your conformers actually have the morphs in them, so every time you load your duf scene DS will apply the auto follow morphs to the conformers, so there really isn’t anything there for it save.

The morph in Genesis needs edited to remove the auto follow function from it, either by DAZ fixing their cockup or by the user editing the files.

 Signature 

**shuffles of with a new headache** tongue wink

Profile
 
 
Posted: 06 October 2012 07:34 AM   [ Ignore ]   [ # 2 ]
Administrator
Avatar
RankRankRankRank
Total Posts:  14343
Joined  2003-10-09

As far as I am aware the morphs are generated in the conformers the first time they are turned up in the figure, and the result then persists and should be saved with the item/scene. I think I recall seeing something about this in the change log - larsmidnatt, are you using the release or the newer beta version of 4.5?

 Signature 

DAZ Studio Frequently Asked Questions

Index of free DAZ Studio scripts and plugins list

Profile
 
 
Posted: 06 October 2012 08:18 AM   [ Ignore ]   [ # 3 ]
Active Member
Avatar
RankRank
Total Posts:  925
Joined  2007-01-04

Richard the morphs need to be saved into the conformer’s data folder as morph assets before they will show in the DUF, only then will the settings be saved.

I’m using the beta and have created a character using the basic female morph and quite a lot of dietrying’s morphs, I conformed the K4 tankini & briefs to my character and saved as a scene, the only modifiers listed in the duf for the tankini & briefs is the basic female morph as DAZ included that in each conformer. I then redid the scene, this time I used a conformer with no morphs built in, the resulting DUF only had skinbinding listed for the conformer, all the rest were assigned to Genesis.

 Signature 

**shuffles of with a new headache** tongue wink

Profile
 
 
Posted: 06 October 2012 12:44 PM   [ Ignore ]   [ # 4 ]
Active Member
RankRank
Total Posts:  544
Joined  2011-04-12

Possible workaround: instead of zeroing the morph, try setting it to a very small nonzero value (e.g. 0.001).  If the cause of the problem is what I suspect, this should avoid it.

 Signature 

Not interested in the giant leap backwards that is “Genesis 2”.

Profile
 
 
Posted: 06 October 2012 01:59 PM   [ Ignore ]   [ # 5 ]
Administrator
Avatar
RankRankRankRank
Total Posts:  14343
Joined  2003-10-09

if the morphs aren’t saved as an asset they should be saved locally, in the .duf (which will be larger as a result). Of course that may not be happening, but that’s my understanding of what should be happening.

 Signature 

DAZ Studio Frequently Asked Questions

Index of free DAZ Studio scripts and plugins list

Profile
 
 
Posted: 07 October 2012 01:09 PM   [ Ignore ]   [ # 6 ]
Power Member
Avatar
RankRankRank
Total Posts:  2302
Joined  2010-12-18

thanks for the replies I lost track of this thread when I got email bombed wih 104 notifications. I’ll try saving with a small value and see if that works. Thanks

EDIT: nope that doesn’t work. putting in a value doesn’t stay when you save and reload. I’m using 4.5 official release and not betas

 Signature 

My deviantArt Pinup Gallery

Profile
 
 
Posted: 07 October 2012 09:05 PM   [ Ignore ]   [ # 7 ]
Power Member
RankRankRank
Total Posts:  1009
Joined  2012-02-04

The .137 beta fixes many DUF bugs; I would strongly recommend switching to it.  It may not fix your particular bug, but it will fix other save issues in the official release.  (I know because I submitted several that were fixed, and I’ve seen others listed in the bug tracker, as well.)

If you still experience this problem with .137, then I would recommend you report it as an issue at https://bugs.daz3d.com/ .  DAZ seems particularly sensitive to bugs in the new DUF format, and has been very responsive in fixing them.

 Signature 

My deviantART Homepage
Set Focal Distance script for DAZ Studio

Profile
 
 
Posted: 08 October 2012 05:00 AM   [ Ignore ]   [ # 8 ]
Active Member
Avatar
RankRank
Total Posts:  925
Joined  2007-01-04

IMHO this is more a content bug rather than a DS bug, the active morph transfer system should never have been turned on for many of the Evo head morphs, but because someone came up with a “half-assed” work around DAZ haven’t bothered to fix them.

Back when this problem was first discovered I advised people to edit the morph to turn off the active morph transfer system, I get the feeling I was pretty much ignored, well you got two choices now, either bitch to DAZ to get them to fix the morphs, or do it yourself, which btw is just as easy for you to do in DS as it is for DAZ to do.

 Signature 

**shuffles of with a new headache** tongue wink

Profile
 
 
Posted: 08 October 2012 05:56 AM   [ Ignore ]   [ # 9 ]
Power Member
Avatar
RankRankRank
Total Posts:  2302
Joined  2010-12-18

Ok thanks folks. Not sure I want to go to a beta version at this point since I’m in the middle of a project(s). I guess I’ll keep an eye out for an official release.

 Signature 

My deviantArt Pinup Gallery

Profile
 
 
Posted: 08 October 2012 02:39 PM   [ Ignore ]   [ # 10 ]
Member
Avatar
Rank
Total Posts:  210
Joined  2011-09-13

I have the 4.5 beta version and I still have this problem (admittedly I didn’t try the “small value” suggestion).

Profile
 
 
Posted: 08 October 2012 04:52 PM   [ Ignore ]   [ # 11 ]
Active Member
Avatar
RankRank
Total Posts:  925
Joined  2007-01-04

Clear the scene and load in Genesis, in the Parameters tab find the morph that’s causing your problems, if you dial it make sure you zero it again before continuing, (pic 1a) click on the “cog” and in the new menu select “Parameter Settings…”, a new window will appear (pic 1b), uncheck the box for auto follow and click Accept.

That’s you removed auto follow for the morph as it is inside the Genesis you have loaded into the scene, now you need to add that alteration to the file in the data folder. For this you go “File > Save as > Support Asset > Save modified assets”, after you click on this DS will have a quick scan of Genesis and should create a new window (pic 2), the files listed in here are the ones it’s going to alter, as long as the listed file resembles the name of the morph (it wont be identicle if it’s a DAZ morph) then your safe to click accept.

You can now clear the scene and load in the duf scene you were having issues with, in the case of the ear morph they should now be poking through the hair, rather than the hair being distorted.

Image Attachments
Fixed.jpgGoodbye.jpg
 Signature 

**shuffles of with a new headache** tongue wink

Profile
 
 
Posted: 08 October 2012 09:00 PM   [ Ignore ]   [ # 12 ]
Power Member
Avatar
RankRankRank
Total Posts:  2302
Joined  2010-12-18

very cool thanks much

 Signature 

My deviantArt Pinup Gallery

Profile