Custom morph files under Shaping / Posing tab?

dan.shivedan.shive Posts: 0
edited December 1969 in Daz Studio Discussion

Does anyone know how to get custom Genesis morphs to be visible in the Shaping and/or Posing tabs when using .dsf files (I have yet to upgrade to 4.5)?

I like the option of using ERC freeze in the property editor tab, but the resulting morph and pose dials only appear under the Parameters tab regardless of what node and/or group I assign them. This isn't an end of the world issue or anything, but it would be far more convenient to use them via the Shaping or Posing tabs.

I've compared .dsf files to determine what decides whether they show up as desired, but I have yet to find the smoking gun.

Comments

  • Richard HaseltineRichard Haseltine Posts: 26,222
    edited December 1969

    I've not had to look into this, but try assigning a region to the morph and then look under that region in the Shaping pane.

  • cridgitcridgit Posts: 823
    edited December 1969

    Dan

    Its the Content Type that determines whether they show up in the presets tabs. If you open the Content DB Editor from the Content Library menu you can assign a type to each of those assets.

    The ones you're looking for are Presets/Morph/... and Presets/Pose.

  • Richard HaseltineRichard Haseltine Posts: 26,222
    edited December 1969

    Indeed, I'd forgotten setting the property type.

  • kitakoredazkitakoredaz Posts: 2,669
    edited October 2012

    mmm,,, I am sorry If I say mistake,,

    but I think about morph dsf in data,, we seems not access by content editor.
    (or is that way to save the morph which can set meta-data in content editror?)

    then cridgit say right , I understand the category where you can see the morph desided by "type"
    not Path eg, "Actor/Female" (it seems decide node hierarlchy and category in editor )

    I think we can decide the type about morph, by the parameter setting editor, I think,,.
    eg ”Modifier/Shape” it can show your morph with erc in shape tab.
    (I hope it is right, and I am mazing about types and yet grab crear knowledge too,,)

    edited

    afther change type, you need to save the controller settings by save modified assets ,
    or simple "save as moprh" to keep the type of dsf morph file.

    "Path" is important too, they seems decide the selection and node,
    when use pozing tool , and region navigation. about pozing and shaping tab,
    they move with these tool.

    Post edited by kitakoredaz on
  • rbtwhizrbtwhiz Posts: 919
    edited December 1969

    The type on the property should be set to:

    - "Modifier/Shape" for it to show up on the Shaping pane
    - "Modifier/Pose" for it to show up on the Posing pane

    For a figure like Genesis, that has Regions, a property must also be assigned to a Region to show up on the Shaping pane. For figures that do not have Regions, like the previous generations, this is not a requirement.

    In 4.5, this is easily done in the Parameter Settings dialog via the Path and Type attributes. The Parameter Settings dialog is accessed from the option menu that pops up when you click on the gear icon in the top right corner of a parameter.

    -Rob

  • dan.shivedan.shive Posts: 0
    edited December 1969

    Thanks for the help! The issue with the .dsf files was definitely the lack of any settings for "Presentation", and those are easily set via the Parameters tab. I was thrown by the fact that even if you don't set presentation, you can still fine "Modifier/Shape" and such in the file. With presentation set up properly, however, that shows up twice. Once under asset info, and once under presentation.

    Thanks again!

  • http://docs.daz3d.com/doku.php/public/software/dazstudio/4/referenceguide/interface/panes/shaping/start

    Permission Denied

    Sorry, you don't have enough rights to continue.

    ______

     

    I'm googling about and found this thread and that link above. reading this thread and it's just not sinking in.

    I made a clothing item in Hexagon sent to DS with the bridge. Got it set up as a figure saved using Save as -> Support Asset -> Figure/Prop Assets

    Now I made several morphs for it using Hexagon and sending them back to DS with the bridge.

    I just noticed the dozen morphs I made are in the Parameters tab but are not showing in the shaping tab.

    Is there a way to just go into the data folders morph folder and copy all those morph files and paste them into a shaping location? if so where is it?

    If I got to do all this manually would someone please give me a few screen shots with instructions on how to get my morphs from the parameters tab to show up in the shaping tab?

    thanks in advance

     

  • Richard HaseltineRichard Haseltine Posts: 26,222

    What you need to do is make sure that their path is under Actor and that their type iss et to Modifier/Shape - both of which can be done in the Parameter Settings dialogue (or you can right-click on the Parameters pane and set it into Edit mode, seelct the paarmeters you want to edit, and right-click to Set>Proeprty Group... to set the path and Set>Presentation to adjust the type). Then use File>Save as>Support Assets>Morph Asset again.

Sign In or Register to comment.
Rocket Fuel