Digital Art Zone

 
     
Question about Emitters
Posted: 20 September 2012 01:33 AM   [ Ignore ]
Member
Avatar
Rank
Total Posts:  63
Joined  2003-10-09

i’ve got a problem using emitters which is driving me slightly nuts

it’s been a while since i’ve used carrara in anger, but i’ve come back to it recently, and i know i’ve had this effect working ok before, but now… it won’t

i know how emitters work, and i can get those working ok to generate various particle effects. what i want is for the particles to collide with scene objects

if i add, say, a plane into the scene, and add it as “Collide with Scene Objects… Only…. Plane” that works fine, as expected. the particles hit the plane and don’t go through it (as in the 2nd attachment)

BUT, if i try the same thing using a character (i’ve tried v4, m4, and v3 all to no avail) and do “Collide with Scene Objects… Only… M4 (or whatever)” then… the particles pass straight through the figure (as in the 1st attachment)

i’m sure the answer must be something obvious, but at the moment i’m stumped. any suggestions would be welcome

Image Attachments
PE001A.jpgPE001B.jpg
Profile
 
 
Posted: 20 September 2012 03:29 AM   [ Ignore ]   [ # 1 ]
Power Member
Avatar
RankRankRank
Total Posts:  1825
Joined  2004-08-24

HI smile

the particle collision is set within the advanced options in the particle emitter editor, (see pic)
You need to enable the particle emitter, to create particles which can collide with scene objects.

The default set-up, where particles will collide with the floor, is really set-up to stop the particles at 0 height, whether there’s is a floor plane in the scene or not.

The real physical object collision is enabled in the particle editor, with the option to specify which objects to collide with,.. (or all objects)

Image Attachments
particle_collision.jpg
Profile
 
 
Posted: 20 September 2012 04:02 AM   [ Ignore ]   [ # 2 ]
Member
Avatar
Rank
Total Posts:  63
Joined  2003-10-09

thanks for the reply, and i don’t wish to sound ungrateful for the assistance, but i knew that already

as i said in my original post, i’m able to quite happily get particles to collide with a simple object such as a plane (or a sphere, or whatever)

what i can’t seem to do is to get them to collide with is one of the human figures such as v4, or m4 or whatever. they pass right through them - as shown in the first image in my original post (the second image demonstrates them being blocked by the plane object)

Profile
 
 
Posted: 20 September 2012 04:12 AM   [ Ignore ]   [ # 3 ]
Power Member
Avatar
RankRankRank
Total Posts:  2419
Joined  2008-01-28

you picking M4 figure or m4 model to collide with?

 Signature 

http://andrewfinnie.blogspot.com.au/

Profile
 
 
Posted: 20 September 2012 04:18 AM   [ Ignore ]   [ # 4 ]
Member
Avatar
Rank
Total Posts:  63
Joined  2003-10-09

ok, i think i’ve got it

i’ve been using “only” to try and limit the amount of calculation that carrara needs to do, but if i just leave it at the default “all objects except”, and don’t add anything into the list box, then it works as expected

Profile
 
 
Posted: 20 September 2012 04:56 AM   [ Ignore ]   [ # 5 ]
Power Member
Avatar
RankRankRank
Total Posts:  1825
Joined  2004-08-24

HI hieronymous smile

It’s working fine for me here with that setting enabled.

Looks like you’ve found a bug / flaw smile

If the option is set to ONLY, and the figure is selected, then the particles will pass through the figure, which is wrong.

If the option is left at it’s default (all objects except) and nothing is selected, ...then it works as expected. the particles collide with objects.

Image Attachments
particle_hit.jpg
Profile
 
 
Posted: 20 September 2012 06:24 AM   [ Ignore ]   [ # 6 ]
Member
Avatar
Rank
Total Posts:  63
Joined  2003-10-09

thanks. yeah, looks like i’ve found (another) bug, er “feature”

i knew i’d had it working in the past. guess i must have just left it to the defaults that time

Profile
 
 
Posted: 20 September 2012 08:20 AM   [ Ignore ]   [ # 7 ]
Power Member
Avatar
RankRankRank
Total Posts:  1825
Joined  2004-08-24

Further investigation shows that it actually works,.. and possibly as it should,. or,...works the way Carrara handles groups.

The Michael 4 (listing) is the main “group” for the actual 3D geometry and rigging,..
The Model (listing) is the actual “object” which could be collided with.

So, If you select the option to collide with “Only” selected objects,. then branch open the Michael4, and select “Model”, then the particle will collide with it.

The same applies to V4.

Hope it helps smile

Image Attachments
particle_model.jpg
Profile
 
 
Posted: 20 September 2012 02:36 PM   [ Ignore ]   [ # 8 ]
Addict
Avatar
RankRankRankRank
Total Posts:  6978
Joined  2006-08-27
3DAGE - 20 September 2012 08:20 AM

Further investigation shows that it actually works,.. and possibly as it should,. or,...works the way Carrara handles groups.

The Michael 4 (listing) is the main “group” for the actual 3D geometry and rigging,..
The Model (listing) is the actual “object” which could be collided with.

So, If you select the option to collide with “Only” selected objects,. then branch open the Michael4, and select “Model”, then the particle will collide with it.

The same applies to V4.

Hope it helps smile

That was actually going to be my suggestion.

 Signature 

I find it somewhat liberating not to be encumbered by accuracy.

Profile
 
 
Posted: 26 March 2015 09:15 AM   [ Ignore ]   [ # 9 ]
New Member
Avatar
Total Posts:  6
Joined  2003-10-09

Requesting particle collision help. Does not seem to be working for me. How can I keep my particle emitter particles from passing through my model, and have them rest on top of my model? See images for current settings.

A - Emitter start
B - Emitter end
C - Emitter Basic settings
D - Emitter Advanced settings
E - Physical Properties settings

Thanks in advance.

Image Attachments
D-emitter-advanced-settings.jpgE-physical-properties.jpgC-emitter-basic-settings.jpgB-stop.jpgA-start.jpg
Profile
 
 
Posted: 26 March 2015 11:07 AM   [ Ignore ]   [ # 10 ]
Power Member
RankRankRank
Total Posts:  1111
Joined  2010-04-15

I can see that “Die in impact” is checked…
Look also at the materials of the blobs and of the object which collide with, and uncheck the gravity of the scene and set the collision distance at 0 or 1.

 Signature 

          Site: http://bond3d.wix.com/carrarators
      Forum: http://www.bond3d.byethost18.com/
            My site: http://mhdproductions.be/

Profile
 
 
Posted: 26 March 2015 01:57 PM   [ Ignore ]   [ # 11 ]
Addict
Avatar
RankRankRankRank
Total Posts:  6978
Joined  2006-08-27

You may also need to increase the metaball influence. try setting it at around 2 to start.

You may also want to look at the effects tab of the object that you are trying to have the emitter place the particles on, and set the surface properties to have low bounce and high friction, just as you have in the emitter.

If you would like, I used emitters to write a word in an animation, and I made the file available for anybody that wanted to use it, pick it apart, or whatever they want. You can DL it from dropbox. No account needed:
https://dl.dropboxusercontent.com/u/7370483/emitter-writing.zip

The animation:
https://www.youtube.com/watch?v=CmQySueK00c

 Signature 

I find it somewhat liberating not to be encumbered by accuracy.

Profile
 
 
Posted: 27 March 2015 06:59 AM   [ Ignore ]   [ # 12 ]
New Member
Avatar
Total Posts:  6
Joined  2003-10-09

Thanks for your feedback, guys. They were very helpful.

Profile