Digital Art Zone

 
     
Metadata overide not working right
Posted: 17 September 2012 08:54 PM   [ Ignore ]
Power Member
Avatar
RankRankRank
Total Posts:  1441
Joined  2006-07-04

I’m very upset, but I’m trying to be rational about this.  Forgive me if I get rambly.

I spent some time this afternoon making custom metadata for last year’s Fantasy Castle 2011 and accessory sets (personal user categories, re-categorizing “scene” items as sets so I could merge them into a scene, and yes, removing the “default” metadata).  After that, I discovered that I had to reset and reinstall the DAZ files for those items.  Sigh.  Not happy, but it happens.

I made a point to save/export my user data before I did the re-installs.

I opened DS immediately after moving the files and not before, so there was no interim Metadata writing.

I made sure that when I opened DS again after I did the re-installs and move the folders into the Content Directory, “Override with User Metadata” was checked on the load Metadata window.

As far as I can tell, I did everything right to make sure that my User Data stayed.

All but two files wound up having all the user categories metadata overwritten.

Considering the number of Genesis outfits and other items that need resetting and adjusting for DS4.5, I can’t help but see this as a bug, and a rather serious one.  But it could be a glitch or even user error.

However, the only thing I can think of that would be my fault as to why it didn’t work is because I deleted the Default categories Metadata… except that’s how I keep track of what I have and haven’t categorized.  My plan is to eventually only have in the Default category any new installs, and then only until I get them organized into the appropriate user defined categories.  Requiring that the jumbled mess that is the default categories to remain is just… well, sloppy, in my opinion.  (Actually the words I would use are a lot harsher than that, but as I said, I’m trying to be reasonable.  For the most part, I find the default categories useless.)

 Signature 

DAZ Gallery * * *DA Gallery

Profile
 
 
Posted: 18 September 2012 04:21 AM   [ Ignore ]   [ # 1 ]
Active Member
RankRank
Total Posts:  901
Joined  2009-12-07

You’re forgiven my dear grin

DaWaterRat - 17 September 2012 08:54 PM

I made a point to save/export my user data before I did the re-installs.

 
Can you post a screenshot of how you saved/exported your user data?

DaWaterRat - 17 September 2012 08:54 PM

I opened DS immediately after moving the files and not before, so there was no interim Metadata writing.


What do you mean “moving the files” - didn’t you install them to My Library? Metadata included in the installed gets written during the installation.

DaWaterRat - 17 September 2012 08:54 PM

I made sure that when I opened DS again after I did the re-installs and move the folders into the Content Directory, “Override with User Metadata” was checked on the load Metadata window.

As far as I can tell, I did everything right to make sure that my User Data stayed.

All but two files wound up having all the user categories metadata overwritten.


Again a screenshot would help, because I don’t have this option. After installing a product with metadata, next time you start DS (or if you select Content DB Maintenance \ Re-import Metadata) you’ll be asked to select which product to import (or reimport) metadata for. If you’re reimporting you should UNCHECK ALL OTHER PRODUCTS. My window has an option “User Data Overrides Product Data” but not “Override with User Metadata”.

DaWaterRat - 17 September 2012 08:54 PM

However, the only thing I can think of that would be my fault as to why it didn’t work is because I deleted the Default categories Metadata… except that’s how I keep track of what I have and haven’t categorized.  My plan is to eventually only have in the Default category any new installs, and then only until I get them organized into the appropriate user defined categories.  Requiring that the jumbled mess that is the default categories to remain is just… well, sloppy, in my opinion.  (Actually the words I would use are a lot harsher than that, but as I said, I’m trying to be reasonable.  For the most part, I find the default categories useless.)


This is very unusual. In my case I always move new content out of Default (I also like to keep default clean) but even after reinstalling a product or reimporting product metadata, it will put it back in Default but never touches my own categories outside Default. You should double check whether the product has simply reappeared in Default or whether it has lost your user categorization (this would be abnormal behaviour).

 Signature 

PoseMaster for DAZ Studio and PoseMaster People Pack now sold at Rendo.

Profile
 
 
Posted: 18 September 2012 06:16 AM   [ Ignore ]   [ # 2 ]
Power Member
Avatar
RankRankRank
Total Posts:  1441
Joined  2006-07-04
cridgit - 18 September 2012 04:21 AM

You’re forgiven my dear grin

DaWaterRat - 17 September 2012 08:54 PM

I made a point to save/export my user data before I did the re-installs.

 
Can you post a screenshot of how you saved/exported your user data?

See below

cridgit - 18 September 2012 04:21 AM
DaWaterRat - 17 September 2012 08:54 PM

I opened DS immediately after moving the files and not before, so there was no interim Metadata writing.


What do you mean “moving the files” - didn’t you install them to My Library? Metadata included in the installed gets written during the installation.

I have never, never used “My Library”, even when I was beta-testing DS4.  I have an extensive, 250+GB Runtime Structure from before DS4, which I have no intention of dumping into my DS4Library (where I keep my Genesis Content, and a few other things specifically designed for DS4).  As I work with the older files, I create user data for them if time allows.

I did not move the Metadata files, but the other installed DS files (the Props directory, specifically) to conform with the older Topfolder>Content>Props hierarchy, as opposed the current Topfolder>Props hierarchy.  Again, I’ve been doing this for a while, I just now have to remember to do it before I launch DS4.5

cridgit - 18 September 2012 04:21 AM
DaWaterRat - 17 September 2012 08:54 PM

I made sure that when I opened DS again after I did the re-installs and move the folders into the Content Directory, “Override with User Metadata” was checked on the load Metadata window.

As far as I can tell, I did everything right to make sure that my User Data stayed.

All but two files wound up having all the user categories metadata overwritten.


Again a screenshot would help, because I don’t have this option. After installing a product with metadata, next time you start DS (or if you select Content DB Maintenance \ Re-import Metadata) you’ll be asked to select which product to import (or reimport) metadata for. If you’re reimporting you should UNCHECK ALL OTHER PRODUCTS. My window has an option “User Data Overrides Product Data” but not “Override with User Metadata”.

Aha!  I think this is where I made my mistake.  I read “User Data Overrides Product Data” as “Override with User Metadata.”  That is, if I re-installed an older product that I had created User Data for, that now came with metadata, the older User Data would take precedence over the new metadata.  I still think that it should, but at least I know now where I made the mistake.

cridgit - 18 September 2012 04:21 AM
DaWaterRat - 17 September 2012 08:54 PM

However, the only thing I can think of that would be my fault as to why it didn’t work is because I deleted the Default categories Metadata… except that’s how I keep track of what I have and haven’t categorized.  My plan is to eventually only have in the Default category any new installs, and then only until I get them organized into the appropriate user defined categories.  Requiring that the jumbled mess that is the default categories to remain is just… well, sloppy, in my opinion.  (Actually the words I would use are a lot harsher than that, but as I said, I’m trying to be reasonable.  For the most part, I find the default categories useless.)


This is very unusual. In my case I always move new content out of Default (I also like to keep default clean) but even after reinstalling a product or reimporting product metadata, it will put it back in Default but never touches my own categories outside Default. You should double check whether the product has simply reappeared in Default or whether it has lost your user categorization (this would be abnormal behaviour).

I am absolutely sure that it deleted my User Data, because the folder I had been on in my Content Directory was the User Category, which was now empty (except for two files.)  So when DS 4.5 came up again, it was on that (now mostly empty) category.

I’ve replaced half of that user data, or I would post another screen shot.

Image Attachments
Export.jpg
 Signature 

DAZ Gallery * * *DA Gallery

Profile