Digital Art Zone

 
     
Radical distortion during morph or pose
Posted: 12 September 2012 03:48 PM   [ Ignore ]
Member
Avatar
Rank
Total Posts:  240
Joined  2012-08-08

Sorry if this is a redundant question. I think I’ve seen entries on the topic, but I can’t find them, now.

I’m one-month-new to DAZ Studio, using 4.5, and I don’t know what I did / may have done / didn’t do to cause this situation, but it didn’t always used to happen.

When I apply morphs to a figure, or change the pose, the figure distorts radically during the process, and reverts to normal, morphs and pose changes included, after I release the slider.

Aside from making measured adjustments problematic, because I can’t see how much change is applied until after the fact, it makes animation unusable, in that the distorted transitions are animated as well.

As an example, if I reposition a shin in any direction, the shin shrinks up like a stick while I’m moving it, then reverts immediately to its normal shape as soon as I’m done moving it. Very weird, very annoying.


Has any of the community seen / dealt with this?

Profile
 
 
Posted: 12 September 2012 03:54 PM   [ Ignore ]   [ # 1 ]
Administrator
Avatar
RankRankRankRank
Total Posts:  14335
Joined  2003-10-09

It may be the Manipulation Draw style, set in the Tool settings pane, though that usually replaces the figure with blocks. The other thing it could be, though again that doesn’t sound likely, is smoothing needing to recalculate after posing. Can you post an image showing the distortion?

 Signature 

DAZ Studio Frequently Asked Questions

Index of free DAZ Studio scripts and plugins list

Profile
 
 
Posted: 12 September 2012 03:57 PM   [ Ignore ]   [ # 2 ]
Addict
Avatar
RankRankRankRank
Total Posts:  6667
Joined  2005-08-15

It sounds like a problem with the display Draw Style.  If you go to Window > Tabs > Tool Settings with one of the manipulation tools selected find the label During Manipulation, and cahnge the Draw Style to ‘Use Current (off)’.

If that is not the problem, it may be an OpenGL issue.


Another XPost, sorry!

Profile
 
 
Posted: 12 September 2012 04:29 PM   [ Ignore ]   [ # 3 ]
Member
Avatar
Rank
Total Posts:  240
Joined  2012-08-08
Richard Haseltine - 12 September 2012 03:54 PM

The other thing it could be, though again that doesn’t sound likely, is smoothing needing to recalculate after posing. Can you post an image showing the distortion?

Thanks, Richard,

There has been a “smoothing/collision” process in each recent case, clothing items adapting to a morphed shape that I was either still morphing or trying to fine-tune a pose on.

I had thought to remove all those items, because the iteration process slows the workflow, but it seemed laborious to have to delete everything, reposition, and then reload everything, for each adjustment I was making, especially as some of the adjusting was intended to affect how the clothing looks. Again, awkward fine-tuning by guesswork.

Am I right in thinking that simply hiding the items from the scene won’t forestall the smooth/collision iteration process?

Not sure how I can get an image, since the distortion is only evident while the mouse is being used to activate the control. I’ll try freezing an animation on a frame that demonstrates the issue.

And, as you and JimmyC suggest, I’ll look at the Draw Style settings.

Thanks!

Profile
 
 
Posted: 13 September 2012 08:52 AM   [ Ignore ]   [ # 4 ]
Member
Avatar
Rank
Total Posts:  240
Joined  2012-08-08

Okay. I have an image of the problem, during and after pose execution.

First question: how does one send the image? The attachment box of the reply window says the file I have is not allowed. It’s a bmp.

Second (more of a comment): I chose a rear hip view of the male genesis figure, because the the weird distortion shows up very clearly in the glute large muscle area, but I also just read the notice about allowed images, and see that “buttocks” are not kosher. In this case that seems a trivial objection, but the distortion is visible on any other area, just not as glaringly. It shows up when morphing as well, but is more subtle; you have to see it happen, as the figure seems to tense, and shrink in the morphed area, then relaxes and expands when the mouse button is released. This tense-shrink/relax-expand process does record in animations of the figure, which is how I was able to capture the during-after images.

As I wait for instructions about how to include an image, which I did look for but didn’t find on the forum, I will redo my demonstration image to send tomorrow.

Incidentally, I did check the tool settings, and they are as JimmyC says they should be. Also, as this figure is unclothed, there were no smoothing/collision iterations to observe. The distortion is very evident just with the base Genesis male figure.

I’ll also be googling about OpenGL. I don’t practically understand what JimmyC is referring to in mentioning it as a next-step diagnostic vector.

Profile
 
 
Posted: 13 September 2012 09:08 AM   [ Ignore ]   [ # 5 ]
Addict
Avatar
RankRankRankRank
Total Posts:  6667
Joined  2005-08-15

To attach an image, I think it must be in JPG format, use the Browse button below where you type your message, find the image on your machine, then Submit Post.

OpenGL is what the viewport uses in DAZ Studio to display objects in your scene.  Your Graphics Card should tell you what versin of OpenGL it uses in Help > Troubleshooting > About Your Video Card.  Since this issue has only recently started, did you update your video card drivers?  If so, you may need to Roll Back to the previous version, or find a better driver.

Profile
 
 
Posted: 13 September 2012 09:13 AM   [ Ignore ]   [ # 6 ]
Member
Avatar
Rank
Total Posts:  240
Joined  2012-08-08

Thanks, JimmyC,

Profile
 
 
Posted: 14 September 2012 01:53 AM   [ Ignore ]   [ # 7 ]
Active Member
Avatar
RankRank
Total Posts:  480
Joined  2010-06-18

Hi nowefg…

by default the Draw Manipulation subdivision is set to Delayed and the Skin Binding is set to Optimized… this is what causes that effect that you are seeing.

In the Tool Settings pane select the Universal Manipulator

Change the Subdivision to Persistent (On) and the Skin Binding to Full

This will now change the draw for all Manipulators and morph sliders

Now when you adjust the pose or a morph the transition will be smooth and accurate, but this does use more memory and if your OGL video card is slow, it could also cause lag in the viewport.

Hope this helps… smile

Image Attachments
tool_settings.JPG
Profile
 
 
Posted: 14 September 2012 08:43 AM   [ Ignore ]   [ # 8 ]
Member
Avatar
Rank
Total Posts:  240
Joined  2012-08-08

Thank you, niccipb,

That solves the issue. Tested the new settings with pose and animation and it’s just right.

I didn’t notice lag in response times, though it was a simple scene for testing purposes. If lags do show up as scene complexity increases, I can revert to default for workflow, and use the new settings for critical pose/morph adjusts and animation.

I appreciate everyone’s thoughtful, helpful input.

Profile