Hexagon could not set registry key

soundssounds Posts: 0
edited May 2012 in Hexagon Discussion

Hi,

I just installed Hexagon but getting this error near the end of installation:
Problem running post installation step, install may not complete correctly.
Hexagon could not set registry key hkey_classes_root.hxnreg_sz
:ahhh:

Any suggestions?

Thanks later

EDIT

I got it to run but i get the popup asking for serial, i am aware they are working on that issue.
Can run hexagon if using serial posted by another member, still have to enter it every time.
Although when using certain tools in hexagon like the smooth tool, hexagon crashes.

Post edited by sounds on

Comments

  • Richard HaseltineRichard Haseltine Posts: 19,933
    edited December 1969

    Moved to the hexagon Discussion forum as it is more likely to be seen by someone who knows the answer here.

  • afreaginnameafreaginname Posts: 0
    edited May 2012

    sounds said:
    Problem running post installation step, install may not complete correctly.
    Hexagon could not set registry key hkey_classes_root.hxnreg_sz


    Not entirely sure what might be going in here.

    Under hkey_classes_root I have a ".hxn" key with a REG_SZ default value of "hxn_auto_file".

    I'm running XP pro SP3; what OS are you running? And are you installing hex with administrator rights?

    If you're running XP and want to take a chance, you can copy the following 3 lines (BETWEEN the "=====" but not including the "=====") into a text file and name the file "somename.reg":

    ======
    Windows Registry Editor Version 5.00
    [HKEY_CLASSES_ROOT\.hxn]
    @="hxn_auto_file"
    ======

    Then doubleclick the "somename.reg" icon and the reg editor will attempt to write the same ".hxn" value that I have in my registry into your registry.

    I have NO idea if that will work for you OR if it will do you any good if it does.

    Messing with the registry is never a great idea, but in this case I don't see that it would harm anything. Worst case, it will create the entry but the entry won't do anything.

    Post edited by afreaginname on
  • soundssounds Posts: 0
    edited May 2012

    Hi,

    I'm on vista home premium
    As far as i know i have admin rights, i login to my desktop.
    I had similar problems with older versions of hexagon.

    Post edited by sounds on
  • afreaginnameafreaginname Posts: 0
    edited December 1969

    sounds said:
    I'm on vista home premium


    Okay, I now strongly advise AGAINST your using the reg file I gave you only because I don't know diddly squat about the inner workings of vista.

    Worse than that, vista slams me into a brick wall before I even got off the starting line, so I'm at a complete loss.

    I do remember that one of the major complaints about vista was that it was such a control freak that you could barely even use the keyboard without it's asking you for some kind of permission to continue.

    Maybe you should upgrade to XP... (Please forgive me...I just couldn't resist... :-) That used to be the de facto not-so-tongue-in-cheek response we geeks would give to vista users back when it first came out. The humor laid in the fact that MS was calling vista an upgrade from XP)

    Seriously though, hopefully there's a vista expert floating around here somewhere that could give you some hints.

  • soundssounds Posts: 0
    edited May 2012

    Too late i tried your reg file which entered it fine to registry
    But still the same errors when installing hexagon, I can run it but
    that popup asking for serial is annoying when this is advertised as free.
    The installer is not installing properly so i have to keep removing hexagon manually
    So i am probably leaving files behind somewhere every time dunno.

    It crashes anyway if i use some utilities like smooth tool, might be issue with my graphics card too
    Coz viewing a model gets real slugish when moving around it after adding any extra details.

    I haven't really had much probs with vista, have it since 2007 when i got this laptop,
    Recently i have one issue with a security update, microsoft support recommended i do a clean install.
    I don't have 100 bucks right now to do that so i've been looking for a solution since.

    Thanks later

    Post edited by sounds on
Sign In or Register to comment.
Rocket Fuel