Digital Art Zone

 
     
Looping Material Glitch
Posted: 30 August 2012 02:23 PM   [ Ignore ]
New Member
Avatar
Total Posts:  13
Joined  0

Hi guys,

I think I’ve discovered a bit of a bug with the material editor, and how it handles “Make Repeat.”  Here’s the skinny:

I was trying to use the Ambience channel coupled with Make Repeat in the AML to simulate a strobe light going off.  At Frame 0, Ambience was at 100%, then at Frame 1, at 0%; and finally, at Frame 14, another key frame for 0%.  The idea was to have the strobe light flash for one frame every 15 frames.

Sounds simple right?...well not so fast.  The light came on at Frame 0 and went off at Frame 1, but at Frame 15 (the first loop point), it did nothing!...I worked with it, and then finally got it to work by doing this:

Frame 0:  Ambience at 0%
Frame 1:  Ambience at 100%
Frame 2:  Ambience at 0%
Frame 15:  Ambience at 0%

Throw in Make Repeat, and this time it works exactly the way it’s supposed to.  Weird…anybody else run across this?

Profile
 
 
Posted: 30 August 2012 07:51 PM   [ Ignore ]   [ # 1 ]
Member
Avatar
Rank
Total Posts:  240
Joined  2005-09-28
tnpir4000 - 30 August 2012 02:23 PM

Hi guys,

I think I’ve discovered a bit of a bug with the material editor, and how it handles “Make Repeat.”

Ah yes, this one. I think the term you might be after is ‘rediscovered’ wink

This is a problem with Matlab animation generally: animation is a tad ‘deaf’, especially with Auto key on for some reason.

I’m sure your solve works, but it was a bit like stopping the pain you feel in your head by stepping on a cactus: you’re distracted from the original pain, but you haven’t addressed the former pain as such.

Matlab parameters have trouble sticking, especially with Auto Key on. When doing Matlab loops, take Auto key off and manually set each keyframe by holding down the “+” key button and selecting the specific parameter in the drop-down menu.

When you’ve finished, go back to the beginning and check every keyframe you’ve set. You might find that some have remained defiantly unchanged.

I run into this problem a lot when animating 2-keyframe material animations, like water traveling on a plane: one keyframe at the start of the animation, one at the finish. I’m now in the habit of turning Auto Key off, setting the first keyframe, then setting the last keyframe, then going BACK to the first keyframe to RE-set its parameters, which have often magically changed into the LAST keyframe settings.

I’ve noticed material animation has been dodgy since Bryce 5.5, but it may have been earlier than that: I’m not sure.

 Signature 

Oroboros Presents… KEY-FLAME: Bryce Animation Tutorials

Profile