DAZ Studio 4.5 SDK Production Release (4.5.0.114)

rbtwhizrbtwhiz Posts: 486

The DAZ Studio 4.5 SDK* is now available to the general public.

This IS the Production Release of the DAZ Studio 4.5 SDK. Plugins can be built against this version and submitted for serial number prefix assignment, building of installers, smoke testing, public beta and final versions. Any plugins built against this Production Release CAN be published in the store for purchase. Plugins developed using this SDK require a binary compatible version of DAZ Studio 4.5 Pro. Earlier versions of DAZ Studio 4.x are NOT binary compatible with this SDK. All plugins will need to be compiled against the Production Release of DAZ Studio 4.5, using this release of the DAZ Studio 4.5 SDK.

*The SDK is required for building compiled plugins for DAZ Studio. It is NOT required to author DAZ Script files. For more information on DAZ Script please see this post.

-Rob

Post edited by rbtwhiz on

Comments

  • Mage 13X13Mage 13X13 Posts: 233
    edited December 1969

    I would like to know what the requirements are for the machine this is to be installed on. Also a question I have is whether the production release of DAZ Studio 4.7 Pro is a binary compatible version?

    I have been looking at the DAZ Studio 4.5 SDK in the store and have read the included text in the promo several times. I am thinking about getting it and seeing if I can do something with it. As the promo indicates that basic instructional documentation is included, it sounds like it might be something I can use.

    I await your reply.

  • dtammdtamm Posts: 120
    edited December 1969

    I would like to know what the requirements are for the machine this is to be installed on. Also a question I have is whether the production release of DAZ Studio 4.7 Pro is a binary compatible version?

    I have been looking at the DAZ Studio 4.5 SDK in the store and have read the included text in the promo several times. I am thinking about getting it and seeing if I can do something with it. As the promo indicates that basic instructional documentation is included, it sounds like it might be something I can use.

    I await your reply.

    You can install it on any Windows or Mac machine. To use it on Windows you will need Visual Studio 2010. On Mac, XCode3 is recommended but some people are using XCode4 or 5. The requirements to run DAZ Studio are also relevant.

  • Mage 13X13Mage 13X13 Posts: 233
    edited December 1969

    dtamm said:
    I would like to know what the requirements are for the machine this is to be installed on. Also a question I have is whether the production release of DAZ Studio 4.7 Pro is a binary compatible version?

    I have been looking at the DAZ Studio 4.5 SDK in the store and have read the included text in the promo several times. I am thinking about getting it and seeing if I can do something with it. As the promo indicates that basic instructional documentation is included, it sounds like it might be something I can use.

    I await your reply.

    You can install it on any Windows or Mac machine. To use it on Windows you will need Visual Studio 2010. On Mac, XCode3 is recommended but some people are using XCode4 or 5. The requirements to run DAZ Studio are also relevant.


    OK, I looked into Visual Studio 2010 and have found that it costs far more than I can afford. For that reason, I must decide against getting the DAZ Studio 4.5 SDK .
    Thank you for your reply and the info you have provided. You have given me the means to make a wise choice, though it is not what I was hoping for.

  • rbtwhizrbtwhiz Posts: 486
    edited December 1969

    Visual Studio Express

    Visual C++ 2010 Express (limited to 32-bit compiler)

    -Rob

  • Takeo.KenseiTakeo.Kensei Posts: 935
    edited December 1969

    I have a question regarding the SDK : is there a possibility to get the SDK documentation as qch file for intergration inside QTCreator?

Sign In or Register to comment.
Rocket Fuel