Digital Art Zone

 
     
Problem with shaders on imported obj. files…
Posted: 13 August 2012 08:35 AM   [ Ignore ]
Member
Rank
Total Posts:  42
Joined  2003-10-09

Good Morning,

I have created some objects in Sketchup and exported them as obj files.  When I import them into DS4 Pro, they come in perfectly (except for having to resize).  The main problem is that when I apply a texture or shader, it doesn’t seem to work properly.  The Sketchup object’s surface changes to a pale imitation of the base color of the shader applied, but does not show any detail, bump, or displacement even though the settings and maps in the Surface tab show they are all correct.  As an experiment, I imported a simple cube obj and then created one directly in DS.  I applied the same shader to both and made sure that the Surface settings were exactly the same.  The DS cube looked great, but the obj cube turned light gray (the base color of the shader) but did nothing else. Even rendered, the image didn’t change.  Can anybody please tell me what I’m missing or doing wrong?  I’m trying to post a screen capture, but my system isn’t cooperating this morning.

I am using DS 4.0.3.47 Pro.

Thanks…

Profile
 
 
Posted: 13 August 2012 08:48 AM   [ Ignore ]   [ # 1 ]
Active Member
Avatar
RankRank
Total Posts:  271
Joined  2005-08-20

Do UV map your objects.

 Signature 

*Sigh* Window->Tabs->Tool Settings->Draw Style->Manipulation: Off
Yeah. It’s like that.

Profile
 
 
Posted: 13 August 2012 08:49 AM   [ Ignore ]   [ # 2 ]
Active Member
Avatar
RankRank
Total Posts:  939
Joined  2007-01-04

You need to make sure that what you export from Sketchup has been UV mapped, otherwise all you get is the color from the top left pixel in your texture.

 Signature 

**shuffles of with a new headache** tongue wink

Profile
 
 
Posted: 13 August 2012 09:12 AM   [ Ignore ]   [ # 3 ]
Member
Rank
Total Posts:  42
Joined  2003-10-09

Thanks guys,

I am currently slapping myself on the forehead and thinking “how could I have missed that?”  Too many hours, too much caffine, and too much time away from 3d I guess.

Thanks again!

Profile