Digital Art Zone

 
     
Particles Simulated
Posted: 30 July 2012 12:33 PM   [ Ignore ]
Active Member
Avatar
RankRank
Total Posts:  631
Joined  2010-09-22

I have half a dozen particle emitters in my scene. To speed up the rendering to check the Movements I have turned OFF visibility in the assembly room BUT in the render room they are still SIMULATING them as they render. WTF?

Profile
 
 
Posted: 30 July 2012 02:08 PM   [ Ignore ]   [ # 1 ]
Addict
Avatar
RankRankRankRank
Total Posts:  5456
Joined  2006-08-27

They’ll do that.


Is it possible to go to the beginning of the animation and turn the particles emitted to zero, or a really low number?

 Signature 

I find it somewhat liberating not to be encumbered by accuracy.

Profile
 
 
Posted: 04 August 2012 07:05 PM   [ Ignore ]   [ # 2 ]
Power Member
Avatar
RankRankRank
Total Posts:  1059
Joined  2007-10-15
RichardChaos - 30 July 2012 12:33 PM

I have half a dozen particle emitters in my scene. To speed up the rendering to check the Movements I have turned OFF visibility in the assembly room BUT in the render room they are still SIMULATING them as they render. WTF?

Come on, dude, seriously…do you take even 5 seconds to research a solution before posting? I know nothing about particle emitters, and it took me all of 10 seconds to figure out there is an “Emitter ON Now” checkbox that allows you to turn off/keyframe the emitters when you want them off.

Profile
 
 
Posted: 04 August 2012 07:59 PM   [ Ignore ]   [ # 3 ]
Addict
Avatar
RankRankRankRank
Total Posts:  7680
Joined  2009-07-13

hitting esc during the render will stop the particle calculation
(found that out by accident! & no JoeM it is not in the manual tongue rolleye )

 Signature 

WARNING do not click tongue rolleye what video horrors will be seen if you do cannot be unseen.
my render thread
        never forget
A Drows Walk
Jaderail is at it again

Profile
 
 
Posted: 06 August 2012 10:49 AM   [ Ignore ]   [ # 4 ]
New Member
Total Posts:  3
Joined  2008-10-08
JoeMamma2000 - 04 August 2012 07:05 PM
RichardChaos - 30 July 2012 12:33 PM

I have half a dozen particle emitters in my scene. To speed up the rendering to check the Movements I have turned OFF visibility in the assembly room BUT in the render room they are still SIMULATING them as they render. WTF?

Come on, dude, seriously…do you take even 5 seconds to research a solution before posting? I know nothing about particle emitters, and it took me all of 10 seconds to figure out there is an “Emitter ON Now” checkbox that allows you to turn off/keyframe the emitters when you want them off.

Turning the emitter off stops particles from being rendered, but it still grinds away simulating particles wether they are rendered or not, increasing render times to many hours on anims. Making the emitter invisible does the same thing. Anyone know how to make the damn thing stop simulating particles (even when not rendering them) when you dont want it to?

Profile
 
 
Posted: 06 August 2012 03:14 PM   [ Ignore ]   [ # 5 ]
Member
Avatar
Rank
Total Posts:  111
Joined  0

evilproducer has the best answer I could find during experimenting. You can not make zero particles per second, but you can make one. This speeds things up enormously.

Profile
 
 
Posted: 06 August 2012 04:16 PM   [ Ignore ]   [ # 6 ]
New Member
Total Posts:  3
Joined  2008-10-08

Thats an ok workaround but doesnt help on the final render. If I have a 20sec anim with only 10 sec of particles showing the emitter insists on simulating particles even when they dont show, even though I have turned it off and made it invisible. And worse, it gets exponentially slower as the render frames increase so that the last frames bring my dual-quad to its knees.  3/4 of the render time is in the last 1/4 of the anim simulating particles even if the emitter its turned off and the particles arent visible.
I have watched a 12hr render spend about 9hr of it simulating particles that were out of the frame. An insane waste of processing time that ought to be avoidable.

Profile
 
 
Posted: 07 August 2012 04:36 PM   [ Ignore ]   [ # 7 ]
Addict
Avatar
RankRankRankRank
Total Posts:  5456
Joined  2006-08-27

Turning off the emitter at a set time stops the emitter from generating more particles only. The particle emitter still calculates what’s happening to the particles in the scene if they’re still doing something. If you have your emitter stop at two seconds, but have the particle life set at 10 seconds, Carrara still calculates what the particles are doing until they “die.” The more Carrara has to calculate, the longer it takes, especially if you have the create new particles on collision option enabled. I just tested this.


You can speed up scene set-up if you check the “No Calculation in 3D View” box. It will still calculate at render time though.

 Signature 

I find it somewhat liberating not to be encumbered by accuracy.

Profile
 
 
Posted: 09 August 2012 09:25 AM   [ Ignore ]   [ # 8 ]
New Member
Total Posts:  3
Joined  2008-10-08

Hey thanks, that makes sense. I just couldnt figure that out. Knowing the emitter keeps calculating old particles I now know to keep any future particles in small quantities and short lived to shorten the render times. I assume using “Die on impact” also would also shorten the lives of old particles as well. Unless it only works when collisions are enabled.

Yes, I already discovered the “No calculations in 3d” box. That was a big day.

I appreciate the help.
Im a longtime user (have a Ray Dream manual on my shelf), but I guess I should check out this forum more often.

Profile
 
 
Posted: 11 August 2012 05:34 PM   [ Ignore ]   [ # 9 ]
Addict
Avatar
RankRankRankRank
Total Posts:  5456
Joined  2006-08-27

Old Raydream vet myself. It’s amazing sometimes how much has changed and how much has stayed the same. Check out the DOF settings or some of the Spline modeler for a blast from the past!

 Signature 

I find it somewhat liberating not to be encumbered by accuracy.

Profile