DAZ Studio 4.5.0.90 SDK Release Candidate 3

rbtwhizrbtwhiz Posts: 436
edited August 2012 in DAZ SDK Developer Discussion

The DAZ Studio 4.5 SDK Release Candidate 3* is now available for the general public.

This is NOT the General Release of the DAZ Studio 4.5 SDK. Plugins can be built against this version and submitted for serial number prefix assignment, building of installers, smoke testing and public beta, but final versions of any plugins built against this Release Candidate will NOT be published in the store for purchase. Plugins developed using this SDK require a binary compatible version of the DAZ Studio 4.5 Release Candidate 3. Earlier versions of DAZ Studio 4.x are NOT binary compatible with this SDK Release Candidate. All plugins will need to be compiled against the Production Release of DAZ Studio 4.5, using the General Release of the DAZ Studio 4.5 SDK, once it becomes available.

*The SDK is required for building compiled plugins for DAZ Studio. It is NOT required to author DAZ Script files. For more information on DAZ Script please see this post.

NOTE: When resetting your downloads... The link for the download should update to reflect the new version, but the product they are listed as being part of will continue to display the name of the product at the time it was added to your account. For instance, the download link should indicate that it is "DAZ Studio 4.5.0.90 SDK RC3 - zip - pc", but the product will remain "DAZ Studio 4.5 SDK Release Candidate" or "DAZ Studio 4.5 SDK Release Candidate 2" depending on the name of the product at the time it was "purchased". Only newly "purchased" orders will indicate "DAZ Studio 4.5 SDK Release Candidate 3" as the product name in your Itemized Order History and/or My Downloadable Products.

-Rob

Post edited by rbtwhiz on

Comments

  • pcicconepciccone Posts: 434
    edited December 1969

    Hello.

    Can you tell us if this is the last SDK update that we will need? If there is another update coming to the SDK I'd like to wait until Studio is not breaking backward compatibility.

    Thanks in advance..

  • rbtwhizrbtwhiz Posts: 436
    edited December 1969

    Um... read the post you are responding to again?

    rbtwhiz said:
    This is NOT the General Release of the DAZ Studio 4.5 SDK. Plugins can be built against this version and submitted for serial number prefix assignment, building of installers, smoke testing and public beta, but final versions of any plugins built against this Release Candidate will NOT be published in the store for purchase. Plugins developed using this SDK require a binary compatible version of the DAZ Studio 4.5 Release Candidate 3. Earlier versions of DAZ Studio 4.x are NOT binary compatible with this SDK Release Candidate. All plugins will need to be compiled against the Production Release of DAZ Studio 4.5, using the General Release of the DAZ Studio 4.5 SDK, once it becomes available.

    -Rob

  • rbtwhizrbtwhiz Posts: 436
    edited December 1969

    Please see the recent post regarding the DAZ Studio 4.5 SDK Production Release.

    -Rob

Sign In or Register to comment.
Rocket Fuel