Digital Art Zone

 
     
Ripped up and shredded
Posted: 19 April 2014 09:00 PM   [ Ignore ]
Member
Avatar
Rank
Total Posts:  95
Joined  2004-06-24

I made an object (same as in my last post) and it is a group of 4 objects.  This object is a hood.  I didn’t want to weld it in Hexagon because when I did it created a single new object ‘Form’ and I lost my uvmapping and material designation.  After exporting it from Hexagon as an object (consisting of 4 objects) I took it into UVmapper.

In UVmapper I selected by material and assigned to groups.  I exported it, rigged it but when I try to morph it, it pulls and rips apart at the group edges.  Example is neck polys pull away from the chest polys.

So it needs to be welded somehow.  In UVmapper I went to Tools/weld vertices but I get an error message ‘This obj contains no normal vectors’.

What does that mean?  Is it something to do with exporting out of Hexagon?  What am I doing wrong?

Profile
 
 
Posted: 20 April 2014 01:49 AM   [ Ignore ]   [ # 1 ]
Power Member
Avatar
RankRankRank
Total Posts:  1286
Joined  2008-01-01

Did you rig in DS and bring it into Hex via the bridge or as an .obj?

Profile
 
 
Posted: 20 April 2014 02:22 AM   [ Ignore ]   [ # 2 ]
Member
Avatar
Rank
Total Posts:  188
Joined  2003-10-09

Something that might work on this is if you import it to uvmapper and then save out the uvs data for the original figure. Then weld a new object and import that one to uvmapper and then just import back the uvdata again to the new one. This has helpted me a couple of times in the past.

 Signature 

Renderosity. http://www.renderosity.com/mod/bcs/index.php?vendor=29771

Rendo Freebies. http://www.renderosity.com/mod/freestuff/index.php?username=ghostman

RDNA http://www.runtimedna.com/Ghostman/

Profile
 
 
Posted: 20 April 2014 07:12 AM   [ Ignore ]   [ # 3 ]
Member
Avatar
Rank
Total Posts:  95
Joined  2004-06-24

Hi, I modeled the item in Hexagon, exported as an object, then rigged and jointed it in DS.  In Hexagon I have four objects (chest, neck, droop1 and droop2) that make up the hood object.  I have two material zones per separate object (the stitches and the hood cloth).  I brought the hood into UVmapper and selected by materials then assigned them to separate groups.

It conforms perfectly and if it wasn’t for the ripping when morphing I’d be happily morphing along.

This aspect of the conforming clothing process is completely confusing me.  I was doing this following videos I bought and the author uses a different program and simply selects polygons and then uses a group command.

If I bring V4 into my model program and click on her face, it is a separate group.  Her neck is separate, her forearm, etc.  She doesn’t rip apart.

What I thought might work was to weld the entire object together, then create shading domains, then select the shading domains in UVmapper and assign to groups.  The problem with that route is that trying to select my stitches on the hood would be a long and tedious (and don’t make a mistake) process.  But if you think it might work I would try it.

And Ghostman, if I could get that uv mapping switch to work then doing both might just be the answer to my problem.

Thank you Roygee and Ghostman

Profile
 
 
Posted: 20 April 2014 12:38 PM   [ Ignore ]   [ # 4 ]
Power Member
Avatar
RankRankRank
Total Posts:  1286
Joined  2008-01-01

Why I asked whether you had imported it to Hex as a .obj - once you assign groups in another app and bring it back into Hex, it reads the groups as separate meshes.  The best bet is to bring it in over the bridge, then it reads it the same as it is in Studio - as a single item.

If for some reason you don’t want to use the bridge, you can export from Studio as an .obj and uncheck the option to write groups - then Hex won’t split it up.

Before DS4, the common method of grouping for rigging was to do it the way you did - pretty tedious and too easy to get squint-eyed make mistakes.  DS 4.6 has a group editor, which is also pretty tedious and repetitive, but a lot better than the old method.

Profile
 
 
Posted: 20 April 2014 12:52 PM   [ Ignore ]   [ # 5 ]
Member
Avatar
Rank
Total Posts:  95
Joined  2004-06-24

Well, I learned to rig in DS 3.1 so that’s what I used.  Thank you for the info on DS4.6 and bringing objects in and out of Hex and DS.  I did not know that.

I’m going to have to try a few things here.  First I’ll try welding the entire object into one form then select shading domains and group it in UVmapper.  I have not tried it that way because of all my stitches.  If that works then I’m good to go.  I can do what Ghostman suggests for the uvmapping.

I had not brought my object back into Hexagon to morph until I tried morphing it first in Blacksmith3D.  That’s where I first saw the ripping.  I then tried it in Hexagon and it happened there too.

Profile